1. dotFIVE's Avatar
    I recently discovered a new issue with my iPod Touch after upgrading it to 4.1 (jailbroken). Whenever it is plugged in somewhere (dock, car radio transmitter) and I go to play a song, it won't play. I tap the song and the song will get highlighted but it will get stuck there. Afterward the music app is completely unresponsive; the problem repeats even after conducting a respring, reboot and hard reset.

    Music plays fine in headphones though.
    The only things I have installed are quick lock and sbsettings (bundled with activator). I do also have multitasking and home screen wallpaper enabled.

    I never had this problem on 4.0. Any ideas on how to fix? Thanks.
    2010-10-14 10:26 AM
  2. Hpwill's Avatar
    What did you jailbreak it with
    2010-10-15 12:46 PM
  3. dotFIVE's Avatar
    Found out the culprit was SBSettings (not sure if it's SBSettings itself or if it's one of the apps, like Activator, that are bundled with it). Even after uninstalling it, the music still wouldn't play while on the dock. I had to restore it to get it back to normal.

    Quite annoying, really.. I depend on SBSettings because I have a broken lock button.
    2010-10-15 10:19 PM
  4. iJamie29's Avatar
    Download QuickLock from cydia. And remove SBSettings... This should fix it.
    2010-10-17 07:05 PM
  5. dotFIVE's Avatar
    I do have Quicklock. I need SBSettings for closing apps, turning off, rebooting, and all that. Plus it's just that handy. Oh well I guess I'll just wait.
    2010-10-17 08:12 PM
  6. wayne247's Avatar
    Got the same problem on my iPhone 3G with iOS 4.1. As soon as I install sbsettings, no dock audio anymore. It just doesn't detect it, it keeps playing audio in the internal speaker.
    2010-10-18 05:14 AM
  7. teachertwish's Avatar
    Anyone tried re-JBing with Redsn0w and make it work?
    2010-10-28 08:15 AM
  8. BenderRodriguez's Avatar
    I used limera1n.com to jailbreak

    Try installing "noAccessorySplash" from cydia, I have sbsettings and mine plays through my stereo(docked) and not my iPhone, it's also a very nice tweak, 4.1 3GS
    2010-10-28 08:43 AM
  9. wayne247's Avatar
    Turns out it's the jailbreak itself. I tried numerous attempts with redsn0w, I've tried with PwnageTools 4.0.1 with the bundle for firmware 4.1, and recently I've tried with the new PwnageTools 4.1. It always fails with the same problems. As soon as MobileSubstrate is installed (by either SbSettings, LockInfo, Activator, etc), the problems begin.

    Solution: Use Sn0wbreeze 2.0.1 to create the custom, jailbroken firmware.

    Note: In my case, I also needed iREB because iTunes 10 really doesn't like my custom firmwares, either PwnageTools or Sn0wbreeze made.

    Note to the note: iREB should display a "you can now restore the firmware" on the iPhone 3G when it's ready. In my case, it didn't, but it worked anyway.

    Been on 4.1 for a week and it's quite solid.
    2010-10-28 04:06 PM
LINK TO POST COPIED TO CLIPBOARD