1. Speedymofo's Avatar
    Guys i've been running Whatsapp on this iPod for at least a year without problems across a couple of jailbreaks, but last night I foolishly upgraded to 5.1 and since jail breaking (tethered) I can't get Whatsapp to work.

    I've tried all the versions in ********** and it either says it can't connect to Whatsapps servers OR it says Whatsapp won't work on this device

    Any ideas fellas? Be real grateful for any suggestions
    2012-04-13 11:59 PM
  2. H4CK3R's Avatar
    Try seeing if this will work: Go to /var/System/Library/CoreServices and then scroll down to SystemVersion.plist Open that up and you will se some code in their. Here's what you need to change:

    Code:
    <key>ProductBuildVersion</key>
    <string>9A405</string>   <--- Yours will say something else, change it to 9A405.
    
    There will be more code here (It's not important. This next part is)
    
    <key>ProductVersion</key>
    <string>5.0.1</string> <--- Yours will say 5.1 change it to 5.0.1
    If this does not work, it isn't compatible with 5.1
    2012-04-14 01:42 AM
  3. Speedymofo's Avatar
    Hey bud, thanks for the reply.
    You were right, those lines of code were different so I changed them. It's still not working :/

    I wonder if this is a problem anyone else is having? I've tried searching but I haven't come up with anything.
    Appreciate the suggestions mate!!
    2012-04-14 09:35 PM
  4. H4CK3R's Avatar
    No problem In the app you're trying to make compatible, look in the filesystem and find info.plist, see if you can find the version stuff in it. I've done it before with a few apps. If that doesn't work I'm afraid you're gonna have to wait til they update it for 5.1
    2012-04-15 12:13 AM
LINK TO POST COPIED TO CLIPBOARD