1. Keiththewolf's Avatar
    Alright...here's what what happened. I was using my 4th gen iPod Touch running jail broken 5.1.1, and launched the Speedtest app (which came form the appstore), which seemed to crash. But when it crashed to the home screen, all my appstore apps, and the folders they were in were gone! Now... a app from Cydia called AppInfo says that all the apps and thier data are still there...and they are! However, they do not show up on the home screen, they don't show up in search, and in iTunes, it doesn't show that any of the space has been taken by applications. That space is now categorized under "Other".

    I would do a restore, and re-jailbreak, however something unfortunate a few weeks happened: the sleep button on my iPod broke. I CANNOT do a restore, or else I won't be able to re-jailbreak my iPod Touch, and then I wouldn't be able to use Activator, and have the ability to use my home button presses to replace the broken button.

    Someone please help...I'm at a lost of what the *bleep* happened. XP

    EDIT: After looking for solutions, I've tried a few things, but nothing has worked. To streamline the process, I'll give everyone more info.

    I've deleted the /var/mobile/Library/Preferences/com.apple.SpringBoard.plist file, and rebooted.
    I've checked that none of the icons are hidden in SBSettings.
    According to Poof, all the apps should be showing
    Last edited by Keiththewolf; 2012-09-26 at 01:49 AM. Reason: Added more info
    2012-09-26 12:59 AM
  2. Keiththewolf's Avatar
    I've fixed the problem! I deleted folder of the app that crashed in the Applications folder, and all of my apps came back! Although they had white icons, so i just needed to use 'uicache', and that fixed that. Hope this helps anyone else who encounters this problem!
    Last edited by Keiththewolf; 2012-09-27 at 12:38 AM.
    2012-09-26 08:03 PM