1. iphonedave's Avatar
    Hi all ive a problem with my Ipod Touch 2G, it was jail broken on firmware 3.1.2 or something like that. My son wanted to start to use it so i thought id update it. i tried to return it to a non jail broken state, by updating it the next offical Apple firmware. Now its stuck on the image with a charge cable and Itunes at the top.. and help pls ..

    thanks

    Dave
    2013-02-05 09:13 PM
  2. H4CK3R's Avatar
    Never just update over a jailbreak. Always restore, otherwise, you'll probably encounter issues with your device.

    Go into iTunes, select the "Restore" option (if you've already backed up your data) and let iTunes do it's thing. When restoring, it will automatically put you onto the latest iOS firmware for your device. From there, you can go about restoring your data to the device.

    Hope this helps.
    2013-02-05 10:41 PM
  3. iphonedave's Avatar
    still not working ... no back up found ? seems to be in a recovery loop.. have tiny umbrella but not sure how this works ?
    2013-02-05 10:47 PM
LINK TO POST COPIED TO CLIPBOARD