1. Funked's Avatar
    Hi guys. I bought a OCZ Agility 3 SSD for my MacBook Pro (early 2011). I replaced my optic drive with an optibay, and put my old 500GB HDD in there, and put the SSD in the normal hard drive bay. Installation of everything went fine (though was a tedious job putting those tiny screws back in!). The SSD shows up on my desktop when I boot to the old HDD, I have formatted and partitioned it ready to go - so I don't think the problem I'm having is hardware related, it all seems to be working.

    I was going to make a bootable USB key using Apple's Lion Recovery HD app. When I choose to boot from it when holding the option key at startup, it goes into the recovery screen. It says it needs to verify the download and installation with Apple (even though I don't want to download it, it should be on the USB). When I click verify, sometimes it says something like "Could not get the information for your system. Contact Apple Support." so I can't go any further. Though sometimes it lets me past that screen, choose the SSD to install Lion, and it appears to work. It has a countdown saying it'll take a few hours, but stops after 10 mins or so and says "Can't download the additional components to install Mac OS X". Keeping in mind, this is when I have selected the USB from the boot menu. I have had my ethernet cable in while trying this though. So I went to a friends house to use his wifi to see if that worked, though the same problems continued. (I have also tried the "Recovery HD" partition on the HDD itself, not USB.) I have tried to force it into internet recovery mode by holding command + option + r. With ethernet, this didn't work since it kept asking for a wifi connection. So I tried it on wifi, and it had a countdown of 20 minutes and seemed to complete the download, but then restarted and I was back at the Lion Recovery screen.

    I've almost gave up hope, I don't want to call Apple because it'll cost a bomb on a mobile phone. I've searched google for hours and came across many tips on how to fix this, but none have worked. I hope someone can help me! Do you think its because the HDD is in the optibay? I put the SSD in the old HDD bay to utilise the 6Gbps speeds, though should I put it in the optibay and try to install Lion on it? Thanks!

    iPad 2 16GB Wifi iOS 5.0.1 - Absinthe
    iPhone 4S 16GB iOS 5.0.1 - Absinthe
    2012-05-05 02:09 AM
  2. Scoops98's Avatar
    You may need to download the Lion installer app from somewhere and install onto your SSD from your HDD. The issue seems to be with Apple allowing you to download the installer, either form the USB recovery drive of the internal. All models after July 19, 2011 can download without requiring an Apple ID. Didi you Mac come with Lion preinstalled or did you have to do the redemption code?

    I have a late 2011 MacBook Pro with the same setup. Good call using your main bay for the SSD. Late 2011 has SATA III in both bays. I'm not what is causing the download issues though.
    Until the next time… And if I help you out, give me a "Thanks!" Thanks!
    2012-05-05 08:31 AM