User Tag List

  1. Cody Overcash's Avatar
    Questions and comments for the guide http://www.modmyi.com/wiki/index.php...g_iPHUC_iPhone

    Ask away.
    2007-08-03 07:36 AM
  2. fdot's Avatar
    what about jailbreak>? the new way to do it
    2007-08-03 06:25 PM
  3. Cody Overcash's Avatar
    there isnt
    2007-08-03 06:55 PM
  4. CyberGreg's Avatar
    Okay cool! I got it all installed and in looking at THIS PAGE once I complete all this I won't need to use jailbreak anymore???
    2007-08-03 07:09 PM
  5. Cody Overcash's Avatar
    only one way to find out,
    2007-08-03 07:56 PM
  6. CyberGreg's Avatar
    only one way to find out,
    bastard

    j/k


    Got as far as this step
    getfile fstab fstab
    and got this error
    shell: No such command 'getfile'
    Last edited by CyberGreg; 2007-08-03 at 08:47 PM.
    2007-08-03 08:26 PM
  7. Cody Overcash's Avatar
    yeah if getfile command isnt included in the latest release of iphuc then you gotta use jailbreak still. those commands on that page are just what jailbreak does
    2007-08-03 08:57 PM
  8. CyberGreg's Avatar
    I typed exit and was able to use the getfile but was only able to get fstab. the ditto did not um well ditto the Services.plist even though it exited without error.

    Not sure what to do now.

    Edit: My Phone still syncs with iTunes so nothing broke :-)
    Last edited by CyberGreg; 2007-08-03 at 09:30 PM.
    2007-08-03 09:19 PM
  9. Kyle Matthews's Avatar
    I'm still working on my guide. Ran into a bunch of real-life things I had to get done. So not to worry, it will be ready soon enough.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-08-03 10:25 PM
  10. Cody Overcash's Avatar
    greg they updated it with getfile, reinstall from the svn
    2007-08-03 10:32 PM
  11. CyberGreg's Avatar
    cool - I'll run through it again and post my results, hopefully not an iBrick

    Edit: ran the svn and just came back with checked 8 or something
    Edit2: I removed the iPhone folder and downloaded and compiled it again. I'll post back
    Last edited by CyberGreg; 2007-08-03 at 11:19 PM.
    2007-08-03 10:43 PM
  12. Cody Overcash's Avatar
    p_f is having problesm as well, I'll take a look along with ya guys once i get home from the office
    2007-08-03 11:33 PM
  13. CyberGreg's Avatar
    Okay looks to me like this is where I'm getting hung up:

    FileSystemCheck /dev/disk0s2 = This repairs minor header damage
    mount /dev/disk0s1 /mnt1 = This returns a 6 and on the phone it says "Invalid argument"
    mount /dev/disk0s2 /mnt2 = This returns a 0 and on the phone it says "the date and then launchd[1]: mkdir("/var/tmp/launchd"): No such file or directory"

    ditto /mnt1/etc/fstab /mnt2/root/Media/fstab = This returns a 6 and just says "Ditto...done." on the phone
    ditto /mnt1/System/Library/Lockdown/Services.plist /mnt2/root/Media/Services.plist = This also returns a 6 and "Ditto...done."

    A return code of 6 is an error????

    Edit: Oh and when I do ls the fstab file is there but no Services.plist which would confirm that 6 means the mount command did not work, maybe....
    Last edited by CyberGreg; 2007-08-04 at 12:44 AM.
    2007-08-04 12:41 AM
  14. poktrokt29's Avatar
    I've installed everything needed for the IPHUC, and ran iactivator to jailbreak the phone. and i'm at the prompt (iPHUC) /: when i try to change the directory to replace i icons, i get cd: No such file or directory '/Applications/DemoApp.app'

    i have nothing itunes running, i'm on a 17 mac book pro, 2.33 , with all updates

    any ideas?

    thanks in advance

    pattyshaw
    2007-08-05 03:27 AM
  15. CyberGreg's Avatar
    I've installed everything needed for the IPHUC, and ran iactivator to jailbreak the phone. and i'm at the prompt (iPHUC) /: when i try to change the directory to replace i icons, i get cd: No such file or directory '/Applications/DemoApp.app'

    i have nothing itunes running, i'm on a 17 mac book pro, 2.33 , with all updates

    any ideas?

    thanks in advance

    pattyshaw
    Are you in iPHUC Restore mode or do you just have the iPHUC prompt?
    2007-08-05 03:37 AM
  16. Cody Overcash's Avatar
    I've installed everything needed for the IPHUC, and ran iactivator to jailbreak the phone. and i'm at the prompt (iPHUC) /: when i try to change the directory to replace i icons, i get cd: No such file or directory '/Applications/DemoApp.app'

    i have nothing itunes running, i'm on a 17 mac book pro, 2.33 , with all updates

    any ideas?

    thanks in advance

    pattyshaw
    http://www.modmyi.com/wiki/index.php...ne#Using_IPHUC
    http://www.modmyi.com/wiki/index.php...HUC_Usage_Note
    2007-08-05 04:06 AM
  17. poktrokt29's Avatar
    i believe it was just at the prompt
    i restarted my phone in restore mode
    as the directions said

    as for the actuall state of the phone, it went from
    the connect to itunes screen to the apple logo, to
    the slide to unlock screen

    i might just have to retry everything, before
    the update i had this problem and i tried again
    and it worked, its just late and people are over
    so i'll try again in the morning
    2007-08-05 05:36 AM
  18. Cody Overcash's Avatar
    if you still have a problems in then go into iphuc type in "ls" and enter and see what the output is, i bet your problem is either an unsuccessful jailbreak or this though
    http://www.modmyi.com/wiki/index.php...HUC_Usage_Note
    2007-08-05 05:38 AM
  19. 0solvent's Avatar
    I've successfully mod'd my phone before the update, threw down gunmetal2 skin, ran the update, restored....
    To re-brake this time I decided to use iActivate, it seemed to go ok; then I ran iphuc and ls returned only limited directory structure indicating a failed jailbreak...I've seen this before the first time so I used my old jailbreak, ran interface030 and things were fine....then I called iphuc no change. I tried using a different mobiledevice.h (ran make clean and recompiled), I tried pulling the iphoneinterface030's main.ccp and iphoneterface.dev into the trunk directory- recompile- no help; tried the afc trick even though it wasnt indicated- no help.
    ....help?
    Here's some command output showing the issue:
    xx-mac:~/phonedmg/iphuc/iPhone/trunk/iPHUC ixxx$ ./iphuc
    iphuc 0.5.0
    >> By The iPhoneDev Team: nightwatch geohot ixtli warren nall mjc operator
    initPrivateFunctions: this is still not clean. Architecture: i386
    AMDeviceNotificationSubscribe: 0
    CFRunLoop: Waiting for iPhone.
    notification: iPhone attached.
    AMDeviceConnect: 0
    AMDeviceIsPaired: 1
    AMDeviceValidatePairing: 0
    AMDeviceStartSession: 0
    AMDeviceStartService AFC: 0
    AFCConnectionOpen: 0
    AFCPlatformInit: (no retval)
    notification: Entering shell in Normal Mode.
    shell: Entering loop.
    (iPHUC) /: ls
    .
    ..
    Photos
    com.apple.itunes.lock_sync
    iTunes_Control
    (iPHUC) /: exit
    notification: Shell returned 0
    >> Nothing left to do. Exiting.
    xxx-mac:~/phonedmg/iphuc/iPhone/trunk/iPHUC ixxx$ cd ~/phonedmg
    ixxx-mac:~/phonedmg ixxx$ ./iphoneinterface
    iPhoneInterface v0.3.1 built on Jul 13 2007

    Waiting for phone... established.
    iPhone state: Activated
    type "help" for help
    iPhone:/# ls
    .
    ..
    Applications
    Library
    System
    bin
    cores
    dev
    etc
    mach
    private
    sbin
    tmp
    usr
    var
    Last edited by 0solvent; 2007-08-05 at 06:54 AM.
    I still use Solaris
    2007-08-05 05:51 AM
  20. Cody Overcash's Avatar
    you did this?
    http://www.modmyi.com/wiki/index.php...HUC_Usage_Note
    2007-08-05 06:58 AM
29 12
LINK TO POST COPIED TO CLIPBOARD