User Tag List

  1. cousinphil's Avatar
    I was dissatisfied with El Capitan so I downgraded my MacBook to Yosemite. Much better, thank you. I like the older version of iTunes much better.

    But now my iPod won't connect. I've been doing some reading and it seems that downgrading firmware on a 5G iPod is not so easy. I would like to downgrade the iPod so it will work with iTunes 12.2.1.16 on Yosemite. Any suggestions?
    "Travel light, live light, spread the light, be the light"
    2016-12-27 08:49 PM
  2. bbrks's Avatar
    There is nothing you can do. Downgrade is not possible. The best choice you have is to get the latest version of iTunes. That's all.
    2016-12-28 06:30 AM
  3. cousinphil's Avatar
    Yeah, that's what I was afraid of. Thanks.
    "Travel light, live light, spread the light, be the light"
    2016-12-28 11:48 AM
LINK TO POST COPIED TO CLIPBOARD