1. 33Rocks's Avatar
    How do you put 3rd party apps on the iphone using firmware 1.1.1? Be specific?
    Sounds good, how did you change it?

    Im not an iPhone programmer but it looks to me like when rSBT writes the DisplayOrder.plist file it writes this

    <dict>
    <key>displayIdentifier</key>
    <string>com.apple.mobileipod-MediaPlayer</string>
    </dict>

    when it should write this

    <dict>
    <key>displayIdentifier</key>
    <string>com.apple.mobileipod</string>
    </dict>

    atleast changing that fixes mine. Im not really sure what difference it makes it seems to work fine for the pictures string which is also different.
    Oops, meant to quote this one!
    Last edited by 33Rocks; 2007-10-14 at 05:32 AM. Reason: Automerged Doublepost
    2007-10-14 05:32 AM
  2. unclear's Avatar
    2007-10-14 05:40 AM
  3. doppelganger's Avatar
    I posted in app disscussion (customize 1.12 messed me up): if you reinstall rSBT and DON"T hit ok after you save plist, it won't freeze (I had to reboot), but will get your ipod icon back. I currently have both customize 1.12 (1.11?) installed with rSBT 0.3.3 no issues... just don't SAVE customize rSBT config... use old rSBT separatly
    SUCCESS! I just installed rSBT 0.3.3 onto iphone using SSH. Currently using Customize 1.12/1.11 (i installed the one available through Installer.app- not downloaded from the Customize website if that matters). My icons are now just the way i like them (after reorganizing and clicking save in rSBT.app and then going straight back to the home screen without clicking the 'close' dialog box).

    Thanks TheHK for the for the 'download rSBT from creator's website' suggestion.

    D
    2007-10-14 05:47 AM
  4. enigmanic's Avatar
    Anyone else's 1.1.2 say 1.1.1 down at the bottom?
    Yep my 1.12 version says 1.11 at the bottom too. At least the phone icon problem seems to be fixed. However, rSTB is still acting up for me. It'll change the order of some icons, but not all.
    2007-10-14 05:51 AM
  5. Cave Man's Avatar
    SUCCESS! I just installed rSBT 0.3.3 onto iphone using SSH. Currently using Customize 1.12/1.11 (i installed the one available through Installer.app- not downloaded from the Customize website if that matters). My icons are now just the way i like them (after reorganizing and clicking save in rSBT.app and then going straight back to the home screen without clicking the 'close' dialog box).
    I'm having trouble finding rSBT on my iPhone. It isn't in the Applications folder, nor the Customize folder as far as I can tell. Can you provide the path to it? I have both rSBT 0.3.3 and Customize "1.12" downloaded onto my computer, I just need to move them onto the iPhone with Cyberduck.

    Thanks,

    CM

    Yep my 1.12 version says 1.11 at the bottom too. At least the phone icon problem seems to be fixed. However, rSTB is still acting up for me. It'll change the order of some icons, but not all.
    Yes, mine also says 1.11. I still don't have my iPod icon on Customize, and it only shows up at the end of my icons on SummerBoard, even though it's the 2nd item on my Customize list.
    Last edited by Cave Man; 2007-10-14 at 07:00 AM. Reason: Automerged Doublepost
    2007-10-14 07:00 AM
  6. Murfunit's Avatar
    NM Me. I went to the website and downloaded the file there and it works.
    Last edited by Murfunit; 2007-10-14 at 07:32 AM.
    Je t'aime encore, Roguette
    2007-10-14 07:19 AM
  7. rustymetal's Avatar
    Im not an iPhone programmer but it looks to me like when rSBT writes the DisplayOrder.plist file it writes this

    <dict>
    <key>displayIdentifier</key>
    <string>com.apple.mobileipod-MediaPlayer</string>
    </dict>

    when it should write this

    <dict>
    <key>displayIdentifier</key>
    <string>com.apple.mobileipod</string>
    </dict>

    atleast changing that fixes mine. Im not really sure what difference it makes it seems to work fine for the pictures string which is also different.
    the problem is that customize doesent switch per-version.

    1.1.1 iPod icon is com.apple.mobileipod-MediaPlayer
    1.0.2 iPod Icon is com.apple.mobileipod


    I arannged my icons with the latest customize, opened the M86P.plist, added the "-MediaPlayer". Icons displaying how I want but cannot to change order or else it resets the ipod icon problem. I'm on 1.1.1
    2007-10-14 07:26 AM
  8. one1's Avatar
    is there a way to remove that dang "1" where it says you have an update? I don't want to have to look at it forever.
    2007-10-14 08:00 AM
  9. stlcaddie's Avatar
    has anybody had a problem with the customize SpringBoard strings everything else works but when i changed some of my strings through customize it was fine then i happen to unlock phone to use it ( not firmware unlock ) just slide to unlock. all that is gone and when i go to customize and click on springboard strings, the only thing that pops up is REVERT TO BACKUP....there is now more option to change the strings....ive uninstalled and reinstalled several times but no go....PLEASE HELP
    2007-10-14 08:57 AM
  10. arthursdomain's Avatar
    I have not had problems, did you try uninstalling customize? Also, as far as this thread goes, I hadnt read all the threads, but the new summerboard has rsbt incorporated in, and thats what i use to reorganize my icons.
    2007-10-14 09:09 AM
  11. k.abramavicius@mac.com's Avatar
    i got same problem,i moved ipod out of dock and ipod picture disappeared!just got ipod,i tryed to move it back and i got only three icons in dock!!!
    any help?
    2007-10-14 12:14 PM
  12. trancemode's Avatar
    TO FIX THE IPOD ICON IN THE SPRINGBOARD BACK TO YOUR DOCK!

    Why it happen?
    the update of costumize changed the displayorder.plist for the ipod and that it affected the phone not recognizing it which is placed in the spring board. Since this costumize was for phone that had 1.1.1.

    For 1.0.2 users: To fix

    TO FIX THE PROBLEM FOR 1.0.2 users just what i did was, i used iBrickr and went to the /System/Library/CoreServices/SpringBoard.app/DisplayOrder.plist edit it and looked for "com.apple.mobileipod-MediaPlayer " and deleted the "-MediaPlayer" part off of it. re-uploaded it using ibrickr and restart your phone and it should be working fine
    2007-10-14 12:15 PM
  13. k.abramavicius@mac.com's Avatar
    how did you opened M86P.plist?give some more info please!thanks
    2007-10-14 12:26 PM
  14. rustymetal's Avatar
    how did you opened M86P.plist?give some more info please!thanks
    One of the guides had a link to a script that you input your M86P.plist and would fix it into working XML. I can't seem to find the link but I'll keep looking.
    2007-10-14 01:03 PM
  15. toyvan's Avatar
    TO FIX THE PROBLEM FOR 1.0.2 users just what i did was, i used iBrickr and went to the /System/Library/CoreServices/SpringBoard.app/DisplayOrder.plist edit it and looked for "com.apple.mobileipod-MediaPlayer " and deleted the "-MediaPlayer" part off of it. re-uploaded it using ibrickr and restart your phone and it should be working fine

    In order to edit the DisplayOrder.plist do we have to modify the file name to be able to open it?
    2007-10-14 01:16 PM
  16. doppelganger's Avatar
    I'm having trouble finding rSBT on my iPhone. It isn't in the Applications folder, nor the Customize folder as far as I can tell. Can you provide the path to it? I have both rSBT 0.3.3 and Customize "1.12" downloaded onto my computer, I just need to move them onto the iPhone with Cyberduck
    If you removed rSBT, then it no longer is in your Applications folder. Using Cyberduck, you just navigate to the iPhone's Application folder and drag rSBT there. It should then show up as rSBT.app in the Application folder. Restart iPhone and your good. Just remember to use the standalone rSBT (not the one in customize) from now on and do NOT press close after you save your display order.

    HTH
    D
    2007-10-14 03:04 PM
  17. TheHK's Avatar
    Doppelganger, I'm glad it worked for you! The weird thing is that when I tried to do it for my phone using SSH (I'm on WIndows), the new rSBT application freezes on startup and goes back to the springboard automatically. Did you uninstall Customize first?
    2007-10-14 03:47 PM
  18. X-ception's Avatar
    or they can just make 2 version one for 1.0.2 and one for 1.1.1 and LABEL THEM :P
    2007-10-14 03:47 PM
  19. T4R06's Avatar
    i downloaded the rsbt and trying to upload via independence. the problem is asking me the ip add and root password

    any ideas?
    2007-10-14 04:27 PM
  20. Cave Man's Avatar
    If you removed rSBT, then it no longer is in your Applications folder. Using Cyberduck, you just navigate to the iPhone's Application folder and drag rSBT there. It should then show up as rSBT.app in the Application folder. Restart iPhone and your good. Just remember to use the standalone rSBT (not the one in customize) from now on and do NOT press close after you save your display order.
    That did the trick - thanks a million!

    There was no rSBT in my Applications folder, so it must have been removed when I did an early uninstall of Customize. I downloaded Customize 1.12 and rSBT 0.3.3 directly from the developer's web site, unzipped them and dropped both into the Applications folder, then shut off my iPhone and quit Cyberduck. When I rebooted, rSBT showed up and I can now use it to put the iPod icon where I like it.

    i downloaded the rsbt and trying to upload via independence. the problem is asking me the ip add and root password

    any ideas?
    If using a Mac and iPhone 1.0.2:

    1. Get your ip address from your iPhone by Settings > Wi-Fi and pressing the blue arrow.

    2. Use Cyberduck to sftp to this ip address using root as username and dottie as password. (This assumes you haven't changed your iPhone's password.)

    3. Go to '/' from the pull-down menu.

    4. Open the Applications folder.

    5. Delete Customize and rSBT if they are there.

    6. Drag and drop the unzipped Customize 1.12 and rSBT 0.3.3 into the Applications folder of Cyberduck.

    7. Power off the iPhone.

    8. Quit Cyberduck

    9. Turn on your iPhone!
    Last edited by Cave Man; 2007-10-14 at 04:40 PM. Reason: Automerged Doublepost
    2007-10-14 04:38 PM
127 12345 ...
LINK TO POST COPIED TO CLIPBOARD