User Tag List

  1. samwithoutaname's Avatar
    I'm trying to install sqlite3-ruby, but after entering
    Code:
    gem install sqlite3-ruby
    it hangs and then the phone restarts eventually.

    Has anyone been able to install this gem?

    thanks
    2008-05-04 05:06 AM
  2. GordonChil's Avatar
    I have also tried in the past and have failed with the same hang/restart issue. gem install seems to be working now... I can install ruby-mp3info, but still cannot install sqlite3-ruby. It quits with this error:

    <pre>checking for fdatasync() in -lrt... no
    checking for sqlite3.h... yes
    checking for sqlite3_open() in -lsqlite3... no

    make
    make: *** No rule to make target `ruby.h', needed by sqlite3_api_wrap.0'. Stop.</pre>

    I'll look through /usr/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.4 to see if I can find anything to help it build.
    2008-08-28 10:13 PM
LINK TO POST COPIED TO CLIPBOARD