1. iAdaMx's Avatar
    Agh, Okay. I restored my iPhone to 1.1.4 and then Jailbroke it using ZiPhone....Everything seemed to work fine EXCEPT for YouTube and ApolloIM.... Apollo IM wouldnt let me connect to host,and whenever I tried to get on YouTube it said "Cannot Connect to YouTube" Ive DFU'D restore and then YouTube works now. But I know whenever try to jailbreak it I know youtube will mess up again. and I dunno about ApolloIM since it isnt jailbroken at the moment. Ive already tried copying the backup files in var/root/libray/lockdown or w/e to my computer and replacing them with files ive downloaded...that didnt work,nor did the youtube patch via installer. any help is greatly appreciated thanks very much.
    2008-06-14 07:12 AM
  2. wine_guy's Avatar
    Make sure you are using the latest version of ziphone. You can find it at ZiPhone's Blog. The newer versions allow you to install the youtube patch at the same time you jailbreak. But if you are having problems with the ziphone jailbreak, try out iLiberty, or just pwn the iphone.
    2008-06-14 08:26 AM
  3. iAdaMx's Avatar
    I have the latest ZiPhone package...where in ZiPhone is the youtube fix?
    2008-06-14 10:19 AM
  4. darthalen8's Avatar
    I believe you can also get a Youtube fix via the installer, just google for a list of repos and start searching
    2008-06-14 08:56 PM
  5. iAdaMx's Avatar
    Ive already tried the youtube fix via installer like I said.
    2008-06-15 01:29 AM
  6. england98982's Avatar
    Bigboos has 2 patches in installer have you tried both
    2008-06-15 04:43 AM
  7. iAdaMx's Avatar
    yes,ive tried both. still not working...

    yes,ive tried both. still not working...
    Last edited by iAdaMx; 2008-06-15 at 07:50 AM. Reason: Automerged Doublepost
    2008-06-15 07:50 AM
  8. The_Godfather3's Avatar
    Have no fear! I was once in your situation. If you know how to use WinSCP then this work for you. Follow this step by step guide to get your youtube to work as for Apollo....it did the same for me but what I did was I just uninstalled Apollo and installed Mobile Chat instead. It is pretty much the same thing. These are the actual files you need to dowload to upload into WinSCP ----> YouTube114ActvFiles.zip

    The actual YouTube Fix starts here:

    10. Turn auto-lock to never (Settings > General > Auto-Lock > Never).

    11. Connect to your Wi-Fi network (if need be) and run installer from your SpringBoard (iPhone home screen).

    12. Download "BSD Subsystem" and "OpenSSH".

    13. Download WinSCP (if you don't have it already). (Download Link).

    14. Once WINSCP is installed, run it...
    Host name: (iPhone's IP address)
    Username: root
    Password: alpine
    File protocol: SCP
    Click "Yes" to security breach warning.

    Here are the instructions on how to find out your iPhone's IP address:

    * Tap on Settings on your iPhone's Home screen.
    * Then Tap on Wi-Fi from the Settings menu.
    * Then next to your selected network name (indicated with a tick mark on the left hand side) tap on the blue circle with the arrow in it.

    * Your iPhone's IP Address will be displayed on the next screen.

    15. On the right hand side, double click on "library", then "lockdown".

    16. Next, delete "device_public_key.pem", "device_private_key.pem" and "data_ark.plist".

    17. Double click on "activation_records" and delete any files inside, once completed return to previous folder by hitting backspace.

    18. Double click on "pair_records" and delete any files inside, once completed return to the previous folder by hitting backspace.

    19. Download and save SpikeyMikey303's YouTube activation files (save and unzip onto desktop). (Download Link)

    20. Drag and drop "device_public_key.pem", "device_private_key.pem" and "data_ark.plist" into winscp, and click copy.

    21. Double click on "activation_records" in WinSCP, drag and drop the file "89014103211556075053" from the downloaded file into here.

    22. Double click on "pair_records" in WinSCP, drag and drop the files "2991634953036728237753880" and "29916349521148473128163200" from the downloaded file into here.

    23. Restart your iPhone, reset the settings (Settings > General > Reset > Reset all settings).

    24. Your iPhone will reboot automatically... Now open YouTube from the springboard (iPhone home screen), it may flash "Cannot connect to YouTube" for a moment (this will only appear the first time you run YouTube), but will successfully connect, and allow you to search/watch YouTube videos!

    It will great to know if the instructions provided by SpikeyMikey303 helped you resolve the YouTube problem in the comments or if yes don't forget to drop in a thank you note to your fellow reader (SpikeyMikey303) who has made it possible.

    Thanks a ton SpikeyMikey303 for the excellent step-by-step guide, appreciate the effort.

    Oh damn you may have already tried this. If this doesn't work then I don't know what will work cause it seems like you've tried every option. SORRY
    Last edited by The_Godfather3; 2008-06-15 at 09:24 AM. Reason: Automerged Doublepost
    2008-06-15 09:24 AM
  9. iAdaMx's Avatar
    yes,ive tried both. still not working...

    yes,ive tried both. still not working...

    yes,ive tried both. still not working...

    yes,ive tried both. still not working...
    Last edited by iAdaMx; 2008-06-17 at 01:43 AM. Reason: Automerged Doublepost
    2008-06-17 01:43 AM
  10. thatsgr8's Avatar
    My Youtube is working..............................

    Follow the steps exactly. Mine is now working thank you so much "The Godfather 3" and SpikeyMikey 303. Worked as you explained. Much thanks. Someone give that man a beer.
    2008-06-21 02:59 AM
LINK TO POST COPIED TO CLIPBOARD