1. scapegoat's Avatar
    Hi all,

    I installed SwapTunes on my 3g yesterday and since doing so can't see my music in iPod any more (it says there is no music on there). I have tried running SwapTunes and restarting my phone a few times but still can't see it.

    When I view my phone in itunes it says that there is about 8GB of "other" on my phone which I can only assume is my music.

    I ssh into my phone and browse to private/var/mobile/Media and there were two iTunes_control folders there (one with a 2 on the end). The one with the 2 has all my music in it and the other has no music in it. I deleted the one without my music and renamed the one with the 2 on the end but I still can't see the music when I open ipod on my phone.

    Any ideas or am I going to have to bite the bullet and do a restore?

    edit
    Further to this. Not sure if it is related but any apps I have downloaded from the app store won't open. I get the splash screen for the ones that have one then it just goes back to the main iphone screen where it shows me my apps.
    Last edited by scapegoat; 2008-08-04 at 02:45 AM. Reason: more info
    2008-08-03 11:56 AM
  2. kraziebone's Avatar
    My iPhone is having this same problem, is there any fixes?
    2009-07-17 09:43 AM
  3. nik.mess's Avatar
    If your problem is still there:
    browse into your device, rename "/var/mobile/Media/iTunes_Control" into anything you want e.g. "/var/mobile/Media/iTunes_ControlX".

    Then rename "/var/mobile/Media/iTunes_Control2" into "/var/mobile/Media/iTunes_Control" (maybe take a look in the folder first, to see if yr music's in there).

    Now plug off the cable and reboot yr iPhone.
    If everything worked, you've got your music back and you can delete the folder "/var/mobile/Media/iTunes_ControlX", cos it's empty.

    Greez, nik

    BTW: i've got OS 3.0
    EDIT: the AppStore Apps should work again as well
    In future, i'd try to get all music from the 2nd iTunes into one Folder and copy it to the iPhone via iPhone Browser. At home, load the music in iTunes #1 and sync it to yr iPhone
    Last edited by nik.mess; 2009-08-05 at 07:57 PM.
    2009-08-05 07:54 PM
  4. Ipod Guy's Avatar
    ok so i have an ipod 2g, downloaded swap tunes, ran it and it puts all my music into other and my music app says no content. I really dont want to do a restore. Every time i try to ssh my ipod it says couldnt connect (which is a seperate problem) what do i do?

    Did you now when you use a time capsule internet router guest network you can't access ssh or vnc? well i didnt, so i got ssh and fixed the problem. Thanks!
    Last edited by Ipod Guy; 2010-02-20 at 12:48 AM. Reason: Automerged Doublepost
    2010-02-20 12:48 AM
LINK TO POST COPIED TO CLIPBOARD