1. ageorgios's Avatar
    hello!

    I have 2.0 firmaware on my 1st gen iphone.
    I installed swaptunes (bad luck) on it and it does not work correctly.
    It changed my library on my iphone but it cannot swap it back.
    I dont want to have 2 libraries anymore, I want my old library back.

    How can I revert the changes? thank you.
    2008-08-04 01:02 PM
  2. Four20's Avatar
    I tested this application out. . .it didn't mess anything up for me. . .
    2008-08-04 03:35 PM
  3. ageorgios's Avatar
    I tested this application out. . .it didn't mess anything up for me. . .
    you swap your libraries back and forth without problems in fw 2.0?
    2008-08-04 05:41 PM
  4. pac^man's Avatar
    for me it doesn't work at all.
    I installed it with Cydia.
    When I run it, it renames
    /var/mobile/Media/iTunes_Control
    to
    /var/mobile/Media/iTunes_Control_2
    and when I start the iPod app I still see the same library as before.
    Shouldn't it create an additional directory with the '_2' suffix?
    Also it says "allows you to sync with multiple iTunes libraries". Is it possible to sync with more than 2? I can't remember that this was possible back in the 1.1.4 times when I used it.
    2008-08-15 03:05 PM
  5. jacktaylor73's Avatar
    Yes, it is most likely possible, but that app would definitely not let you do that because it switches between itunes_control, and itunes_control_2. If you had itunes_control_3 or whatever you'd call the 3rd, you would need a new or modified app to switch to it.

    EDIT: Oh, and for the record, I had the same problem as the OP, and eventually just restored my ipod. I'm staying away from this app until EVERYONE says it works well (on 2.0, assuming it gets ported (it's not now, is it?)).
    2008-08-15 06:50 PM
  6. iphoneguy2007's Avatar
    I was about to install this but thought to check the forums first. Thanks for the heads up. I wonder if the problems noted above are related to permissioning? Have any of y'all checked to make sure the permissions are okay? Just a thought.
    2008-08-17 09:05 AM
  7. jacktaylor73's Avatar
    I was about to install this but thought to check the forums first. Thanks for the heads up. I wonder if the problems noted above are related to permissioning? Have any of y'all checked to make sure the permissions are okay? Just a thought.
    you might be right, but I'm not willing to mess around with a few different ones, and risk having to restore if the permission isn't right. I don't even really understand what the different permissions do. I just know that 777 allows reading and writing to a folder, and that some things are better if they're 775, or 755, etc.
    2008-08-17 09:32 PM
  8. Dillby777's Avatar
    i have edited the swaptunes application so it can run correctly on fw2.0.
    i have attached the app to my post. to install this app or to get an existing copy working on fw 2.0 ssh to your phone an copy the folder SwapTunes.app in the zip to the applications folder overwrite any existing file, then you done.

    if you have trouble finding the application folder there is the path.
    /private/var/stash/Applications.zFVMky (the combo of letters after applications may vary on your phone)

    If it doesn't work check the permission on the app folder. you can set it to full permissons using 0777

    need any help let me know
    Attached Files
    Last edited by Dillby777; 2008-09-29 at 08:24 AM.
    2008-09-29 08:18 AM
  9. ripped53's Avatar
    Was this update ported to Cydia and Installer? The current version on Cydia is 1.1.5 and can someone verify that it will work on 2.2 without messing up my installed App Store APPs?
    2008-11-24 11:08 PM
  10. Dillby777's Avatar
    this version of swaptunes was the one made for 1.xx firmware, i have changed it for it to work on 2.x firmware. not 100% if it will work on 2.2. i know that if you use swaptunes that you can have issues with app store apps, e.g. when you swap to another library itunes can think that the phone belongs to another itunes install and will want to start all over again. but that could be jst me as i was playing around with it to get it to work. but other than that it works perfectly for me.
    2008-11-24 11:17 PM
  11. ripped53's Avatar
    So you're the creator of swaptunes...well I loved it on 1.1.4. Helped keep my personals personal...... When I updated to 2.0 and tried it I had to abandon it bc of the conflicts it caused with my Apps. I'll try it on 2.1when I know I'll have time to restore and upgrade to 2.2 if there are any problems.
    Last edited by ripped53; 2008-11-24 at 11:52 PM.
    2008-11-24 11:25 PM
  12. Dillby777's Avatar
    nah i'm not the creator. i to was looking for swap tunes on 2.xx but there wasn't any that i was able to find so i found an old copy and edited it so it to work on 2.xx.
    2008-11-25 12:16 AM
  13. ripped53's Avatar
    Not working consistently on 2.1 for me. Continues to create multiple Itunes control folders and will not reliably swap between the original and the 2nd folder.

    SOME PLEASE MODIFY SWAPTUNES to work for 2.1 and 2.2 consistently.

    This is a very useful App when it works.
    2008-12-06 06:19 PM
  14. Dillby777's Avatar
    i have edited the file and now should now be working fine on 2.xx.
    i have attached it to my post and have uploaded it to the downloaded section:Apple Forums | ModMyi.com | iPhone, iPod, Mac, OS X, Mods, More - Downloads - Swaptunes for 2.xx
    Attached Files
    2008-12-07 11:43 PM
  15. ripped53's Avatar
    I upgraded to 2.2 yesterday and have spent the entire day perfecting my phone. Dillby777 have you tried this on 2.2, or has anyone for that matter?
    2008-12-08 05:21 AM
  16. Dillby777's Avatar
    no i havn't tested on my phone.
    there was a prob with the code not renaming the folder correctly.
    i fixed that and should be all good.
    2008-12-08 05:28 AM
  17. ripped53's Avatar
    Has anyone tested on 2.2 firmware? Or the version from cydia for that matter.
    2008-12-11 05:49 PM
  18. Dillby777's Avatar
    both should work. swaptunes is a simple app all it does is rename folders.
    2008-12-11 11:07 PM
  19. ripped53's Avatar
    alright..since no one else sees the value of this App I guess I'll give it a try...
    2008-12-14 01:21 AM
  20. login_05's Avatar
    Hi guys

    I'm on 2.2.1 (on an iPhone - 1st generation - 8GB).
    I've been using Swaptunes since the first day on. Without any major problem.
    Once in a while the swap wouldn't work but I kept on launching ST and it eventually worked.
    Since yesterday it doesn't work at all anymore.
    I didn't update anything / change settings /... Really nothing.
    Just from one day to another the switch doesn't work anymore.
    And worse ... it is stuck on the "wrong" library.
    I sync my multimedia content with my private laptop and calendars, contacts... with my professional laptop. And to do so, switch from the main library (multimedia) to the secondary.
    When I connect to itunes now, I see all used space (almost 8 GB) as "other".
    I can't sync / change / remove any content of course.
    The only solution I can imagine is to restore the Firmware (and go through the whole unlocking/jailbreaking/reinstalation of 3rd apps...)
    And I don't want. It is such a burden...
    Help ... help ... help....

    @ Dillby777
    Any idea / new update on Cydia?

    Btw, I already uninstalled / reinstalled the app... No luck...
    2009-06-18 01:58 PM
22 12
LINK TO POST COPIED TO CLIPBOARD