1. GrimtekP21's Avatar
    Hello, I have had a jailbroken iPhone 3G for months and Winterboard has never caused me a problem. It worked fine in 2.2, but when I noticed the Oregon Trail was not working with 2.2 and required 2.2.1, I decided that it was the time to finally upgrade. Afterwards the iPhone worked fine though Winterboard themes did not change icons of applications anymore. Every other feature of Winterboard functions correctly.

    I tried reinstalling Winterboard, restarting my iPhone, and then trying again to no avail. The theme I was trying (which worked fine on 2.2) was named "Mortagon.theme" and contained a folder only containing icons with the name of the application followed by PNG. Again, this worked for months. I then tried renaming my theme to "Mortagon", "Mortagonus.theme" and so on, but none of these made a difference. The theme would still appear in Winterboard and I could check it, but it would not change the icons. I then downloaded a theme from Cydnia just to see if it was just my theme, but that also did not change icons, just everything else. All other applications (appstore and cydnia ones) work fine.

    Thinking something must have gone wrong with the firmware update, I cleared all data from my iPhone, did a restore to the Apple 2.2.1 firmware having redownloaded it from them through iTunes, then jailbroke with Quickpwn 225-2, the latest version. I immediately tried installing Winterboard with nothing else installed and again, icons did not change. I then tried restoring again with the official Apple 2.2.1 firmware deleting everything from my iPhone, and tried Quickpwning with Quickpwn 2.2.1, the Quickpwn that came out shortly after 2.2.1's release but was not official. This also did not change the icons when I installed Winterboard. In Winterboard I have tried only enabling my custom theme with icons in it and nothing else, and the icons will not change. I have also tried changing the order of the items to make my custom theme on top, but this also does nothing. I even tried doing this entire process on a second iPhone and it has exactly the same problem with Winterboard.

    Has anyone gotten themes to work correctly in 2.2.1? Help would be very appreciated. I pretty much wasted all of yesterday trying to fix this to no avail.
    2009-03-13 03:45 PM
  2. bhz1's Avatar
    Did you restore your iphone as a new phone, it sounds like you did when you say you cleared all the data.
    If not you need to restore as "new". You also say that you installed WInterboard immediately after jailbreaking. I would not do this. I would open up Cydia first and install any and all upgrades it flags.Then install OpenSSH. Reboot the iPhone then install Winterboard and REBOOT the iPhone. Then install your themes. If you are SSH'ing, make sure you are placing them in /var/stash/Themes. If you have complied the custom themes double check the naming of the files and file and folder structure.
    2009-03-15 01:19 AM
LINK TO POST COPIED TO CLIPBOARD