1. anigamersk's Avatar
    Hey, I jailbroke my phone using Ziphone a couple weeks ago and everything was working great until I tried typing some things I had to do in notepad. As soon as I clicked out of notepad everything I wrote was erased and all the notes I made before the jailbreak were showing up. I tried deleting my old notes and it shows it being deleting while the same note shows up again behind it (in otherwards, they won't delete). I'm pretty sure this has to do with where the program saves data and some kind of change between 1.1.3 and 1.1.4 (which I didn't think should be an issue). But anyway, notepad is broken for me, so does anyone have any ideas on how to fix this?
    2008-03-12 09:26 AM
  2. Kyle Matthews's Avatar
    Question: do the following work for you?

    • storing photos from Camera app
    • fast forward/rewind in iPod while playing app
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2008-03-12 09:33 AM
  3. anigamersk's Avatar
    Yes on both.

    Edit: Ok, so I found another issue that might be related. Safari keeps bringing up the same 4 pages I had up before the Ziphone jailbreak. So my guess is both these programs are trying to save in the new location for these programs, but still pulling up info from the old location (or the reverse). If it helps any I used BossTool to move my ringtones, fonts, and applications folder over to give me more space for apps.
    Last edited by anigamersk; 2008-03-13 at 11:08 PM. Reason: More info on problem
    2008-03-12 09:48 AM
  4. anigamersk's Avatar
    *Bump*

    (Sorry for the double post, thought the edit would bring it up to the front page so I can get a few more views to see if anybody has any ides)
    2008-03-13 11:09 PM
  5. azbrowns's Avatar
    I've been having the same problem, notes won't save, camera app leaves a white box when taking pictures, and now mail won't sync....

    Seems like there is no real answer yet as to how to solve this.

    Any help would be great!!

    Cheers,
    2008-04-17 07:30 PM
  6. luistohe123's Avatar
    I have the same problem, and I know why....but I can't fix it
    this happens, because you put a photos or a notes db and replace it for the original
    ...like a backup....so I wanted to backup my notes but now cant erase or save anymore notes...I've tried changing permissions and owner....but SSH won't let me change owner
    Can anyone share a new notepad db?
    2008-06-20 08:53 PM
  7. Kyle Matthews's Avatar
    SSH in, type:

    chown -R mobile:wheel /Applications/MobileNotes.app
    and hit Return/Enter.

    That should do ya.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2008-06-20 09:02 PM
  8. jpjedi's Avatar
    i have the same issue. I left it unsolved because i thought it might be solved with a new firmware version.

    Now today I updated to 2.0.1 -> still I cannot save notes and keep the 4 safari pages coming back.

    No above mentioned suggestione worked for me.

    Anybody who managed to solve this?
    Last edited by jpjedi; 2008-08-10 at 03:47 PM.
    2008-08-10 03:45 PM
  9. ceez's Avatar
    I have the same issue after doing a restore...it won't let me change the background or save any notes... I had the same problem when i went to 1.1.4 now I am in 2.0.1 I will probably do a restore again and start all over. The only thing i care about is the contacts and the pictures which I will have to add manually.
    2008-08-11 11:02 PM
  10. michoolyoung's Avatar
    i had a problem with my email but the guy at the apple store said do a restore and pick set up as a new phone because when you restore it to the old phone you are just putting everything that was wrong back on the phone the only problem was that setting it up as a new phone i lost all of my text messages and notes
    2008-08-20 08:16 AM
  11. AKA_Ben's Avatar
    This is a permissions problem I was whining about months ago (go search - its actually kinda funny in a sad way :P) I went into my phone and found every related bit to notes and changed the permissions and chowned everything. If chowning the app doesn't help make sure to chown the database file and folder and set permissions accordingly. I can imagine your pain - living without notes sucked
    2008-08-20 08:53 AM
  12. slaich2000's Avatar
    hahaha

    Edit Broomhead Spam
    Last edited by Broomhead; 2008-08-20 at 07:12 PM.
    2008-08-20 06:33 PM
  13. MOSHO92's Avatar
    one thing to try before you restore... SSH into the mobile/library and delete the notes folder. When you open the notes app it should be blank and will automatically recreate the new folder and notes.db for you.

    Worth a try. It worked for me a while back.
    2008-08-20 08:06 PM
  14. NetMage's Avatar
    Or you could try running the BossPrefs permissions fix - fixed my Mail.app that was broken after upgrade / restore.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage
    2008-08-21 01:34 AM
  15. theran's Avatar
    Hi All,

    Just go to /private/var/mobile/library and change the permission of Notes to -R 777

    Hi Again,

    For Photo, just change -R 777 for /private/var/mobile/Media.
    Last edited by theran; 2008-08-22 at 05:04 PM. Reason: Automerged Doublepost
    2008-08-22 05:04 PM
  16. darthjesus's Avatar
    try chown the notes.db, that solved mine
    ssh into your phone, then
    chown -R mobile:wheel /var/mobile/Library/Notes/notes.db
    chmod 777 /var/mobile/Library/Notes/notes.db
    Last edited by darthjesus; 2009-01-14 at 12:26 AM.
    2009-01-03 01:07 AM
  17. justywusty's Avatar
    try chown the notes.db, that solved mine
    ssh into your phone, then
    chown -R mobile:wheel /var/mobile/Library/Notes/notes.db
    chmod 777 /var/mobile/Library/Notes/notes.db
    thanks! worked like a charm!
    2009-08-05 03:53 AM
LINK TO POST COPIED TO CLIPBOARD