1. yoshi9769's Avatar
    Five icon dock is not working correctly, it pushes the icons to the left, and i tried Five-Column SpringBoard, once you hit install it comes up with a message "NOTE: The requested modifications cannot be applied due to required dependencies or conflicts that cannot be automatically found or fixed" So that does not work either.
    2009-06-21 06:21 AM
  2. NeoNightmareX's Avatar
    Five icon dock is not working correctly, it pushes the icons to the left, and i tried Five-Column SpringBoard, once you hit install it comes up with a message "NOTE: The requested modifications cannot be applied due to required dependencies or conflicts that cannot be automatically found or fixed" So that does not work either.
    I don't know about Five Column SpringBoard, so I'll remove it.

    Five Icon Dock and SBSettings, however, both work. I know because they are both on my phone. I'll just put a note next to them saying works on sometimes.
    If I helped you, then hit the "Thanks!" button please.

    I can't find Cydia on app store
    2009-06-21 06:26 AM
  3. yoshi9769's Avatar
    I don't know about Five Column SpringBoard, so I'll remove it.

    Five Icon Dock and SBSettings, however, both work. I know because they are both on my phone. I'll just put a note next to them saying works on sometimes.
    Yeah i guess its just hit or miss. Here is a pic of Five Icon Dock not working on my phone.

    2009-06-21 06:59 AM
  4. oo3's Avatar
    SB settings worked when I first installed it, now it crashes.

    Categories worked also the first time I used it, now it crashes when I try to load it. It could be because I put it in a folder (which I've always done w/ 2.X), but I can't unhide it to check because SB settings doesn't work.

    *EDIT*

    The new mobilesubstrate update just released seems to have fixed it I think.

    edit2

    NVM it didn't.
    Last edited by oo3; 2009-06-21 at 08:13 AM.
    2009-06-21 07:03 AM
  5. BigBoss's Avatar
    Many apps are not working because of the install environment. For example, SBSettings works on 3.0 fully. If you are having is crash right on start, you have most likely a messed up dirname setup. I believe this is part of coreutils. It also requires /usr/lib/libintl.8.dylib.

    Prior to the jailbreak, Saurik redirected his repository to a temporary 3.x version of the repository which he plans to remerge back into the main repository. Most likely those of you with issues have one or more of these:

    1) You used an early Icy without its essential updates that do not fix saurik's repo.
    2) You used apt backup to restore your packages and it restored the old repository.
    3) You did not accept some essential updates.
    4) Some other thing that I am not aware of. But the cause is most likely failing dirname command.

    This will definitely impact SBSettings more app. It will impact a lot of other apps. It is not fault of those apps and to fix it no work will be done on those apps. It is an issue with the environment.

    I am compiling a list of known working, recently updated, and known not working apps on my site (you should know where that is!).

    You may be able to see if you still have the old saurik repository by going into Cydia, manage, sources, then look for telesphoreo in teh list. If you see this line of text *exactly*, you have the new repository "Distribution of Unix Software for iPhoneOS 3". If you see this line: "Distribution of Unix Software for iPhoneOS" you have the *old* repository.
    Last edited by BigBoss; 2009-06-21 at 08:47 AM.
    -BigBoss
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.
    2009-06-21 08:41 AM
  6. yoshi9769's Avatar
    Thanks for the info! As for aptbackup i actually tried to restore from it and it started to like it does and then stopped after a few seconds so i don't think it did anything because Ive installed most of my previous packages including boss prefs and they all work fine "except for what i posted above".
    2009-06-21 10:03 AM
  7. Maddcow's Avatar
    Hi all, new to MMI (been around ModMyMoto for ages). I noticed that Stack doesn't work with 3.0....all apps launched from Stack seem to crash.
    2009-06-21 10:13 AM
  8. fanaticrom's Avatar
    Noticed 2 things just now.

    Using notify, doesn't seem to update. Mail icon been there for about 30 minutes when I have no mail.
    StatusNotify works.
    Notifier (written just like that) does exactly what you describe.

    BossPrefs works but behaves strangely. First time I start it it crashes, than, on a second go, it works.
    2009-06-21 01:26 PM
  9. oo3's Avatar
    1) You used an early Icy without its essential updates that do not fix saurik's repo.
    2) You used apt backup to restore your packages and it restored the old repository.
    3) You did not accept some essential updates.
    4) Some other thing that I am not aware of. But the cause is most likely failing dirname command.
    Thank you for your suggestions. Unfortunately I have never used Icy, set up my phone as New after jailbreaking and did not use aptbackup, and have all my updates.

    The only tweaks I have currently installed are installd and five icon dock (which works perfectly btw.)

    They Cydia apps I have installed so far are:
    Categories
    SB Settings
    WB (installed, but no custom themes are tweaks running)
    Dtunes
    Cycorder
    BiteSMS

    I downloaded the new Categories and SB Settings updates this morning and both apps still crashes.

    *EDIT*
    Just to clarify exactly what and when they crash, SB Settings will crash when I press the "more" button. It will load and try to initialize the ads, then crash shortly after. Other than that, everything else works. Categories crashes when I try to load the actual app. Folders work fine.
    Last edited by oo3; 2009-06-21 at 09:49 PM.
    2009-06-21 09:43 PM
  10. NeoNightmareX's Avatar
    Yeah i guess its just hit or miss. Here is a pic of Five Icon Dock not working on my phone.

    Here is mine, definitely hit or miss:

    If I helped you, then hit the "Thanks!" button please.

    I can't find Cydia on app store
    2009-06-21 09:44 PM
  11. jayteez's Avatar
    lockdown isnt working for me.
    bossprefs isnt working for me..
    2009-06-21 09:53 PM
  12. _NULL_'s Avatar
    FontSwap isn't switching the fonts on my phone.
    and Logome isn't downloading.
    2009-06-21 10:38 PM
  13. chrischi79's Avatar
    Weird stuff is going on... After update MobileSubstrate SBSettings 2.99-4 worked perfect. Now after update SBS to 2.99-5 the same thing with the "more" button starts again. I also see in the Interface still 2.99-4, in Cydia i installed 2.99-5. I really don`t get the point here...
    2009-06-22 05:03 AM
  14. mike2001ny's Avatar
    the prob i got is after i downloaded and the apps crashed my fone, it made it to where if my fone was locked and someone called me, sometimes i can't slide the slider to pick up the call. on 1.1.4 and 2.2 it was always like that, but when i upgraded to 3.0 it was working all the way until i started downloadin the apps that aren't supported yet and crashed. even crashed when i had it locked, all of a sudden when i went to unlock i noticed it was already in safe mode
    2009-06-22 05:45 AM
  15. b3nny's Avatar
    20 second lock screen works great
    5 icon dock works great for me
    winterboard works great for me
    sbsettings works great for me (even more button, and i've edited the dock and themed it and stuff to)
    categories works great for me (app and folders)
    wbapp woks great
    mysms seems to be working
    mxtube is working great

    mobilefinder is not working for me it just crashes
    swirlymms won't install
    pwnplayer loads up and DOES get past the splash screen, but crashes just a moment later

    and i had some interesting experiences with backgrounder.. it isn't working, but it does install and the app does open, so i figured maybe it was only not working because of the changes to the way the home button acts (for force quit and such) and so i thought i should try to choose pandora to always background. after clicking "application-specific" in backgrounder.app, at first it seemed to have crashed, with a blacked out bubble towards the upperleft part of the screen, but then it went away and my apps populated the list. because of the timing and the look of the bubble, i believe that its actually the "enumerating apps" pop up, but its so off center you can hardly see it. so then, my apps are there, but its not the apps i have installed currently. its the ALLLLLLL the apps i had installed on 2.x and it remembered my preferences as well. there was pandora, already turned on for backgroundig (and i know it wasn't backgrounding properly at this point). so i turned it off and back on and then turned mxtube on (just as a second test) and waited for the respring but alas no actual backgorunding happening on either app. so anyways, that was my experience, hopefully someone finds it helpful, but its interesting nonetheless. i hope to see some updates for some of these broken apps soon... i'm sure dev's everywehre have their heads spinning like crazy over some of these issues.

    also obviously poof works but hidden apps can't be found by spotlight. thats probably not something that needs to be fixed in poof, but nonetheless its is hindering the functionality of poof/bossprefs/sbsettings/categories, or at least keeping them from living up to their full potential in 3.0... hope to see a fix soon
    Last edited by b3nny; 2009-06-22 at 06:08 AM.
    2009-06-22 06:00 AM
  16. kwall's Avatar
    I am loving 3.0. Runs smooth. I only have 2 gripes thus far. Upon reboot there is that huge black gap in between the apple logo and the lockscreen. Two Cydia lags but that is no biggie I appreciate all the effort and time Saurik gives to us for free.

    And back to on topic Mobile Terminal Works. I only tested 'kill SpringBoard' and 'Reboot' however it installed and worked fine.
    2009-06-22 06:15 AM
  17. remf's Avatar
    Weird stuff is going on... After update MobileSubstrate SBSettings 2.99-4 worked perfect. Now after update SBS to 2.99-5 the same thing with the "more" button starts again. I also see in the Interface still 2.99-4, in Cydia i installed 2.99-5. I really don`t get the point here...
    Yeah there's definitely some sbsettings weirdness going on, as you say, especially the toggles.

    SBsettings & BossPrefs keep turning bluetooth back on after switching it off. Bluetooth stays off when done from Settings/General/Bluetooth.

    I noticed the version mismatch too.
    2009-06-22 08:12 AM
  18. kwall's Avatar
    The Cydia Update is very snappy so I retracted my gripe about Cydia. 6 Rows from Touch-Mania also works but it does not display the icons on springboard so it is a half working tweak [It did not SWOD so I consider it a plus].
    2009-06-22 05:18 PM
  19. Amadomon's Avatar
    also working, in addition to apps already listed:
    NemusSync (yay! Essential work tool for me.)
    iTextUploader

    NOT working yet :-(
    MobileFinder (please get this working; it too is essential for me)
    videorecorder3g (they say it is, but it simply crashes for me.)
    2009-06-23 12:17 PM
  20. elr0y7's Avatar
    Dock.app is still working for me, which is crazy considering it hasn't been updated for 3 months.
    It actually seems to scroll through the apps smoother.

    edit: Speed Dial from dock.app doesn't seem to work. Well at least most of the app works.
    edit2: nvm, all apps respring the springboard when I try to select them.
    edit3: Ok, so as long as the apps are on the springboard Dock.app can launch them, sry for so many edits.
    Last edited by elr0y7; 2009-06-24 at 08:11 PM.
    "Spaceships don't come equipped with rear view mirrors..." -Andre Benjamin the 3000th
    2009-06-23 01:31 PM
117 1234 ...
LINK TO POST COPIED TO CLIPBOARD