1. DJ420a's Avatar
    im on AT&T and ive been tryna get this to work for so long. I've got the camera icon in my text my settings set up and my apn sticks. when i try to send a pic it stops at like 90% and gives me and error can anyone help. And in the settings do we need the password and username?
    Did you restart after the settings? What I did after I put the settings in, was went back to the Network page, then rebooted. I dont have an usernames or passwords.

    If you restart your device after you get mms working you will have to do the steps of putting your sim in another none iPhone and connect to Internet and then swap sim back to iPhone. In shot try to avoid rebooting your device as it stops mms from working.
    Thats odd, this doesnt happen to me. I never even had to take out my SIM. This app behaves like it came with the phone.
    Last edited by DJ420a; 2009-06-29 at 06:56 PM. Reason: Automerged Doublepost
    2009-06-29 06:56 PM
  2. oneduality's Avatar
    I know I'm chiming in very late here and it's probably been said already, but being that I'm on my lunch break and don't have much time..

    Someone mentioned small incoming messages and how they wished phone faking was there as it is in SwirlyMMS ..

    IT IS!

    The UA Prof URL field is for "phone faking" as it's now known .. it stands for "User Agent Profile" and it lets your ISP know the capabilities of your phone .. if your phone is only capable of low resolution it will size them down before it sends them to you, in some cases .. without the User Agent Profile, the ISP will size it way down to be safe (tmobile does this).

    Want to be a Sony Ericsson? enter this in UA Prof URL (I use this setting)

    http://wap.sonyericsson.com/UAprof/W800iR101.xml

    How about a Nokia N95?

    http://nds1.nds.nokia.com/uaprof/NN95-1r100.xml

    At least with the Sony UA Prof URL, images come in full size..
    2009-06-29 06:59 PM
  3. littleasian's Avatar
    having a little trouble on my unlocked/jailbroken 2g iphone running 3.0 that i'm using with ATT

    used pgjay's advice and downloaded teh carrier bundle for ATT. then reinstalled activatemms2g on cydia. rebooted the device, check settings>general>network to see i now have a cellular data tab...awesome.

    however i go into my messages tab and there's no option to activate mms! how can get the trigger to activate mms? everything else seems to be ok
    2009-06-29 09:25 PM
  4. xxbenbenxx's Avatar
    having a little trouble on my unlocked/jailbroken 2g iphone running 3.0 that i'm using with ATT

    used pgjay's advice and downloaded teh carrier bundle for ATT. then reinstalled activatemms2g on cydia. rebooted the device, check settings>general>network to see i now have a cellular data tab...awesome.

    however i go into my messages tab and there's no option to activate mms! how can get the trigger to activate mms? everything else seems to be ok
    if you have the cellular data tab then put in your settings then hit home and reboot again just to make sure and when you turn on your iphone you should see the icon.
    2009-06-29 09:41 PM
  5. ikdaw's Avatar
    my **** works too with activatemms2G all i had to do was install from cydia, reboot after putting in the apn settings and viola!! works like a charm, the camera icon is in my text message. thanks ispazio and people that contributed to this. i can now brag to the 3GS and 3G owners that once bragged to me about MMS not being on the iphone 2G because of "hardware limitations"
    2009-06-29 09:49 PM
  6. littleasian's Avatar
    ok well after manually putting in the APN stuff and rebooting my phone, i now get the little camera icon next to my texts.

    however, i just tried sending a text message and the sending bar stopped at like 95% and then gave me an error.

    any ideas on how to fix this?

    im running unlocked/jailbroken 2g iphone 8gb on ATT.

    thanks!
    2009-06-29 09:55 PM
  7. amini9's Avatar
    I know I'm chiming in very late here and it's probably been said already, but being that I'm on my lunch break and don't have much time..

    Someone mentioned small incoming messages and how they wished phone faking was there as it is in SwirlyMMS ..

    IT IS!

    The UA Prof URL field is for "phone faking" as it's now known .. it stands for "User Agent Profile" and it lets your ISP know the capabilities of your phone .. if your phone is only capable of low resolution it will size them down before it sends them to you, in some cases .. without the User Agent Profile, the ISP will size it way down to be safe (tmobile does this).

    Want to be a Sony Ericsson? enter this in UA Prof URL (I use this setting)

    http://wap.sonyericsson.com/UAprof/W800iR101.xml

    How about a Nokia N95?

    http://nds1.nds.nokia.com/uaprof/NN95-1r100.xml

    At least with the Sony UA Prof URL, images come in full size..
    speak to me more on this please.

    So "phone faking" will it make it work on AT&T or only tmobile?
    2009-06-29 10:17 PM
  8. benjiuk's Avatar
    I used ActivateMMS2G through the ispazio repo and worked great! I got the settings for MMS and the little camera in the messages app.
    Great news that you have got your mms working....and thank you for letting us all know....but could you tell a little more like what network your on and what settings please, thanks ahead !
    Iphone 3g 16g jailbroken4.2.1... "dont fear the jailbreak !"
    2009-06-29 10:19 PM
  9. myke580's Avatar
    you guys are looking at settings/general/network/cellular data network for the mms settings right?
    2009-06-29 10:30 PM
  10. littleasian's Avatar
    i can't seem to get mms to work on att. the icon shows up and i can select pictures but it won't send and i can't receieve

    ive downloaded the new carrier profile from help.ben.at and it helped put in some of the settings for me.

    cellular data service: wap.cingular
    mms apn: wap.cingular
    mmsc: http://mmsc.cingular.com
    mms proxy: wireless.cingular.com

    anybody get it to work while on att? btw i keep my edge blocked because i don't have a data package..not sure if that affects things.
    2009-06-29 11:35 PM
  11. DanielNTX's Avatar
    I just got MMS working on the 2g iPhone for AT&T Blue mMode (for those on AT&T prior to becoming Cingular (orange)) using the following settings:



    MMSC URL: http://mmsc.mobile.attwireless.net
    MMSC Proxy: 010.250.250.100
    MMSC Port: 9201

    Other possible settings besides what I used includes:
    MMSC URL: http://mmsc.mobile.attwireless.net
    MMSC Proxy: 010.250.250.055
    MMSC Port: 8080

    MMSC URL: http://mmsc.mymmode.com
    MMSC Proxy: 010.250.250.100
    MMSC Port: 9201

    MMSC URL: http://mmsc.mymmode.com
    MMSC Proxy: 010.250.250.055
    MMSC Port: 8080
    2009-06-30 12:10 AM
  12. pqjay's Avatar
    You have to have data on there. Don't forget to put sim in another non iPhone and connect to Internet.
    2009-06-30 12:14 AM
  13. DayumQuitPlayin's Avatar
    im on AT&T and ive been tryna get this to work for so long. I've got the camera icon in my text my settings set up and my apn sticks. when i try to send a pic it stops at like 90% and gives me and error can anyone help. And in the settings do we need the password and username?
    Check this out. A lot of useful info.
    Might help you.

    http://www.modmyi.com/forums/file-mo...ml#post4635441
    2009-06-30 12:27 AM
  14. sirganon's Avatar
    I finally got mine working thanks to Abneriel. If u are on t-mobile then go to page 8 and look at Abneriel's post. I think it's the first post with a large quote at the beginning.

    I still have a problem though, the pics I receive are pretty crappy quality still. I'm going to test something and I'll let u guys know if I get the quality fixed.

    **EDIT** I tried messing around with the "MMS Max message size" and the few numbers I tried caused the mms to stop working. I couldn't send any pics. I have no idea what unit is being used in that section though; b, B, KB, MB? And all u can do is insert a number so u can't specify which unit to use. Hopefully someone can figure out the quality problem. This would be perfect if they can.
    Last edited by sirganon; 2009-06-30 at 01:19 AM.
    2009-06-30 12:59 AM
  15. DayumQuitPlayin's Avatar
    Some people seem to believe that the reason for the pic being blurry is because they go directly to the iPhone whereas Swirly fetches for them.

    If you're an ATT user, there's a guy that's going to post a walkthrough on how he got his to work with good quality pics.

    I'm with T-Mobile, but maybe it'll work for us aswell.

    http://www.modmyi.com/forums/file-mo...ml#post4635441
    2009-06-30 01:17 AM
  16. feng303's Avatar
    I got mine working thanks to abneriel on page 8 as well, but i didnt have to change the settings, i just kept it as

    Cellular Data:
    APN - wap.voicestream.com
    Username -
    Password -

    MMS:
    APN - wap.voicestream.com
    Username -
    Password -
    MMSC - 216.155.174.84/servlets/mms
    MMS Proxy - 216.155.165.50:8080
    MMS Max Message Size -
    MMS UA Prof URL -

    also, i kept data roaming off and it still works. it being, i can send and receive picture messages to/from a friend with a T-mobile G1, and another phone motorola razr.

    i have t-mobile, 2g phone, US, jbed and unlocked 3.0.

    i'm also experiencing the horrible picture quality i receive. wondering how to increase the resolution of the pictures i receive (however the ones i send seem to have kept its original image quality), i'm trying the UA profile change in the post above using:

    "Want to be a Sony Ericsson? enter this in UA Prof URL (I use this setting)

    http://wap.sonyericsson.com/UAprof/W800iR101.xml"

    Other members, please test this and see what you come up with! I'll keep updating if i find something.

    EDIT: i tried to fake the sony ericsson using the above method and received another pic message from a friend with the G1 which reportedly takes very good quality pictures. result: FAIL. same low res quality pic received on my iphone.

    picture received, taken by G1:

    picture sent, using my iphone:

    Last edited by feng303; 2009-06-30 at 02:02 AM. Reason: update
    2009-06-30 01:18 AM
  17. ksiphone's Avatar
    My MMS worked fine yesterday, but for the sake of experimentation i decided to restore and retry the activatemms2g hack.

    After restoring and jailbreaking, i lost the ability to edit the apn under settings, general... the choice for cellular data just wasn't there like many are experiencing. I have actually had this happen before. It sucks, but you have to restore and jailbreak again. I retried and the "cellular data network" choice was back.

    I then setup the phone as a new iphone through itunes. Next, i opened Cydia, let it update and then installed essential upgrades. i installed SSH, SBsettings, and activatemms2g only. I went to settings, general, network, cellular data network, and entered the apn information for data and mms. Next came a reboot and mms was active in the native messaging app.

    Next i installed irealsms and set it up to use apple ui. i rebooted and mms was active in irealsms. pictures have been both sent and received multiple times to both email addresses and phone numbers. yesterday, mine would only work if i had swirly installed. today it works with no swirly.

    i went on to install the rest of my apps. on a side note, i've had 59-62mb avail memory all day according to sbsettings. i've never been above 55 until today's restore/reboot-a-thon.

    sorry this was long, but hopefully it will help somebody.

    4gig, 2g, T-mobile
    apn: wap.voicestream.com
    mmsc: 216.155.174.84/servlets/mms
    proxy: 216.155.165.50:8080
    ua prof url: http://wap.sonyericsson.com/UAprof/W800iR101.xml

    EDIT: i tried to fake the sony ericsson using the above method and received another pic message from a friend with the G1 which reportedly takes very good quality pictures. result: FAIL. same low res quality pic received on my iphone.
    i've tried ua prof for both sony ericsson and nokia n95. neither help with image quality. photos that i've sent using snapture have retained their quality. the problem there however is that a black bar appears in the camera roll instead of thumbnails for photos taken with snapture.
    Last edited by ksiphone; 2009-06-30 at 02:04 AM. Reason: Automerged Doublepost
    2009-06-30 02:04 AM
  18. peyay's Avatar
    this is what was going on with me
    installed activeate
    reboot
    applied network settings
    i received mms but could not send
    after failed sent message i could not make calls or receive calls so i uninstalled
    i reinstalled and same thing
    came home i read all these post and i decided to install the ipcc for my carrier (tmobile)
    reset settings and put in the settings again and everything works i even got the visual voicemail settings but ofcourse they dont work
    2009-06-30 02:26 AM
  19. phasetoo's Avatar
    I just noticed that i can send pics to myself and recieve them on edge, but when im using wi-fi i cant recieve them. Does this happen for anyone else.
    2009-06-30 02:52 AM
  20. peyay's Avatar
    you know i was on wifi the whole time i dont know if it will work on edge lol ill turn off wifi and try it out maybe the native mms works on edge only who knows
    2009-06-30 02:56 AM
157 ... 5678
LINK TO POST COPIED TO CLIPBOARD