1. BiOsS's Avatar
    Here are the steps to enable MMS “send/receive” for the iPhone 2G only. I.e. First generation, metal back, silver back … etc.


    1- If you haven’t enable ipcc support in iTunes 8.2, do it before you proceed “links at the end”.

    2- Install “activatemms2g” from Cydia and reboot.

    3- Install a working “tested” carrier bundle “.ipcc” file for your operator.

    4- Reboot.

    5- After reboot go to: Settings / Messages / MMS Messaging ==>ON, other options as desired.

    6- Go to: Settings /General / Network / Cellular Date Network – your APNs should be all in there, if not try to reset the settings. you will only need to fill in the “MMSC / MMS Proxy” fields.

    7- Enjoy.


    Note: if at step 6 you find the wrong APN setting for mms like what happened in my case (Data setting was filled in all APNs), then you will have to edit the carrier.plist inside the ipcc file by changing all APNs values to your MMS setting (APN, Username and Password) if you have to do this then in step 6 all the APNs will be set to MMS setting, however this can be changed manually from the phone with no conflict.
    Hope it works for all.

    How to Enable Carrier Bundle Support in iTunes 8.2 (Windows)
    How to Enable Carrier Bundle Support in iTunes 8.2 (Mac)
    2009-06-29 11:26 AM
  2. jhey2k5's Avatar
    I done this and now it removed the MMS tab and options, the Settings still remain in network, but thats it...
    2009-06-29 03:34 PM
  3. BiOsS's Avatar
    I done this and now it removed the MMS tab and options, the Settings still remain in network, but thats it...
    repeat step 4 and 5
    it should bring it back.
    2009-06-29 05:31 PM
  4. Lord Reaper's Avatar
    where can I find the carrier.plist ?

    edit: in my phone of course! >=p
    Last edited by Lord Reaper; 2009-06-30 at 02:50 PM.
    2009-06-29 11:37 PM
  5. klouud's Avatar
    Everything worked great but I get hung up on the last little bit while trying to send MMS - Text work fine still. Have all options for MMS but they will not send.

    Any suggestions?

    thanx

    tim
    2009-06-30 06:24 AM
  6. BiOsS's Avatar
    Everything worked great but I get hung up on the last little bit while trying to send MMS - Text work fine still. Have all options for MMS but they will not send.

    Any suggestions?

    thanx

    tim
    this means you mms setting is incorrect, make sure your using the right one.
    2009-06-30 08:02 AM
  7. klouud's Avatar
    this means you mms setting is incorrect, make sure your using the right one.
    could you upload the .zip for the 2G so I can SSH it into the bundles folder? I can't seem to get the cmd prompt to execute the command to allow iTunes to install the Apple file.

    thanx

    tim

    NOTE: I copied this into my 2G --->http://www.modmyi.com/forums/t/56587...-0-iphone.html

    Are these files only for the 3G?

    Settings>General>Cellular Data Network:

    Cellular Data
    APN: wap.cingular
    Username:
    Password:

    Visual Voicemail:
    APN: wap.cingular
    Username:
    Password:

    MMS:
    APN: wap.cingular
    Username:
    Password:
    MMSC: mmsc.cingular.com
    MMS Proxy: wireless.cingular.com
    MMS Max Message Size:
    MMS UA Prof URL:
    Last edited by klouud; 2009-06-30 at 02:20 PM.
    2009-06-30 02:14 PM
  8. Jahogus's Avatar
    -------- CONFIRMED WORKING!! --------

    well at least for right now its working.

    I used a SIM from my old Nokia with a text plan from ATT. Make sure your SIM card can send and recieve mms on a different ATT phone first, follow the instructions above. The .ipcc file i used will be attached(---- FOR AT&T ONLY!!! ---), just change the .zip to .ipcc when you are ready to inject the carrier bundle with itunes. I had to manually add the MMSC and the proxy(for me it was MMSC: http://mmsc.cingular.com Proxy: 66.209.11.32:80) make sure you dont touch the other setting under the MMS heading. Reboot and test. good luck feel free to PM me or what not if you have specific questions I will try to help the best i can!
    Attached Files
    2009-07-26 07:52 PM
LINK TO POST COPIED TO CLIPBOARD