1. BuffyNZ's Avatar
    Hi folks,

    I just updated my iPhone 3G to 3.1.2 and used blackra1n to do a jailbreak.

    All good, went like a dream.

    But I can not get sbsettings to open.

    I installed it via Rock, then rebooted.

    I uninstalled it and mobile substrate, then rebooted, then reinstalled sbsettings (which pulled mobile substrate in) and rebooted, but no go.

    I then repeated the process with Cydia.

    I have tapped, double tapped, two finger tapped, swiped up, down, left, right, used harsh language and offered it time alone with a iTouch, but nothing seems to be working.

    I am familiar with SBSettings and how to open it, I have been using it for ages.

    Can anyone offer any advice, please?
    2009-10-12 05:21 AM
  2. nighthawk283's Avatar
    resore it,i did the saem thing on my ipod touch adn sbsetting wasn't opening and then i restore and then ran and install and worked like a charm
    2009-10-12 05:55 AM
  3. janHR's Avatar
    It's not working for me either.
    Has the same symptoms!
    Is waiting for an update needed, maybe?

    I'm on 3GS and jb 3.1.2
    2009-10-12 07:45 PM
  4. ckislam's Avatar
    Had the same issue after jailbreaking with blackra1n sbsettings winterboard lockcalendar springjumps didn't work!
    After the following steps it worked for me
    1. Uninstall Cydia Installer (icy)
    2. Reboot
    3. Install Cydia Installer (icy)
    4. Reinstall DPKG (cydia) [caused unpacking errors]
    5. Reinstall SBSettings (cydia)
    6. Reinstall MobileSubstrate (cydia)

    Then Everything worked again.
    try it
    Using iPhone 3GS 3.1.2 32GB
    2009-10-13 02:01 AM
  5. mezdup's Avatar
    Had the same issue after jailbreaking with blackra1n sbsettings winterboard lockcalendar springjumps didn't work!
    After the following steps it worked for me
    1. Uninstall Cydia Installer (icy)
    2. Reboot
    3. Install Cydia Installer (icy)
    4. Reinstall DPKG (cydia) [caused unpacking errors]
    5. Reinstall SBSettings (cydia)
    6. Reinstall MobileSubstrate (cydia)

    Then Everything worked again.
    try it
    Using iPhone 3GS 3.1.2 32GB
    can anybody confirm/deny?
    i installed 5column springboard on mine and can't seem to uninstall it. from what i understand, if i turn the setting off in sbsettings, i'll be able to, but that of course can only be done if i can get sbsettings to work. this will be my project for this afternoon, lmao.
    2009-10-14 02:22 PM
  6. StevenSimpson's Avatar
    Or you could use the new Pwnage Tool...I just updated to 3.1.2 and haven't had any issues with SBSettings or anything else for that matter
    2009-10-14 02:39 PM
  7. adiangonzalez's Avatar
    Quote:
    Originally Posted by ckislam
    Had the same issue after jailbreaking with blackra1n sbsettings winterboard lockcalendar springjumps didn't work!
    After the following steps it worked for me
    1. Uninstall Cydia Installer (icy)
    2. Reboot
    3. Install Cydia Installer (icy)
    4. Reinstall DPKG (cydia) [caused unpacking errors]
    5. Reinstall SBSettings (cydia)
    6. Reinstall MobileSubstrate (cydia)

    Then Everything worked again.
    try it
    Using iPhone 3GS 3.1.2 32GB
    can anybody confirm/deny?
    i installed 5column springboard on mine and can't seem to uninstall it. from what i understand, if i turn the setting off in sbsettings, i'll be able to, but that of course can only be done if i can get sbsettings to work. this will be my project for this afternoon, lmao.
    yea it works just do the last 3 and it should work the first 3 are kinda pointless
    2009-10-15 03:13 AM
  8. aceslick911's Avatar
    damn dude! thanks! worked like a charm.

    i was wondering what the hell was goin on...

    Had the same issue after jailbreaking with blackra1n sbsettings winterboard lockcalendar springjumps didn't work!
    After the following steps it worked for me
    1. Uninstall Cydia Installer (icy)
    2. Reboot
    3. Install Cydia Installer (icy)
    4. Reinstall DPKG (cydia) [caused unpacking errors]
    5. Reinstall SBSettings (cydia)
    6. Reinstall MobileSubstrate (cydia)

    Then Everything worked again.
    try it
    Using iPhone 3GS 3.1.2 32GB
    2009-10-28 11:07 AM
  9. samurai_vara's Avatar
    Simple rebooting worked for me
    2009-10-28 10:02 PM
  10. haissk's Avatar
    Nope not working for me
    please help i have followed every steps
    2009-11-06 04:08 AM
  11. will16684's Avatar
    hi guys i was suffering the same problem but i found mine by swiping across the status bar at the top. hop this helps
    2010-01-04 02:16 PM
  12. daddyfix's Avatar
    I was also suffering the same problem.

    After installing Veency and SBSettings nothing showed up.
    Tried to reinstall Cydia as posted by ckislam and no eve Cydia Showed up on springboard.

    Found out that swiping the top of the screen showed SBSettings.
    All ok now!

    This post helped, thanks, will16684!
    2010-02-01 06:35 AM
  13. drmias's Avatar
    Had the same issue after jailbreaking with blackra1n sbsettings winterboard lockcalendar springjumps didn't work!
    After the following steps it worked for me
    1. Uninstall Cydia Installer (icy)
    2. Reboot
    3. Install Cydia Installer (icy)
    4. Reinstall DPKG (cydia) [caused unpacking errors]
    5. Reinstall SBSettings (cydia)
    6. Reinstall MobileSubstrate (cydia)

    Then Everything worked again.
    try it
    Using iPhone 3GS 3.1.2 32GB

    How to do step 4 ?
    Thanks,
    2010-06-22 06:46 PM
  14. RockyWood's Avatar
    I was also suffering the same problem.

    After installing Veency and SBSettings nothing showed up.
    Tried to reinstall Cydia as posted by ckislam and no eve Cydia Showed up on springboard.

    Found out that swiping the top of the screen showed SBSettings.
    All ok now!

    This post helped, thanks, will16684!
    I had the same problem and tried what you did and it works.

    Thanks.
    2010-07-07 02:38 AM
  15. ekgirl's Avatar
    hi guys i was suffering the same problem but i found mine by swiping across the status bar at the top. hop this helps
    Amazing - with me its usually the SIMPLEST thing. I have swiped up, and I have swiped down, but never ACROSS! Thanks a bunch.
    2011-09-23 11:52 PM
LINK TO POST COPIED TO CLIPBOARD