User Tag List

  1. mockup's Avatar
    Ok… so I have MobileRSS from the App Store, and I loved it until it started quitting on launch a few updates ago. Well, it would work on first launch, but not on subsequent ones. After getting no help from the developers I did some investigation of my own. And the results puzzle me.

    When I restart the phone in safe mode, MobileRSS works. Naturally, I tried turning off various MS extensions to find the particular culprit. But even when I turned all of them off, the crashing persisted. I even tried uninstalling SBSettings, and that didn't help either.

    My impression was that all safe mode simply disables Mobile Substrate. So if I can turn off all extensions and the problem is still there, does this mean that the problem is with Mobile Substrate itself?
    2010-02-21 03:57 PM
  2. iamlegend1's Avatar
    I had a similar issue with tweetie 2, heres what I did and it corrected itself...1st, logout your credentials for MobileRSS, put the phone into safe mode, put your credentials back in, repring, and than see what happens.

    Also, do you have any gmail linked internet links that might have your reader attached into it already? If thats the case, try temp logging out of that while doing the step above

    edit/your still crashing in safe mode? If thats the case this wont help you, safe mode does disable all ms..and its not a prob with the ms. Maybe you just have too many subscriptions;/
    Last edited by iamlegend1; 2010-02-22 at 05:12 PM.
    2010-02-22 05:05 PM
  3. mockup's Avatar
    Thanks. I basically tried that. There's actually no way to log out the credentials without uninstalling it and installing it again. So that's what I did. I then opened it in safe mode and patiently waited for it to fully process all my feeds. Again, crashed on launch once I tried it in regular mode. But when I went back to safe mode, it was fine again…

    It's so weird. I'd almost suspect them of deliberately sabotaging the app, except that it wouldn't explain why the app even launches that first time, and I can't think of any motive for them to do that without even some disclaimer that they don't support jailbroken phones.
    2010-02-22 05:10 PM
  4. iamlegend1's Avatar
    Very strange, I have MobileRSS and it works great for me...so theres def a conflict with the ms if it doesnt crash while in safe mode.

    What extensions are you running?
    2010-02-22 05:39 PM
  5. mockup's Avatar
    Assuming SBSettings is listing them all / I'm not forgetting anything: ActionMenu, Activator, Backgrounder, BatteryControl, CyDelete, DimDelay, Five Column Springboard, Five Icon Dock, LockInfo, LockInfoMail, MailToAttachmentM… (cut off, forget the full name), MultiIconMover, OverBoard, PopupBlocker, PreferenceLoader, PrivaCy, RotationInhibitor, SimulatedKeyEvents, SnappyHook, StatusNotifier, Veency, WeatherIcon, libhide, qStatus, shrink, wigglefree.

    That sounds like so much when I type it, but none of those are particularly resource consuming or buggy as far as I can tell.

    Now, I happen to have done a clean system install i.e. restore last night… I found an app that required 3.1.3, and decided while I was upgrading I'd just give the phone a digital enema while I was at it. So I'm going to try it again now and see how it goes.
    2010-02-22 05:53 PM
  6. iamlegend1's Avatar
    Sucks to do a clean install on 1 app, you're almost better off finding another reader(I actually like NetNewsWire). Being on a 2g, maybe you're just running out of ram. Just try to monitor it with SBSettings...good luck
    2010-02-22 07:36 PM
  7. 1hihum's Avatar
    I am having the exact same issue with E*TRADE.It is driving me nuts. My issue started two updates ago. Prior to that it worked flawlessly, but now I am on the verge of getting rid of it. I tried the same things you did (killing everything in MS etc). I even updated from 3.0 to 3.1.2, still no dice. So I know now it's just the one app, but clearly there is something causing a conflict. If you find anything that works, please please post it here!!!

    P.S. I should note however that E*TRADE still crashes even in safe mode
    2010-02-26 04:45 AM
  8. iamlegend1's Avatar
    If its crashing in safe mode than its mostly not an ms conflict...
    iElegance Pro HD, can't wait!!!!!!
    2010-02-27 09:36 PM
  9. JStraitiff's Avatar
    if you have or have had vwallpaper installed, look for skrew common. I was having problems with tweetie 2 and thats what was conflicting it. see if it works for you
    2010-02-27 11:13 PM
  10. 1hihum's Avatar
    if you have or have had vwallpaper installed, look for skrew common. I was having problems with tweetie 2 and thats what was conflicting it. see if it works for you
    I have it on the phone, but have not been using it. I will remove it and see if that is the problem. I also have another odd issue that may or may not be related. It seems now that every time I open the phone app, my email updates. I have noticed that it does this when I open other apps now as well (iReal sms for example). I have no idea why, as I have my push set to manual only. Anyway, just food for thought. I also noticed with the E*TRADE app, that when it does open, it will often tell me that it can't connect to the internet, even when i have full bars (I am on edge only at work). Once I am home, and on WIFI, I don't seem to have an issue with the app, so I really don't know what the hell is going on, but it is starting to really aggravate me!
    2010-03-01 07:21 AM
LINK TO POST COPIED TO CLIPBOARD