1. kiddoko's Avatar
    I just wanted to post this for anyone who has been having issues with Safari not saving cookies on their iPhone. This has been an issue for me for well over a month! Ive asked for help here and on various IRC iPhone chans seemingly with no response and people just ignoring my plea for help... Maybe no one knew how to help me. Who knows?

    But I'm posting this because my problem has FINALLY been solved!!! Now usually I'm NEVER able to change permissions with Terminal on my phone. It just gives me Permission Denied and/or Operation not permitted errors. I can't use SSH so that was out of the question and so is WinSCP. What to do? Nothing...! Nothing but suffer with a broken safari for weeks on end....

    That is until this evening. I refreshed Installer and noticed something. I have a Japanese source installed in Installer called Japan Public Repository and the author is masaki. In the "Recent" category there was something called 1.1.4 Safari Cookie Fix. Now I run firmware 1.1.3 Ziphone jailbroken. I tapped on the More Info tab to see what exactly this fix would do. The fix seemed like it would do the same for 1.1.3 because 1.1.3 and 1.1.4 share the same mobile/Library/Cookies folder location. I took a chance out of desperation and even though the fix says it is for 1.1.4 it works on 1.1.3!!!! MY SAFARI IS BACK TO NORMAL!!!!!!!! Oh happy day!!! As I type this I am reassured that I WILL NOT HAVE TO LOGIN AGAIN TO SEND!!!

    I have to tell you that has been VERY annoying! And with NO HELP FROM ANYONE! So, for anyone reading this if you have been having the same problems with safari not saving passwords not saving cookies not saving well ANYTHING! Try this fix. Even if you're running 1.1.3 it seems to work fine. I've been running Safari now for about an hour and its been saving EVERYTHING! Its worderful to have my normal safari back. So I hope that I've helped someone. I'm typing from my iPhone to this post right now. If you need to find he Japan Public Repository source just google it. Its not hard to find. You'll need to have BSD Subsystem or Cydia (which is what I have and is also known as FAKE BSD Subsystem) and you will need to reboot your phone after the fix is implemented.

    Anyway enjoy your now fixed safari browser like I am!
    Last edited by kiddoko; 2008-03-18 at 05:08 AM. Reason: grammatical changes, correct installer source
    2008-03-18 04:40 AM
  2. stlcaddie's Avatar
    BRO.....your the man....I seen that on installer but I was afraid to even try it....read ur post and tried it...I didn't even need to type my username in like it was always there....thanks for the big set of balls u have....Right on bro
    2008-03-18 05:25 AM
  3. kiddoko's Avatar
    BRO.....your the man....I seen that on installer but I was afraid to even try it....read ur post and tried it...I didn't even need to type my username in like it was always there....thanks for the big set of balls u have....Right on bro
    oh dude I'm happy for you! So that means you know what it's been like. Guess what? Safari is still going! I mean it's still logged into MMI and I've even closed all browser windows and yet I'm still logged in!!! I can't tell you how happy I am! But then again I'm sure you know lol.
    2008-03-18 05:35 AM
  4. TheOrioles33's Avatar
    Awesome find. I have just been "living" with this issue. Did you "install" it through installer because I am getting script errors or did you manually execute the terminal commands? Thanks!
    2008-03-18 05:20 PM
  5. kiddoko's Avatar
    Awesome find. I have just been "living" with this issue. Did you "install" it through installer because I am getting script errors or did you manually execute the terminal commands? Thanks!
    I installed the fix through Installer. The script error you're getting might be a local thing depending on your specific phone configuration. For example. I have Cydia installed which pretty much erases the original BSD Subsystem files and I believe installs a Fake BSD Subsystem. Then I have something else known as SUID Lib Fix. But that may have nothing to do with it.

    When I get that script error usually I just have to remove said App from the Queue in Installer, respring using Summerboard and/or restart my phone then try installing said App from Installer again. I've never tried to issue those commands from Terminal only because like I said in this original post that I can never get the permissions to change with Terminal when I've tried to change permissions for other Apps or programs. I'm actually surprised that fix worked for me. Because with Terminal it just refuses to change any permissions.

    However if for some reason you continue to get the script error maybe you can be successful at entering the commands via Terminal or SSH if you are proficient with that. Let me know if you are successful because I feel your pain "living" with a broken Safari.
    2008-03-19 03:41 AM
  6. hidehide's Avatar
    You can also fix it by setting permission to 777 for var/mobile/Library/Cookies/Cookies.plist
    2008-03-19 11:14 PM
  7. POYZEN's Avatar
    Installer fix available. Just go to the appledailytimes website to find the fix posted on Mar 16. Title "1.1.4 Cookie Fix Available in Installer". It only requires the BSD Subsystem to be installed on your iPhone. This fix worked perfectly. Did it over wifi. The "Remember Me" option in Safari now works flawlessly.

    P.S. I just signed up to post what I find to be an easier method to resolve the cookie issue. Although the methods posted in posts 1 and 6 work. I find post 6 too complicated as I don't have terminal / ssh skills and post 1 gives me a script error as stated in post 4.
    2008-03-20 04:55 AM
  8. secretmrx's Avatar
    Installer fix available. Just go to the appledailytimes website to find the fix posted on Mar 16. Title "1.1.4 Cookie Fix Available in Installer". It only requires the BSD Subsystem to be installed on your iPhone. This fix worked perfectly. Did it over wifi. The "Remember Me" option in Safari now works flawlessly.

    P.S. I just signed up to post what I find to be an easier method to resolve the cookie issue. Although the methods posted in posts 1 and 6 work. I find post 6 too complicated as I don't have terminal / ssh skills and post 1 gives me a script error as stated in post 4.
    Yea add appledailytimes.com/installer and install the "1.1.4 Cookie Fix" works perfectly

    btw thats my repo
    Want some help PM me and ill answer it asap
    2008-03-25 01:35 AM
  9. ajl917's Avatar
    Yea add appledailytimes.com/installer and install the "1.1.4 Cookie Fix" works perfectly

    btw thats my repo
    What exactly does it do?
    2008-03-25 02:45 AM
  10. kiddoko's Avatar
    Yea add appledailytimes.com/installer and install the "1.1.4 Cookie Fix" works perfectly

    btw thats my repo
    The "Japan Public Repository" which I originally used to install the 1.1.4 Cookie Fix also worked flawlessly. I guess it just depends on how you want to install the fix and what repo you want to use.
    Big kid playing with iPhone! Learning as I go...
    2008-03-25 03:23 AM
  11. pallavt's Avatar
    You can also fix it by setting permission to 777 for var/mobile/Library/Cookies/Cookies.plist
    hey is it 777 or 0777
    2008-03-25 01:29 PM
  12. mak10's Avatar
    just fire up terminal on the iPhone and type the following 2 commands

    chown mobile /var/mobile/Library/Cookies/
    chown mobile /var/mobile/Library/Cookies/Cookies.plist
    2008-03-25 07:56 PM
  13. jiZzLe's Avatar
    Okay, no matter what I do, what Fix I run, what command I run over terminal, nothing HELPS ever!
    2008-04-21 07:53 PM
  14. Xenotime's Avatar
    Yea add appledailytimes.com/installer and install the "1.1.4 Cookie Fix" works perfectly

    btw thats my repo
    Thank you very much. ^^ Is working perfect!

    Sent from iPhone. Big TY!
    D.Xenotime
    iPhone model: 2G
    iPhone firmware: v 3.1.2
    OS: Window 7 x64 Bits
    Status: Jailbroken
    Theme: Customized Full Metal Panic!? Theme
    2008-04-26 05:51 AM
  15. atifds9's Avatar
    Guys just wanted to thank you for this thread, It's been a problem for so long for me, for some reason the Japan source didn't work for me but the apple daily times one did, but thanks to all, as the terminal commands didn't work as is said permission denied.
    2008-05-16 09:07 AM
  16. iPhoneMadness's Avatar
    Man, for a long time I thought I was the only one going threw this. It was such a hassle, I hardly ever logged in anywhere from my iPhone. I just waited until I got home.

    I didn't even know this was a mass problem.

    Thanks so much for the apple source!

    I'm gonna thank all you mofo's just for going through this with me while everyone else just laughed at us for having a red-headed-step-child-of-an-iphone. Talk about a thorn in the ***.
    Last edited by iPhoneMadness; 2008-05-16 at 10:54 PM.
    2008-05-16 10:51 PM
LINK TO POST COPIED TO CLIPBOARD