1. stuntsy99's Avatar
    Hi,

    Mobile Substrate is causing problems with my iPod accessory. Whenever it is active, and the iPhone is docked into the Phillips Alarm Dock, the iPod app stops working and I can't play music (crashes soon after).

    When I uninstall it, the dock works perfectly and it even comes up with the message that this iPod accessory is not fully supported by the dock etc.

    Can anyone help me solve this problem?

    Cheers.
    2010-10-01 01:27 PM
  2. stuntsy99's Avatar
    Well... I did manage to solve this problem. I had previously jailbroken using the latest redsnow beta. That was when it didn't work. I tried then to jailbreak with same method and still wouldn't work.

    Next I tried the old unofficial pwnage tool 4.1 method, but however chose to install mobile substrate as a package in the ipsw. So far, this has worked, and both my accessories and mobile substrate are working correctly.
    2010-10-02 05:29 PM
  3. gpz500's Avatar
    Same problem with an iPhone 3G (iOS 4.1) and a Belkin car charger with FM transmitter. I will try the PwnageTool method as soon as possbile...
    Last edited by gpz500; 2010-10-03 at 10:49 AM. Reason: I've added the car charger firm
    2010-10-03 03:06 AM
  4. stuntsy99's Avatar
    I just tried sn0wbreeze 2.0.2 without including mobile substrate (installing it after), and results are looking good. Still working perfectly, which must mean redsn0w is at fault somehow...

    Can someone point the dev team to this thread or notify them? I don't have twitter
    Last edited by stuntsy99; 2010-10-03 at 07:41 AM.
    2010-10-03 07:34 AM
  5. gpz500's Avatar
    Hi! I have just written a comment to the redsn0w post in the official Dev-Team blog.
    2010-10-03 10:53 AM
  6. stuntsy99's Avatar
    Thanks gpz500!

    I'm just glad I wasn't the only one with the problem :S. Lets hope they fix it next beta/release.
    2010-10-03 12:03 PM
  7. organik's Avatar
    same problem here with L5 remote accesory. Tried sn0wbreeze but having problems restoring custom firmware, errors etc, tried DFU and Recovery with no luck.

    Any ideas? What's this pwnage tool 4.1 method?
    2010-10-13 09:12 PM
  8. gpz500's Avatar
    Hi organik!
    PwnageTool is a Mac tool to make a jailbroken firmware, similar to sn0wbreeze. The last official release doesn't yet support iOS 4.1 on iPhone 3G, so you have to manually "hack" your copy of PwnageTool 4.01 to do it.
    Here some info: Jailbreak iPhone 3G iOS 4.1 with PwnageTool [Guide] | Redmond Pie

    PS: I have just jailbroken with PwnageTool and, as far as I know, now it's working well :-)
    2010-10-14 09:17 AM
  9. seemebreakthis's Avatar
    Thanks for posting this! I knew the problem wasn't becasue of something I did....

    But I am running Windows, is there any tool for jailbreaking ios4.1 besides redsn0w? (on iphone 3g)

    Answering my own question --- sn0wbreeze

    same problem here with L5 remote accesory. Tried sn0wbreeze but having problems restoring custom firmware, errors etc, tried DFU and Recovery with no luck.

    Any ideas? What's this pwnage tool 4.1 method?
    You may want to try again using sn0wbreeze (to create the .ipsw)and iREB (to restore).

    Basically, open itunes, then open iREB, then plug in the phone, then DFU the phone, then follow instructions on iREB after clicking on the phone model.

    When you finally get a white screen on the iphone, press shift while clicking on restore on itunes to select the firmware created with sn0wbreeze.

    Worked for me.
    Last edited by seemebreakthis; 2010-10-15 at 01:47 PM. Reason: Automerged Doublepost
    2010-10-15 01:47 PM
LINK TO POST COPIED TO CLIPBOARD