1. fmagreed2's Avatar
    I've recently jailbroken my Ipod Touch 4g and installed network-cmds.

    Running ifconfig doesn't seem to work. I've tried the following, all using su.

    ifconfig en0 ether xx:xx:xx:xx:xx:xx
    No error, but mac address did not change.

    ifconfig en0 lladdr xx:xx:xx:xx:xx:xx
    Same thing

    ifconfig en0 down
    ifconfig en0 ether xx:xx:xx:xx:xx:xx
    Error saying the reciever is down.

    I tried all combinations of having the wifi on/off/connected/disconnected, and I can't spoof the MAC address.

    If you're wondering why, I want to connect to a school network, but we can only register 1 computer (which is controlled via a MAC filter). I've gotten permission to access the network this way (he said the only reason we're only allowed one device is really just because there would be too many addresses to track).

    Anyone know a fix?
    Last edited by fmagreed2; 2010-10-14 at 09:57 PM.
    2010-10-14 09:50 PM
  2. fmagreed2's Avatar
    Can anyone help at all?
    2010-10-19 02:51 AM