1. 89.tristan's Avatar
    on my iPhone, in /bin, i have all sorts of ssh and scp and the sftp and all that fun stuff, but theres no "just" 'ssh'... can someone provide that, or is there a reason it wasn't in the binkit sshkit on nate true's site?

    THANK YOU

    ...remember to push for the nes emulator to be worked on
    Last edited by 89.tristan; 2007-08-07 at 05:51 AM.
    2007-08-07 05:46 AM
  2. Blueasseddwarf's Avatar
    You need to rename ssh2 to ssh. Afterwords, it should work :]
    2007-08-08 05:40 PM
  3. 89.tristan's Avatar
    I still get caught in a loop asking for passwords, I'll upload a screenshot later...
    2007-08-09 03:28 PM
  4. dmbaird's Avatar
    I still get caught in a loop asking for passwords, I'll upload a screenshot later...
    yes same here
    2007-08-09 07:27 PM
  5. holybjork's Avatar
    yes same here
    what program (terminal / WinSCP) are you using to connect to the iPhone with SSH?

    you may be trying to connect with a user other than root - on a mac when you ssh in terminal... the command will be:

    ssh [email protected]

    where x.x.x.x is the ip address of your phone

    hope this helps... maybe not though...
    2007-08-09 09:02 PM
  6. 89.tristan's Avatar
    unfortunately its the latter choice, what we are trying to do is not ssh TO the iPhone, but out of it... ssh'ing to it works perfectly...
    2007-08-09 09:29 PM
  7. copland007's Avatar
    I have found that passwords with certain characters don't work, '#' for me didn't work. When I ssh'ed into a box without a '#' in the password it worked.
    2007-08-09 09:41 PM
  8. 89.tristan's Avatar
    my passwords are hexadecimal.... only numbers and letters
    2007-08-09 09:49 PM
  9. 89.tristan's Avatar
    what i am trying to do works from my mac -> iphone, but not iphone -> mac

    i have tried ssh -l root 192.168.0.2
    i have tried ssh [email protected]
    amongst others...

    i have no need for all the security options, just the connection, as open as it may be,

    i successfully connect to the mac, it says am i sure, yada yada yada, i type yes, then it asks for the pass, then it starts the loop that you see at the bottom.... please help
    Attached Thumbnails ssh2 on iPhone, but ssh?-foo_0.png  
    2007-08-09 10:13 PM
  10. Daerid's Avatar
    I have terminal and binkit installed, but I have no ssh or ssh2 option from the iPhones terminal. What am I missing?
    2007-08-12 03:25 AM
  11. 89.tristan's Avatar
    look at where u got the binkit, theres also an ssh kit

    (iphone.natetrue.com or something like that)
    2007-08-12 04:01 AM
LINK TO POST COPIED TO CLIPBOARD