1. organik's Avatar
    I would love to post a step by step right here, but I don't know how to do it...somebody please post a step by step for us? There are a lot of people in the iPhone NES thread asking for it.
    Last edited by organik; 2007-08-11 at 12:27 AM. Reason: More descriptive title.
    2007-08-10 07:57 PM
  2. GreggSymington's Avatar
    I would suggest changing you Title.
    2007-08-10 08:10 PM
  3. s2kpdx's Avatar
    I agree, I was all excited, maybe instead of the "+++" you should put "???"
    2007-08-10 08:49 PM
  4. duggal's Avatar
    It's in Nervegas' readme: make sure you read the file
    alias nosound="launchctl unload /System/Library/LaunchDaemons/coreaudiod.plist"
    alias sound="launchctl load /System/Library/LaunchDaemons/coreaudiod.plist"
    2007-08-10 08:49 PM
  5. s2kpdx's Avatar
    It's in Nervegas' readme: make sure you read the file
    alias nosound="launchctl unload /System/Library/LaunchDaemons/coreaudiod.plist"
    alias sound="launchctl load /System/Library/LaunchDaemons/coreaudiod.plist"

    I think we all know this, but have no idea what this means...

    Could you post a step by step on what to do with this information?? Where to enter it, or what code to change, or if we need MobileTerminal to do it or what.... Thanks...
    2007-08-10 08:53 PM
  6. k0mpresd's Avatar
    It's in Nervegas' readme: make sure you read the file
    alias nosound="launchctl unload /System/Library/LaunchDaemons/coreaudiod.plist"
    alias sound="launchctl load /System/Library/LaunchDaemons/coreaudiod.plist"
    I have entered those commands in mobileterminal on the phone and sent them to the phone using puttie and I still cannot get sound working

    I type sound and alias sound in terminal on the iPhone and they both say command not found

    I really don't know what I'm doing wrong
    2007-08-10 08:53 PM
  7. Cial00's Avatar
    Here's what I did:

    I entered both of these aliases into MobileTerminal on the iphone itself. They both worked, but as soon as I close out of MobileTerminal and relaunch it, the aliases are lost and apparently don't save. I know it has something to do with having a .profile in the var/media folder but I'm not sure how to create this .profile in order to save the aliases.

    Also, when I did disable sound (and I checked it, as my ipod no longer worked) the NES sound still didn't work. Anyone able to get this to work properly?

    btw, make sure you put the aliases in EXACTLY as NerveGas wrote them, they are also case-sensitive.

    -Cial
    2007-08-10 09:18 PM
  8. EmoRebellion's Avatar
    Did you have the headphones plugged in?
    2007-08-10 10:13 PM
  9. Cial00's Avatar
    No, didnt try it with the headphones in. I didn't think it mattered since v.21 allows sound through the speakers
    2007-08-10 11:22 PM
  10. FJT's Avatar
    lolololoo did i miss v.21? where is it
    2007-08-10 11:59 PM
  11. k0mpresd's Avatar
    its up to .24 now
    2007-08-11 12:12 AM
  12. FJT's Avatar
    but where? its not under downloads.... is it?
    2007-08-11 12:19 AM
  13. EmoRebellion's Avatar
    I only see 0.20.1 on google code, where do you see .24?

    EDIT: I see, there is a .24 available on http://iphone.natetrue.com/nesapp/, but it is just the code. The newest compiled code by NerveGas is .21.
    Last edited by EmoRebellion; 2007-08-11 at 12:40 AM.
    2007-08-11 12:36 AM
  14. s2kpdx's Avatar
    I have .22 on my phone, it said it was NESapp (not the one with nervegas in the title), and the controls are way better than .21....

    STILL NO SOUND ~!~
    2007-08-11 12:43 AM
  15. k0mpresd's Avatar
    I only see 0.20.1 on google code, where do you see .24?

    EDIT: I see, there is a .24 available on http://iphone.natetrue.com/nesapp/, but it is just the code. The newest compiled code by NerveGas is .21.
    you might want to try downloading and actually looking @ the files before posting
    2007-08-11 12:45 AM
  16. s2kpdx's Avatar
    Yup, I am sure .24 is a working version, I will be downloading it when I get home
    2007-08-11 12:50 AM
  17. organik's Avatar
    apparently nobody knows how to get sound working via the alias .profile method? Any way to contact natetrue to get an expanded readme? So sad all of us with our silent nes games. So very much better with sound, i am sure.
    2007-08-11 01:40 AM
  18. s2kpdx's Avatar
    Yeah no sound FTL. Anyone on IRC want to get in contace w/ Natetrue??? I dont even know what the heck IRC is.... lol
    2007-08-11 03:23 AM
  19. CheekyDevil's Avatar
    Try running this from MobileTerminal or ssh in and then reboot the iPhone. You'll have to do the opposite to turn sound back on ... just make sure you don't have any headphones plugged in when you do this.

    You can also follow the readme at http://iphone.natetrue.com/nesapp/files/README
    2007-08-11 04:02 AM
  20. Kaos2800's Avatar
    Google Linux alias and these commands will make sense.

    alias nosound="launchctl unload /System/Library/LaunchDaemons/coreaudiod.plist"
    alias sound="launchctl load /System/Library/LaunchDaemons/coreaudiod.plist"

    You are telling the phone to assign a small short name to a long command. By running from WebShell the commands will still be in affect when you go to the game.

    Step 1: Run WebShell
    Step 2: Run both commands above.
    Step 3: type nosound and press return.
    Step 4: Play NES
    Step 5: Lose game, return to WebShell and type sound
    Step 6: Press return and have system sounds back. I hope this helps.
    2007-08-11 04:52 AM
37 12
LINK TO POST COPIED TO CLIPBOARD