1. abalfour's Avatar
    Hey man, thanks for your offer of assistance.

    Yea -- I'm using a USB cable to transfer the app from my Mac to my iPhone via iFuntastic....
    Do you have or NOT have the new app icon showing up on your iPhone?

    If not, make sure that you have correctly put the following lines
    in the DisplayOrder.plist file somewhere between the

    ---key---iconList ---/key---
    ---key--- displayIdentifier ---/key---
    ---string--- com.JiveTalk.embark ---/string---

    Note: the ... being, other apps that have icons that show up on your iphone. (ie...Weather, Maps, etc...)
    and the --- are where the Greater Than or Less Than signs would go, but on the Webpage, they all get deleted so I put dashes instead.

    Do NOT put the new app that you want into the <key>special</key>
    area because the icon will be hidden.

    Or it is not customary to put new apps into the ---key--- buttonBar ---/key---
    area unless it is an app that you use all the time and having it in the bottom icon bar area is convenient for you.

    Anyway, once you are sure that your new app lines are properly included in the right place in the DisplayOrder.plist and it IS spelled LETTER for LETTER, correctly (UPPER and LOWER cases, do apply, as well as DOTS, DASHES, UNDERSCORES, etc.).

    The next thing, which is where you are having the problem, is where you need to set the PERMISSIONS of each and every file that you put into the new.app folder, including the new.app folder itself.

    Normally, I use the following permissions;

    Folder = 0777
    App = 0755
    xxx.png = 0777
    xxx.plist = 0777

    For all of you "wizards" out there that are just itching to comment here on permissions, DON'T....this is only meant to help this person get things going...so I know that the permissions can be set to something else.

    The files in the jivetalk.app folder should be the following files;


    The line used above within the DisplayOrder.plist file, <string>com.JiveTalk.embark</string> comes from a line contained within the Info.plist file that is in the jivetalk.app folder.

    Now you notice that the jivetalk.app is using the file embark?

    Well, this is the frontend (like a browser) that basically calls for the URL,
    http://iphone.beejive.com which is also a line contained in the Info.plist file in the jivetalk.app folder.

    Anotherwords, the app OpenURL is just another browser and the jivetalk.app does not use that browser. It COULD if you change the Replace.This which is contained the a line in the info.plist file that is included with the OpenURL app.

    First, print out this post of mine and get all of the files explained above and make a little block diagram so that you understand what is done and needs to be done, before attempting to actually do it.

    As far as setting permissions, which can also be done manually using chmod but that is another thing which takes some additional files to be put into th iPhone and several other commands to be issued, etc., so we won't go there, right now.

    Now you said you are using iFuntastic from your Mac...well since I do not have or NEVER will use a MacLemon, I can't help you there but I can only assume that it is capable of at least making new folders and putting files into those folders on your iPhone.

    I do not know if it has a Properties function, in order to change the permissions of files and folders like WinSCP (for Windows machines) does.

    Maybe someone else that uses both iFuntastic and a Mac, can help there.

    Once everything is done, you need to power OFF your iPhone and then power ON the iPhone. Than the new JiveTalk.app will work.
    Last edited by abalfour; 2007-09-22 at 11:57 PM.
    2007-09-22 11:52 PM
  2. Argelius's Avatar
    Thanks again for your assistance.

    I'm missing one vital piece of information -- what program/method do you use to set permissions to those numbers?
    2007-09-23 03:10 PM
  3. abalfour's Avatar
    Thanks again for your assistance.

    I'm missing one vital piece of information -- what program/method do you use to set permissions to those numbers?
    Since I am using a Windows OS based machine, I use WINSCP Properties on the files that I want to set or change the Permissions on.

    I am sure there must be some Mac users here that would be willing to help you on this.

    Come on people...it won't jeopardize your Wizard position...we will all still respect you after you help.
    2007-09-23 03:16 PM
  4. sftl99's Avatar
    anyone have a facebook app? i tried making one but my icon came out looking bad
    You could try this one, it's what I made for my personal use. It's not the exact "f" but it was close enough for me.
    Attached Images iPhone Apper!-icon.png 
    2007-09-24 06:53 PM
  5. Argelius's Avatar
    Actually, I achieved success using a different route.

    I took the existing BeeHive application, opened it up and changed the relevant parameters to the website I wanted and created a new icon.

    Works great now. I am a happy camper!
    2007-09-24 08:35 PM
  6. Lonestar87's Avatar
    Hey are you guys using ibricker to install?? i created an app, but dont know how to upload it! i tried loading with ibricker under applications, but doesnt work, what are you guys using to transfer it to your iphone?
    Last edited by Lonestar87; 2007-09-24 at 11:45 PM. Reason: Automerged Doublepost
    2007-09-24 11:28 PM
  7. Prdirtysouth49's Avatar
    can someone please just link a working Facebook app i keep getting a black screen and im trying to learn how to change permissions and stuff but im so confused
    2007-09-25 02:42 AM
  8. Lonestar87's Avatar
    we all are hahaha

    how are you uploading them? ibricker?
    Last edited by Lonestar87; 2007-09-25 at 05:27 AM. Reason: Automerged Doublepost
    2007-09-25 05:27 AM
  9. Prdirtysouth49's Avatar
    figured out a way to solve the blank screen.. download squid.. go to the your app folder.. find your app.. check exc. for all.. then restart
    2007-09-25 11:48 PM
  10. az1324's Avatar
    Here's a FlickIM one for anyone who wants it.
    Attached Files
    2007-09-26 02:54 AM
  11. IriQuel's Avatar
    figured out a way to solve the blank screen.. download squid.. go to the your app folder.. find your app.. check exc. for all.. then restart

    That worked for me thanks! (Jivetalk)
    2007-09-26 04:26 AM
  12. daniel_emt's Avatar
    Well, I'm not sure what i did diffierent, but it worked for me the first time i tried. And I'm not too smart with this stuff. I use apptapp for almost everything, except icons which i use cyberduck.
    Anyway, i made a Wikipedia app from that site, downloaded, unzipped it, then dragged the app in to my Applications folder via cyberduck and there it was. Working and all.

    i was gonna put up a screenshot, but i can't figure out how to. Oh well.
    2007-09-26 07:25 AM
  13. Argelius's Avatar
    Now that I've conquered the challenge of making "URL Apps", I came up with another great idea.

    If you haven't found them, Bookmarklets are a great addition to the iPhone. They are little bits of java code that you add to your Safari (on your computer) bookmarks bar then sync to your iPhone

    As an example, the Wikipedia bookmarklet pops up a javascript box where you type what you are searing for and then it takes you directly to that Wikipedia page. Try them out, they are cool. (My faves are Wikipedia, Dictionary and Thesarus).

    I was hoping that coping the "url" of the bookmarklet and doing the same thing I did to make other "URL apps" would work, but alas it doesnt.

    Curious if anyone has any ideas how this might be done.
    2007-09-26 12:21 PM
  14. srgilber's Avatar
    hahaha. Thats funny. WHen I have no service I made my phone say "DAMN SERVICE" lol
    How did u make ur phone say "damn service"? instead of no service?


    -Iphone n00b :-)
    2007-09-27 09:19 PM
  15. tdc's Avatar
    Instead of a internet address such as http: etc, is there an app that will support Base64 embedded data: as an URL?

    Is there an app similar to this that supports data: urls, as well as standard http?
    Last edited by tdc; 2007-10-14 at 08:08 AM. Reason: Automerged Doublepost
    2007-10-14 08:08 AM
  16. princesslol's Avatar
    This is SUCH a great idea. I am a total "newbie" and I've been trying to understand this "stuff" for a few months now..countless hours I don't have! I have been able to install installerapp on my iphone and can easily get apps on my iphone from there. However there are a ton of apps I read about and would love to put on my iphone but can't figure out how. I don't understand ANY of the computer lingo ie SSH, HTML, launchers, terminal, URL and tons more. I don't understand Wiki or Widgets. I want to get access apps from an icon on my homescreen. Is this even possible (aside from installerapp?) I don't even know where to go if someone responds to this message. Maybe I'll figure it out?!?
    Can someone PLEASE add info that could help people like me? Or if there is already a place like this please send the link?!
    Last edited by princesslol; 2007-10-17 at 08:37 PM.
    2007-10-17 08:33 PM
  17. Pl4ter's Avatar
    wow..nice...works fine with my iphone....

    now the phone is getting better and better everyday.
    2007-10-18 08:29 AM
  18. shawn o's Avatar
    Why do I keep getting the error: "Oops. There was an error. Make sure you entered a Title, Url, and uploaded a PNG file."

    I attached a valid png, the url, and name.

    2007-10-24 08:42 AM
  19. lgreenberg's Avatar
    All I get is a black screen???
    2007-10-25 02:38 PM
  20. canadianiphone's Avatar
    can someone make an mmi icon for this app?
    something similar to this....
    2007-10-25 08:34 PM
73 1234