1. redeyez69's Avatar
    Just want to warn people that might have an iPhone without a data plan. Its probably people with 1st gen unlocked iPhones who don't have a data plan.

    Cycorder is supported by ads and ads while not using much data would still add up quickly on the bill. Most carriers charge 5 cents/kb. So get a data plan or use cycorder in a wi-fi hotspot.

    Im saying this cuz I tried cycorder with airplane mode on and it wouldnt work lol. Doesnt matter cuz I have unlimited data on my 3G of course. I would pay for a version without ads and better UI or customizable one.
    just tried running cycorder in airplane mode and it works!!!!
    2gen iphone with 2.02 fw
    2008-09-06 02:02 PM
  2. netuser's Avatar
    Airplane mode is a must specialy if you are traveling or dont have unlimited data plan.
    2008-09-06 02:32 PM
  3. laz305's Avatar
    Umm, GET CYDIA! What are you waiting for? Installer is lame under 2.0 in my opinion.
    ok? well I'm still on 1.1.4 so what do I do? I used iLiberty+ last time, what do I use now? winpwn?
    2008-09-06 06:16 PM
  4. TheOrioles33's Avatar
    ok? well I'm still on 1.1.4 so what do I do? I used iLiberty+ last time, what do I use now? winpwn?
    Cycorder only works under 2.0 if I am not mistaken. Time to update!
    2008-09-06 06:24 PM
  5. alerx7's Avatar
    i tried installing cycoder but it doesnt show up on my home screen im on 2.0 and i have iphonevideorecordder already ,,maybe is it because of IPVR , or i do have to ssh and change permissions , idfk>>>
    i saw , i bought, i unlocked!
    2008-09-06 06:34 PM
  6. Rip's Avatar
    I'm experiencing the same 'hissing' when uploaded to Youtube.

    Here's an example
    .

    I'm experiencing the same 'hissing' when uploaded to Youtube.

    [ame="http://www.youtube.com/watch?v=yVqkyApYbAY"]Here's an example[/ame].

    I'm experiencing the same 'hissing' when uploaded to Youtube.

    [ame="http://www.youtube.com/watch?v=yVqkyApYbAY"]Here's an example[/ame].
    Last edited by Rip; 2008-09-06 at 08:13 PM. Reason: Automerged Doublepost
    2008-09-06 08:13 PM
  7. M4tt Dam0n's Avatar
    just tried running cycorder in airplane mode and it works!!!!
    2gen iphone with 2.02 fw
    you're right. Weird it didn't work for me the first time. I guess people without data can turn airplane mode on.
    2008-09-06 11:42 PM
  8. saurik's Avatar
    I think there are delay issues from the time you press record to the time you hit pause?

    It's not excessive, but it's enough to cut some time off those 'golden moments' I find myself grabbing now and again.

    I would say it's around 1 - 1.5 second of shortage.
    To verify, you mean a delay from when you hit record to when it actually begins recording? That also drives me nuts and is something I'm going to work on fixing (in addition to the "finalizing" delay when you hit stop).

    It has to do with the amount of time it takes to setup and tear down the audio system correctly. The former takes time as I need to start the queues up from scratch (lest I screw up the syncing) and the latter takes time as I don't get the audio buffers constantly, only every second, so I have to wait for the final buffers to come in before I can truly stop recording. The next version is going to switch to a lower-level audio API so I can handle the sync without having to constantly turn on/off the audio, and which will give me the audio more often so I don't have to wait a noticeable amount of time when you hit stop.

    I think there is a problem when you upload them to youtube. I uploaded one this morning and I just tried playing it back but the sound is not there. All you hear is an occasional hissing sound but thats it. I wonder if it was just that upload or maybe something in the encoding process that messes it up when uploaded as is. Ill have to wait 'till later to test another video...

    Will post when I can test again...or if someone else can upload a video to youtube and tell me if it came out fine...
    There is definitely something bad going on here. I am going to look into this for the next version (for which I am concentrating on "things you can do with your videos").

    One concern is that there aren't many audio codecs I can legally use (speaking of which, I'm pretty certain that IVR is violating a bunch of patents in its encoding process... I need to look into that more). MP3 costs a lot of money ($2 per copy of Cycorder), and that's what YouTube recommends using :(.

    Also, I don't have /that/ much CPU time available to be doing audio compression. Right now I'm using a 44,100 16-bit, mono PCM channel (uncompressed).

    If anyone knows anything about all of the codecs that YouTube happens to support when you upload a video it would be really useful.
    Last edited by saurik; 2008-09-07 at 12:08 AM. Reason: Automerged Doublepost
    2008-09-07 12:08 AM
  9. Maximus54's Avatar
    Saurik,

    I haven't tried uploading videos from Cycorder to to YouTube yet, but I can tell you that Cycorder with its recent update is one impressive application. You are very talented and I look forward to many more updates and future apps from you. Thank you once again for your hard efforts.

    Maximus_54
    2008-09-07 12:58 AM
  10. x999x's Avatar
    If anyone knows anything about all of the codecs that YouTube happens to support when you upload a video it would be really useful.
    Do you still have to pay any fees for using the LAME codec for audio? I'm pretty sure its open source. You could do post processing on the audio, then mux the feeds together afterwards.
    2008-09-07 01:29 AM
  11. saurik's Avatar
    Do you still have to pay any fees for using the LAME codec for audio? I'm pretty sure its open source. You could do post processing on the audio, then mux the feeds together afterwards.
    Yes. LAME is open source, but you still have to pay the patent costs for using it. You can read more about this on the Wikipedia page for it (which I actually did earlier today when I was trying to figure out what the costs were, I eventually figured out the $2).

    I'm hoping its just that YouTube makes bad assumptions about the data rate on PCM encoded audio. Example: maybe it assumes that the data is always going to be stereo, only takes 32 or 8 bit files, or simply doesn't accept anything over 8kHZ (or some other reasonable value). I'll be doing some experimentation to find out if there's some ideal value that makes it work without other extra encoding.
    2008-09-07 03:25 AM
  12. one1's Avatar
    Saurik, would the situation be any different (good/bad) if you pushed the vids to photobucket instead?
    2008-09-07 03:47 AM
  13. netuser's Avatar
    What about using Ogg ? it is completly free and open source. And it do very good compression
    2008-09-07 03:58 AM
  14. phoenix.stu's Avatar
    Regarding the hissing. I too had the same problem when uploaded to YouTube. I then took the same video and used VisualHub and re-encoded it. I then re-uploaded it and that cured the problem.
    2008-09-07 04:38 AM
  15. 40_ounce's Avatar
    Just foynd out sound has been added.... This is great thanks surik.........
    2008-09-07 04:38 AM
  16. echostats's Avatar
    Ability to e-mail the file would be AWESOME!
    2008-09-07 07:52 AM
  17. Boiling Ice's Avatar
    Ability to e-mail the file would be AWESOME!
    u have to think about the attachment size here, Cycoder videos gets really big in few seconds, so I don't think you will be able to email it...
    2008-09-07 08:42 AM
  18. saurik's Avatar
    What about using Ogg ? it is completly free and open source. And it do very good compression
    This would only make a difference if we knew whether YouTube supported Ogg ;P. Also, I wouldn't want to do that, as I don't believe most people can play videos encoded with Ogg. One of the goals with Cycorder is that the videos are recordered with a codec that I know is playable out of the box on many systems (including the iPhone).
    Last edited by saurik; 2008-09-07 at 09:20 AM. Reason: added commentary on playback portability
    2008-09-07 09:18 AM
  19. at004's Avatar
    hey saurik this is wayyyy better than videorecorder3g its amazing.
    however i am facing a small problem. i have a data plan which is 30 mb per month and i pay 20 $ for it
    and with the ads everytime i open some of that data is being used and for each extra 1 mb is an extra 1$ please is there a way i can remove ads i am ready to pay:S
    2008-09-07 01:43 PM
  20. phoenix.stu's Avatar
    I have a possibly good idea. Why not offer a paid and unpaid version. Only difference is no adds. Would it be possible to receive a payment(whatever the monetary value) and link an id code to the phone as say intelliscreen does?




    EDIT: Just noticed the new update to fix bugs. Now ver. 0.9-5 Thanks for keeping on top of things.
    Changes:
    *Fixed "After 10 Minutes" Crash
    *No StatusBar After Suspend
    *Update MiB After Deletions
    *Removed /tmp/video.mov Link
    Last edited by phoenix.stu; 2008-09-07 at 03:17 PM.
    2008-09-07 02:52 PM
302 ... 21011121314 ...
LINK TO POST COPIED TO CLIPBOARD