User Tag List

  1. spektro's Avatar
    Hi mates

    Finally, iBlacklist 2.0 package was sent to _BigBoss_ for release on Cydia. (Thank you _BigBoss_)
    If it does not show to you yet, please wait a little since we just submitted it.
    Basically, the software is exactly the same as the last 1.9.4 version released for the 1.X firmwares, with the password problem fixed, and others.
    This package has been tested in order to avoid any unexpected behavior. Please use this thread to report problems, since it will be easier to backtrack problems with separated threads for different versions.
    It's installation obeys Saurik's recommenations about using MobileSubstrate feature to load the library without modifying any important file on your device.

    PLEASE BE SURE YOU HAVE MOBILE SUBSTRATE PROPERLY WORKING ON YOUR DEVICE !!!

    If the software does not load, please reboot, if it still not load, you need to be sure your MobileSubstrate is properly installed.
    Last edited by spektro; 2008-11-26 at 11:55 PM.
    2008-09-04 01:25 AM
  2. MWillis561's Avatar
    Great!!!! Looking forward to trying out the new release.
    2008-09-04 01:38 AM
  3. PhoneLine's Avatar
    Awesome! Not seeing it on the repo yet, hopefully in the morning. I'll be registering it once I get it installed. This is one app I loved on the first gen phone, and can't wait to get it on my 3G!

    Thanks for your hard work man!
    2008-09-04 04:24 AM
  4. nycdiplomat's Avatar
    yesssssssss....finally i can block those bill collectors and these annoying @$$ sms msgs from this crazy @$$ stalker broad!!!!
    waiting on my iPhone 6+
    2008-09-04 05:03 AM
  5. chbearsrock's Avatar
    Hey I have been trying to install iBlacklist from Cydia but keep getting "Source Error: subprocess extra-installation script returned error exit status 1." I have mobile substrate installed (i have also tried reinstalling it), and have rebooted multiple times. Any ideas?
    2008-09-04 08:04 AM
  6. edlockW's Avatar
    there is a typo in the installation script:

    /var/mobie/Library/iBlacklist should be /var/mobile/Library/iBlacklist

    workaround, if you know your way around SSH and CLI:

    # cd /var
    # ln -s mobile mobie

    then try reinstalling it

    you can remove the "mobie" symbolic link, after the bug has been fixed

    (by the way: it works smoothly!)

    **UPDATE**
    It doesn't work as "smoothly" as I first thought; just like the other users here, I'm not seeing iBlacklist block anything.

    Wedlock

    PS: to remove the workaround, just do:
    # rm /var/mobie

    Although it doesn't hurt to leave it there (you never know if something within the iBlacklist code may be using this misspelled directory).
    Last edited by edlockW; 2008-09-04 at 12:21 PM. Reason: not as smooth as expected ;-)
    2008-09-04 08:28 AM
  7. voodorush's Avatar
    Unfortunately it doesnt work at all on my Iphone.
    Everything installed fine ; iblacklist registered normaly.
    The problem is that there is no filtering at all.
    Any ideas?
    Any log files or other information to dump?

    Cheers,
    Stoyan
    2008-09-04 10:28 AM
  8. pl_svn's Avatar
    @spektro: love you guys: thank you!!!
    (btw: will "old" licenses still work or we have to buy a new one?)


    Unfortunately I'm experiencing the same "Source Error" chbearsrock reported a couple of posts above (but... if it really is an installation's script typo.... funny it only happens to someone, isn't it?)

    BB... can you, please, leave Customize for a couple of minutes and fix this nasty issue?

    thnx!


    UPDATE: successfully installed thanx to edlockW's workaround but... iBlacklist does not work!

    Tried both manually adding contacts or selecting from Address Book: same result. also tried a "global" filter to no avail. Not even "Restricted Numbers" are blocked (if app is set to, obviously)


    yes: I have restarted (many times) and respringed (many times).

    As far as I recall... iBlacklist 1.x used to install something in /Library/LaunchAgents or in /Library/LaunchDaemons but... found nothing there, now

    (btw: old licenses are flawlessy accepted )
    Last edited by pl_svn; 2008-09-04 at 12:48 PM.
    2008-09-04 10:46 AM
  9. vsnlweb's Avatar
    there is a typo in the installation script:

    /var/mobie/Library/iBlacklist should be /var/mobile/Library/iBlacklist

    workaround, if you know your way around SSH and CLI:

    # cd /var
    # ln -s mobile mobie

    then try reinstalling it

    you can remove the "mobie" symbolic link, after the bug has been fixed



    (by the way: it works smoothly!)

    You might want to put the command to remove the link as well, seeing as it will not be long until this minor error will be fixed, I am assuming.

    For those of you who are not familiar with using terminal or code in general I created a folder in /var called mobie ie: "/var/mobie". Once you created the directory you can install iBlacklist and it will be installed.
    Last edited by vsnlweb; 2008-09-04 at 12:11 PM.
    2008-09-04 11:20 AM
  10. netuser's Avatar
    Great news but I cant install it through Cydia, I have error message Size missmatch what to do ? please upload the corerct files

    thanks
    2008-09-04 11:31 AM
  11. vsnlweb's Avatar
    Ok, I just tried it and I dont get any filtering at as well.... Any ideas...
    2008-09-04 12:12 PM
  12. nycdiplomat's Avatar
    i installed without any issues but i have yet to see if the filtering works because that crazy broad hasnt called yet lol

    yea its not working for me either...i dont know if someone has already done this but im going to notify the dev now
    Last edited by nycdiplomat; 2008-09-04 at 01:07 PM. Reason: Automerged Doublepost
    waiting on my iPhone 6+
    2008-09-04 01:07 PM
  13. netuser's Avatar
    Ok Finnaly able to install it, dont know if there was an update on repo.

    Just did the test with phone call from my work phone and it dont block it so it is not working cant test sms now.
    Last edited by netuser; 2008-09-04 at 01:31 PM.
    2008-09-04 01:23 PM
  14. picassolsus's Avatar
    Ok just adding my two cents as well.

    Blocking not working on either my 3G 2.0.2 or my girlfriend's 3G 2.0.1.

    I've tried:

    -Installing/reinstalling (with subsequent reboots not just resprings)
    -Uninstalling Winterboard thinking it might be interferring (didn't appear to be)
    -Monkeying around with the various switches in the app thinking maybe some were actually negated. No luck there either.

    I've already paid the $12, so I'm kinda anxious but I'm confident that spektro will get things worked out promptly.
    iPhone 3GS 16GB 3.0fw White + Jailbroken
    2008-09-04 01:55 PM
  15. spektro's Avatar
    Hi guys

    Thats what i was talking about on my last message on the 1.X iBlacklist topic. The MobileSubstrate thing have some issues.
    Basically, its the responsible for loading the iBlacklist library.
    If its not loading, its because MobileSubstrate is not running on your phones, as it wasnt on mine.
    So, please do this:

    Open SSH to iPhone;
    Grab the file /System/Library/LaunchDaemons/com.apple.SpringBoard.plist
    Check if this file has this line on INSERT_DYLD_LIBRARIES tag:
    /Library/MobileSubstrate/MobileSubstrate.dylib

    If it does not have this line, MobileSubstrate is not running on your phones. So please check if you have these folders:

    /Library/MobileSubstrate (inside it must have DynamicLibraries folder and the MobileSubstrate.dylib)

    also

    /Library/MobileSubstrate/DynamicLibraries (inside it there will be a symlink called iblacklist.dylib)

    So, MobileSubstrate detects there is a library (iblacklist.dylib) to be loaded and tells to SB to load it. But, if the SB plist does not have the line to load the MobileSubstrate, it does not run, and does not load anything.

    The workaround for this is:

    * Make sure you have MobileSubstrate folders above, including the symlink to iblacklist.dylib that our installation creates;
    * Take a look on SB plist to check if there is this line on DYLD load libraries:
    /Library/MobileSubstrate/MobileSubstrate.dylib
    * Make a backup of the original SB plist
    * If it does not have it, please use this link to convert the original SB plis to a text xml file:

    http://140.124.181.188/~khchung/cgi-bin/plutil.cgi

    * Insert it (/Library/MobileSubstrate/MobileSubstrate.dylib) manually using a text editor on pc (NOT WORDPAD, but notepad). If the orignal files have mention to others libraries, please insert the line and separate the other load lib lines by ':'
    Example: original plist has this line:

    /some_path/some_library.dylib

    Now it will be:

    /Library/MobileSubstrate/MobileSubstrate.dylib:/some_path/some_library.dylib

    Save it and place it again on /System/Library/LaunchDaemons folder. On a mac, just use plist editor and will be fine.

    After this, reboot the phone. It must work if all were done correctly.
    Sorry for this, but we are just trying to follow Sauriks recommendations to use Mobile Substrate feature.
    We will correct the installation file soon and load the library by ourselves, without using MobileSubstrate.
    If you have boot problems after doing this, the SB plist is corrupted, so please load your SB plist backup and the phone will be up again.

    Thanks for the feedback !!!
    Last edited by spektro; 2008-09-04 at 02:29 PM.
    2008-09-04 01:57 PM
  16. picassolsus's Avatar
    Still not working for me. Mobilesubstrate line was already present, all other folders present as well.

    The dynamic link for iblacklist is 0bytes though is that normal?

    EDIT:

    Is my com.apple.SpringBoard.plist contents supposed to have random ascii characters in it when I open in notepad? There looks like there's some funky encoding going on in there? I mena, it's clear enough to read a line or two and see that mobilesubstrate is present, but it's definitely not coming through as plain text? Let me see if I can paste contents here:

    bplist00 ')YKeepAliveULabel_EnvironmentVariables\MachServ ices_ProgramArgumentsXUserName _com.apple.SpringBoard
    _DYLD_INSERT_LIBRARIES_\/Library/MobileSubstrate/MobileSubstrate.dylib:/Library/MobileEnhancer/MobileEnhancer2.dylib
    "$_#com.apple.remotenotification.serve r_%com.apple.springboard.UIKit.migserver_com.ap ple.CARenderServer_com.apple.springboard.migserv er_com.apple.SBUserNotification_PurpleSystemEv entPort_com.apple.springboard\ResetAtClose _HideUntilCheckIn      (_8/System/Library/CoreServices/SpringBoard.app/SpringBoardVmobile    % < I \ e f ~ ™ -Up’
      $%&(c  * j
    Last edited by picassolsus; 2008-09-04 at 02:10 PM.
    iPhone 3GS 16GB 3.0fw White + Jailbroken
    2008-09-04 02:06 PM
  17. edlockW's Avatar
    hi spektro,

    i have:
    1) /Library/MobileSubstrate/MobileSubstrate.dylib in my com.apple.SpringBoard.plist file
    2) /Library/MobileSubstrate
    3) /Library/MobileSubstrate/DynamicLibraries
    4) iblacklist.dylib is in the /Library/MobileSubstrate/DynamicLibraries directory

    but blocking doesn't work

    Still not working for me. Mobilesubstrate line was already present, all other folders present as well.

    The dynamic link for iblacklist is 0bytes though is that normal?

    EDIT:

    Is my com.apple.SpringBoard.plist contents supposed to have random ascii characters in it when I open in notepad? There looks like there's some funky encoding going on in there? I mena, it's clear enough to read a line or two and see that mobilesubstrate is present, but it's definitely not coming through as plain text? Let me see if I can paste contents here:

    bplist00 ')YKeepAliveULabel_EnvironmentVariablesMachServi ces_ProgramArgumentsXUserName _com.apple.SpringBoard
    _DYLD_INSERT_LIBRARIES_/Library/MobileSubstrate/MobileSubstrate.dylib:/Library/MobileEnhancer/MobileEnhancer2.dylib
    "#com.apple.remotenotification.server_ %com.apple.springboard.UIKit.migserver_com.appl e.CARenderServer_com.apple.springboard.migserver _com.apple.SBUserNotification_PurpleSystemEven tPort_com.apple.springboardResetAtClose _HideUntilCheckIn      (_8/System/Library/CoreServices/SpringBoard.app/SpringBoardVmobile    % < I e f ~ ™ -Up’
      $%&(c  * j
    yah, it's definitely not plain text:

    # file com.apple.SpringBoard.plist
    com.apple.SpringBoard.plist: Apple binary property list
    Last edited by edlockW; 2008-09-04 at 02:27 PM. Reason: Automerged Doublepost
    2008-09-04 02:27 PM
  18. picassolsus's Avatar
    hi spektro,

    i have:
    1) /Library/MobileSubstrate/MobileSubstrate.dylib in my com.apple.SpringBoard.plist file
    2) /Library/MobileSubstrate
    3) /Library/MobileSubstrate/DynamicLibraries
    4) iblacklist.dylib is in the /Library/MobileSubstrate/DynamicLibraries directory

    but blocking doesn't work
    edlockW,

    Does your com.apple.SpringBoard.plist read cleanly in notepad? Or does it have funky characters like mine?

    EDIT:

    Nevermind, see that you just edited =)
    iPhone 3GS 16GB 3.0fw White + Jailbroken
    2008-09-04 02:27 PM
  19. pl_svn's Avatar
    Open SSH to iPhone;
    Grab the file /System/Library/LaunchDaemons/com.apple.SpringBoard.plist
    Check if this file has this line on INSERT_DYLD_LIBRARIES tag:
    /Library/MobileSubstrate/MobileSubstrate.dylib
    ... yes: the line is there

    If it does not have this line, MobileSubstrate is not running on your phones. So please check if you have these folders:

    /Library/MobileSubstrate (inside it must have DynamicLibraries folder and the MobileSubstrate.dylib)

    also

    /Library/MobileSubstrate/DynamicLibraries (inside it there will be a symlink called iblacklist.dylib)
    ... all these files/folders are present but...
    a) /Library/MobileSubstrate/MobileSubstrate.dylib -> is actually a symlink
    b) /Library/MobileSubstrate/DynamicLibraries/iblacklist.dylib -> is a real file

    is this correct?
    Last edited by pl_svn; 2008-09-04 at 02:50 PM.
    2008-09-04 02:28 PM
  20. edlockW's Avatar
    tried to copy /Library/Frameworks/iBlacklist.framework/iblacklist.dylib to /Library/MobileSubstrate/DynamicLibraries

    doesn't work either
    /Library/MobileSubstrate/DynamicLibraries/iblacklist.dylib is indeed 0kb size
    2008-09-04 02:38 PM
663 12311 ...
LINK TO POST COPIED TO CLIPBOARD