1. -V-O-Y-A-G-E-R-'s Avatar
    My fault. I was changing /etc, not /usr/local/etc
    You got me scared! I used to get the same error prior to tweaking everything to work I thought that I might forgot to add something to .conf file


    next question: any chance of doing a search in a doc/pdf page?? I'm not sure i've seen this possibility in Safari at all.
    Probably could be pulled out using bookmarklets, but no, there is no search function in Safari so far.
    2008-03-11 05:36 PM
  2. cazlar's Avatar
    Thanks for putting it all together, voyager. I hadn't had a chance to fix up my lighttpd setup since my last restore, but I just used your package and was up and running with your nice css in a few minutes.
    2008-03-12 12:11 AM
  3. blaze_1ne's Avatar
    This is way too awesome. Having all files accessible at my fingertips. This destroys PDFviewer by a long shot. Thanks again.
    2008-03-12 03:11 AM
  4. Lace's Avatar
    one question. do i need wi-fi or edge to view the files, i wanna use this app when im on the subway.
    Last edited by Lace; 2008-03-12 at 06:08 AM.
    2008-03-12 05:30 AM
  5. cazlar's Avatar
    No connection required whatsoever. I think there was one catch though that "localhost" won't work without a connection, but 127.0.0.1 always does.

    And step 4 means replace the default file (lighttpd.conf) with the one provided. The detailed instructions just show what has been changed if you want to do it yourself.
    2008-03-12 06:09 AM
  6. Lace's Avatar
    No connection required whatsoever. I think there was one catch though that "localhost" won't work without a connection, but 127.0.0.1 always does.

    And step 4 means replace the default file (lighttpd.conf) with the one provided. The detailed instructions just show what has been changed if you want to do it yourself.
    yup i got it, i was just having trouble finding the user/local/etc folder.
    GREAT APP!!!! a lot better than the books app and pdfviewer. lovin it.
    2008-03-12 06:28 AM
  7. kpavery's Avatar
    My fault. I was changing /etc, not /usr/local/etc
    Ahh, I did that too before I realized. Glad you got it worked out.
    2008-03-12 08:34 AM
  8. -V-O-Y-A-G-E-R-'s Avatar
    This is way too awesome. Having all files accessible at my fingertips. This destroys PDFviewer by a long shot. Thanks again.
    Not entirely. Safari cannot open large files. I couldn open two 20+ MB PDF files. But this is more slick
    Last edited by -V-O-Y-A-G-E-R-; 2008-03-12 at 10:42 AM.
    2008-03-12 10:25 AM
  9. zidane47us's Avatar
    I'm also having the 404 Not Found error. I've already copied the .dirlist directory to the /private/var/root/Sites folder. I also overwritten the lighttpd.conf file in /usr/local/etc. I just copied everything that came with the package.

    What do you think could be the problem? Little background: I have Apache and jComic before which both serve files. I uninstalled them already prior to installing lighttpd/PHP.

    TIA to all!

    Ooops! I posted too fast. Seems a hard reboot would fix it after all. Thank you for this great mod!
    Last edited by zidane47us; 2008-03-12 at 06:28 PM. Reason: Automerged Doublepost
    2008-03-12 06:28 PM
  10. Eurisko's Avatar
    I'm also having the 404 Not Found error. I've already copied the .dirlist directory to the /private/var/root/Sites folder. I also overwritten the lighttpd.conf file in /usr/local/etc. I just copied everything that came with the package.

    What do you think could be the problem? Little background: I have Apache and jComic before which both serve files. I uninstalled them already prior to installing lighttpd/PHP.

    TIA to all!

    Ooops! I posted too fast. Seems a hard reboot would fix it after all. Thank you for this great mod!
    Did you reboot after un-installing Apache? I just uninstalled, the installed Lighttp but when I ran Safari, it was still Apache.
    Get "iPod & iTunes for Dummies", it'll change your life.
    2008-03-12 06:32 PM
  11. blaze_1ne's Avatar
    Not entirely. Safari cannot open large files. I couldn open two 20+ MB PDF files. But this is more slick
    Yea that sucks, just tried opening up a couple of files I had up there. I wasn't aware of that Safari had a filesize limitation. Kinda sucks, but whatever, I'm pretty sure there's a work around no? Regardless this way still rocks!
    2008-03-12 10:11 PM
  12. mortiz's Avatar
    I have the following problem:

    I only get "Your server to go" screen at http://127.0.0.1/, I don't see my created folders. So I only get the files when I go to directory (i.e. http://127.0.0.1/PDF)

    Can I get the directories at http://127.0.0.1/? How?
    2008-03-12 10:42 PM
  13. -V-O-Y-A-G-E-R-'s Avatar
    "Your server to go"..is that what's on default welcome note from Lighhtp besides that iPhone with Welcome on its screen?

    You probably have to delete index.html in Sites folder.
    Last edited by -V-O-Y-A-G-E-R-; 2008-03-12 at 10:51 PM. Reason: Automerged Doublepost
    2008-03-12 10:51 PM
  14. rauli7's Avatar
    doesn't work for me. i really dont know why. ok thats what i did:

    1) downloaded lighttpd & PHP via installer.app

    2) went to 127.0.0.1; welcome screen was there. so lighttpd should be working fine

    3) downloaded the file attached in the first post of this thread. unpacked it...then copied the folder "dirlist" on my ipod touch to /private/var/root/Sites and renamed "dirlist" to ".dirlist"

    4) then o copied to lighttpd.conf to /usr/local/etc/ to overwrite the existing file there

    Should be everything right or not?
    then i tried 127.0.0.1 again. welcome screen from lighttpd is still there. the adding "/.dirlist" to "127.0.0.1" so it looked like "http://127.0.0.1/.dirlist"

    mobile safari kinda loaded a few seconds then there nothing except "500 - internal server error"

    whats wrong? i remember that i had an error with "404" or so

    but when i type in "http://127.0.0.1/PDF/abcdefgh.pdf " it works fine . but but thats not what i want.

    so what did i do wrong? i had apache installed beforet. maybe there r still some files which interfere with lighttpd? because i read that some people had issues with dropbear or so.
    or maybe there are some other apps which interfere with this?

    also tried to delete the file "index.html"..but still getting 500 - internal server error

    It shouldn't matter what fw i have but just in case; im using 1.1.4 (1.1.1 was it when i bought my ipod touch)
    2008-03-12 11:21 PM
  15. -V-O-Y-A-G-E-R-'s Avatar
    Did you turn off and on your iPhone? I'd do that
    2008-03-13 12:14 AM
  16. rauli7's Avatar
    yeah i did that several times. im gonna try it again....^^brb

    EDIT: reinstalled lighttpd and now theres not even the welcome screen. but i also dont have any files in ~/Sites..where do I get these Files?

    And MNPlight which uses 127.0.0.1:2007 doesn't work anymore since lighttpd is installed -.-

    EDIT2: the files are from PHP right xD?? i didnt install that...hold on

    EDIT3: still not showing the welcome page....what difference would it make if i'd use apache? got MNPLIGHT to work again...one less thing to worry about..

    EDIT4: im stupid....if i would use apache i would have to edit the config file from apache bye myself right? but now i dont have any file in ~/Sites! I don't know why but i deleted them cause i thought they r gonna come back if i reinstall again......so what should i do? complicated...

    Another Question...can I still have Apache installed? Would it still work if I turn off Apache in BossPrefs?
    Last edited by rauli7; 2008-03-13 at 12:55 AM. Reason: Automerged Doublepost
    2008-03-13 12:55 AM
  17. Shedoks's Avatar
    What is the maximum pdf file size ?
    I've tried to open pdf with 700pages (26MB) and i run into error "File is too large"
    2008-03-13 01:10 AM
  18. rauli7's Avatar
    with apache converterpro and MNPlight are working fine....
    how do i do this with apache? is there also a config file which i have to edit?

    EDIT: still not working.... deactivated apache via BossPrefs and the uninstalled lighttpd.
    then turned off and then on my iPod Touch. Installed lighttpd again. Restarted iPod. then when i go to mobile safari nad i get "404 - not found" error. I dont know why i had the "500 - internal server error" before but this is unfortunately still not working.
    Last edited by rauli7; 2008-03-13 at 03:18 AM.
    2008-03-13 01:12 AM
  19. pongster's Avatar
    I cant seem to open chm files. How do we add the ability to read chm's? or is safari unable to open chm files by default?
    pngster
    2008-03-16 04:18 PM
  20. toothpick's Avatar
    Absolutely spot on. great work buddy, just what i was looking for.

    Cheers

    Toothpick
    2008-03-17 12:44 AM
162 1234 ...
LINK TO POST COPIED TO CLIPBOARD