1. Brgiles's Avatar
    I have a 3GS that I jailbroke about a month ago with purplera1n on firmware 3.0. I was enjoying my jailbreak until I installed Supreme Preferences v2.3. I never once used any of the extended preferences and actually forgot I had installed it until I looked in my Pref app one day and discovered that SP had screwed a lot of them up. By screw them up I do not mean changed options, I mean that I can no longer access normal settings for Mail, MobileMe, Phone, Safari, Calendars, and a bunch of other rather important apps. I tried uninstalling with Cydia only to find that Cydia had no record of it in packages, meaning I could no uninstall it there. I searched the forums for a solution and most suggested I either reinstall and then uninstall SP, remove with SSH, or restore. I could not reinstall/uninstall because the current version available on Cydia will not install on 3.0. And I tried finding SP using SSH but it was not located anywhere people said it should be.

    So, a few days ago I restored my phone to a backup created immediately before the restore. This installed firmware 3.0.1 which meant that purplera1n would not work. So, while my phone was unjailbroken I noticed that MakeItMine still worked with a carrier name of "Echoes" but that everything else seemed to be back to standard iPhone firmware, including Prefs returning back to normal. So, today I jailbroke using redsn0w (which was much easier than expected, thanks iPhone Dev Team!) and found that my Prefs were back to looking like crap and hiding normal preferences. I thought it might be because I restored to a backup, so I restored again this time setting it up as a new phone. Now everything was back to normal, including the carrier name. So, again I jailbroke with redsn0w, and to my infinite frustration and disappointment SP was still there screwing up my Preferences. Granted, SP has not caused any other problems of which I am aware, but not having access to standard prefs is a pain in the ***.

    I am sorry if this is too much information, but I figured it best to include the appropriate background so that my situation is clear and everyone understands that I made considerable effort on my own to solve this problem. I am not interested in starting a flame war over the pros/cons of SP of the abilities of iMario as a developer, I just want this fixed. I am not a hacker, programmer, or developer of any sort but I do consider myself relatively computer savvy and can usually handle most stuff given the proper instruction. If you know of a solution posted elsewhere please direct me there or if you have a solution yourself, please help me out.

    Thank you,

    2009-08-21 11:59 PM
  2. Ambrose.'s Avatar
    You might want to try going here to re-download the correct version 3.0 firmware: iPhone Firmware Files | iPhone News, Help and Guides
    Replace your old file with this one and jailbreak again. I don't think you need to start over completely from scratch again, but if this doesn't work, you may want to set it up as new again and then jailbreak with the freshly downloaded firmware.

    Hope this works for you.

    2009-08-22 12:27 AM
  3. Texas Tech's Avatar
    if your phone broke right now you couldnt even take it to apple
    2009-08-22 03:06 AM
  4. Bo Troxell's Avatar
    I think your problem as Ambrose has posted is restoring from a back up. You should always set up as a new phone and then sync for your contacts and music.
    Restoring form a back up causes so many problems with jailbroken iPhones.
    2009-08-22 03:44 AM
  5. Ambrose.'s Avatar
    I hope you are correct. We'll know for sure once Brian posts his results :fingers crossed:

    2009-08-22 05:53 AM
  6. Brgiles's Avatar
    I appreciate the responses and I know my original post was long, but if you read the whole think you will read that the last thing I did was restore using iTunes and set up as a new phone, I did NOT restore from backup the last time. So, if you have any other suggestions besides restoring to a new phone (which I will try again just to be thorough) please let me know.
    2009-08-22 06:02 AM
  7. Bo Troxell's Avatar
    Hard for me to believe. Well perhaps you need to try DFU mode and restore, not shift click restore but a new 3.0 restore.
    Last edited by Bo Troxell; 2009-08-22 at 06:12 AM.
    2009-08-22 06:07 AM
  8. Ambrose.'s Avatar
    Yes, but I think you may have used contaminated firmware which is why I suggested you download fresh and try again. Did you give that a try?

    The reason I suspect this is because you reported everything as normal after setting up as new. It was only after jailbreaking that you had issues. The only files involved in the jb process would be redsn0w and the firmware, hence my suggestion.

    Last edited by Ambrose.; 2009-08-22 at 06:16 AM. Reason: Automerged Doublepost
    iPhone 3gs 32gb j/b redsn0w 0.8
    reformed winmo ppc owner
    2009-08-22 06:15 AM
  9. Bo Troxell's Avatar
    ^+1 exactly. he's picking it up from somewhere that's why I can't believe that it was a fresh restore.
    2009-08-22 06:17 AM
  10. kwall's Avatar
    Its impossible to have left over from a full restore. that is the point its a full restore. however make sure you used dfu mode and a clean copy of the 3.0 firmware which was mentioned above
    Need Assistance? Read Here Tutorial On How to Know Everything
    2009-08-23 02:33 AM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.