1. Switch Blade's Avatar
    I have a 2G 1.1.2 (OTB) that was Jailbroken and Unlocked using ZiPhone 2.6c. I'm currently runnig 1.1.4 Jailbroken and Unlocked, I have also downgraded the baseband to 3.9.

    1 - If I upgrade to 2.0 will the phone work with Rogers without unlocking?
    2 - Will there be any complication due to my downgrading the baseband to 3.9?
    3 - Last question, the new pwn Jailbreak allows the upgrade of baseband to 4.6....whats the best baseband?
    2008-07-21 06:33 AM
  2. MattOnDemand's Avatar
    nope, after they released 2.0 through iTunes, I restored to 2.0 and it locked my phone. Just use PwnageTool 2.0. Mine works now (even though i have the 3G)
    2008-07-21 08:50 AM
  3. Rounder's Avatar
    Just unlock 2.0 using Pwnage. I do happen to have the "activate only" version of iTunes that Rogers uses in store, you just plug in the phone and it activates. (Not sure if it works with a 2G, but it might, cause I plugged a 2G phone in and it said it was already activated. But just Pwn your phone and you'll be fine!
    My Mac:  iMac 21.6" 2.5GHz Quad-Core i5, 4GB RAM, 500GB, AMD 512MB Video (10.6.6)

    iOS Devices: iPhone 4 32GB (4.3.2 JB) | iPad 2 16GB (4.3.2) | Apple TV 2G (4.3 JB)

    MobileMe User
    2008-07-22 08:55 PM
LINK TO POST COPIED TO CLIPBOARD