User Tag List

  1. mafiaplayer's Avatar

    i tried to replace my not-working earpiece on the iphone 2g, after the assembly, i assessed that the earpiece is still not workin, but the microphone and homebutton is also not working now!
    I dont know whether there is something not plugged in correctly or i destroyed something, but i did all gently, so it supriced me that now the problems are gained.

    Does anyone know what can i do or what the problem is?
    I need your help pls!
    2009-02-22 12:57 AM
  2. cpjr's Avatar
    Honestly, nobody's gonna be able to tell you whats wrong without seeing/disassembling the phone. There are to many reasons/things you could have done. Know what I mean?
    2009-02-22 01:34 AM
  3. mafiaplayer's Avatar
    its very hard to say what problem, but if someone has repaired often iphones, then he can limit the problems....

    i mean he can say which opportunities there are to find the problem and repair it.
    2009-02-22 01:48 AM
  4. cpjr's Avatar
    I repair them, alot.

    Thats why I say it could be alot of things.

    could be a bad and/or loose flex cable (that was bad or you damaged). Could be a bad place on the board that got damaged. Could be that the phone had moisture damage to began with which is why the earpiece stopped working. Which could also mean any of alot of things could be malfunctioning on the MOBO to cause the issues.

    I would take it back apart and double-triple check everything. The home and mic are running on the same flex cable.
    2009-02-22 01:57 AM
  5. JStraitiff's Avatar
    it probably got damaged while you were in there

    you dont want to try to do repairs unless you know what you are doing
    2009-02-22 02:37 AM
  6. mafiaplayer's Avatar
    someone in an other forum said this:

    most likely the problems with the microphone and home button are related to one of wires are not snapped back in tight from the logic board. They are tricky to get reconnected again.

    For your earpiece what was the original problem? was it stuck in "Headphones" mode?
    the problem of the earpiece came of falling many times down....

    i think i didnt connect the flex cable right. but the earpiece doesnt work again.
    2009-02-22 10:40 AM