1. SGWilliams's Avatar
    i bought a second hand iphone 3GS 8GB the other day it was all fine locked to O2, so i JB it thru JBme.com and then unlocked it using U.snow, so put my orange sim ni the phone and the signal comes in at a healthy 5 bars, if i leave the phone then its fine the signal stays for a good few hours but if i start using it for messaging, downloding apps etc the bar slow goes down and then it says the network is restricted. i thought it might of been a case that the phone was stolen and it was reported stolen but if i take my sim out and put it back in the phone it goes back to the start again

    any ideas what it could be? could it be my orange sim is too old ? its about 11-13 months old the sim itself?
    2010-08-10 02:01 PM
  2. SGWilliams's Avatar
    bit of an update, the phone will work now for an hours or so but once it loses the signal i have to remove the sim and start again



    any ideas ?
    2010-08-18 07:30 PM
  3. mattdonut's Avatar
    are you using a 3G sim?

    tbh mate ive been with orange since the late 90s and the service and coverage is getting worse
    that bad im thinking of leaving to go to O2

    when they rang asking about next months upgrade i told the bloke about O2 and he said he wouldnt blame me if i left !!!


    anyway ring them for a replacement sim
    2010-08-18 09:11 PM
  4. SGWilliams's Avatar
    I tried my partners sim in the phone and it kinda of works until she takes the phone to a different area then she loses signal and thwn she has to pop sim back in her phone to get signal back

    Does it seem like the phone is broke ?
    2010-08-22 12:59 PM
LINK TO POST COPIED TO CLIPBOARD