1. nenitosoyyo's Avatar
    I recently moved from Rogers Pre-Paid to Telus because Telus is offering better plans. I have the iPhone 4 FirmWare: 4.2.1 , now the problem is that MMS and Data is not working for me :/ My phone was locked onto Fido a long while ago, I JB it and unlocked it with ultrasnow, I was origanlly on FW 4.0 but upgraded because I was having the MMS/Data problems and thought maybe it would fix it. I had to use custom FW because I did not save my BB of 01.59.00 for 4.0 in order to get it to 4.2.1. Yet I am still having the problems with MMS/Data not working on Telus, I never had the problem with Rogers before.

    I have the Cellular Data Network option in Network settings, i have these settings currently:

    And everything else is showing Telus and Telus and Telus, I don't understand why it is not working?

    I called Telus Client Care and all they did was make me do Network Settings Reset, which I had done many times before I called them. Only thing the guy told me to do was fiddle around with the phone more and see if you can get it to work :/ WOW lmfao...

    So I am hoping someone could shed some light... Is there any other files I could try and edit or something, or some hidden button that says "Make it work" lol. I have googled googled and nothing but cirlces of the same info.

    -Also I went back to the Telus Dealer where I bought my sim card and got a new sim card, because maybe the first one was faulty.
    -I do notice that when I turn wifi off and try to use apps like twitter my signal drops to half a bar.
    -Sometimes I get Invalid SIM when I restart or No Service
    -I am in 3G/4G zone, I live close to two towers
    -I have had Data/MMS work once in while, but almost never
    -When I first got the sim card and connected it worked amazingly :/

    Do you think something in the carrier.plist is not set right? Is there something I could edit in there? I have googled so much and have not found anything similar to my problem, either the info is to old and doesn't work.
    Last edited by nenitosoyyo; 2011-03-06 at 07:52 AM. Reason: Automerged Doublepost
    2011-03-06 07:52 AM
  2. 32dave's Avatar
    when you plug it into itunes does a carrier update come up
    2011-03-06 07:23 PM
  3. nenitosoyyo's Avatar
    Thanks for the reply

    When I plug it in, it does not show anything for a carrier update, it is at TELUS 9.0 which I assume is the latest update.

    Also today I decided after so much fiddling around that maybe the proxy mms didn't need a port number, so I removed the :80 and you wouldn't believe what happened, it worked perfectly, but after about 5 to 7 mins it stopped working, I managed to update my twitter a load google maps and send a mms pic... But now its not working again :/ So I really don't know whats going on.

    I changed back to my old LG Shine(Sadly a big downgrade from iPhone 4) I was finally told by Telus Client Care that any iPhone 4 that is not with Telus will not work with there Data/MMS, he said it was grey market phone, so I thought I would let people who decide to do what I did and give them a warning ahead of time. Not to go with Telus with there iPhone 4.
    Last edited by nenitosoyyo; 2011-03-07 at 10:36 PM. Reason: Automerged Doublepost
    2011-03-07 10:36 PM