1. Dtpl's Avatar
    I purchased a Nokia E71 from Wal-Mart, activated it, called from it and it worked, then I put the SIM in my iPhone 3G but the 3G did not recognize it. It just said "No Service". I went into settings and I believe Im on baseband 5.15.04 (it says Modem Firmware: 05.15.04)

    The phone is running iOS 4 jailbroken with sn0wbreeze. Please help! I really would like to use my iPhone!!!
    2011-10-01 02:12 AM
  2. Dtpl's Avatar
    Got it fixed. Had to upgrade to iOS 4.2.1, jailbreak with Redsn0w and have it replace the baseband with the ipad's baseband then unlock with ultrasn0w. Works now, thanks
    2011-10-01 04:58 AM
  3. vtails's Avatar
    I think that upgrading the baseband was a bad idea you dont need to be unlocked to make it work,I have a 3g running prefect on ST without unlock.You wont be able to use any F/W except custom now but I did read that some one was working on something to down grade the 6.15 BB maybe it will happen.
    2011-10-06 01:24 AM
  4. Dtpl's Avatar
    I cant update anyway, iPhone 3G only goes up to 4.2.1 and thats what Im on, so no big deal at all...
    2011-10-06 01:26 AM
  5. vtails's Avatar
    I was just thinking about when you sell it and get I4,I passed on some good price's on i3gs because of the BB issue,but I have a 3G 3GS and i4 now with the i4 I just cut the simm and sync'd with itunes and it works perfect on 4.3.5 without jailbreaking,with my 3g I installed the commcenter patch and edited the carrier.plist and ran the .mobileconfig file so I guess those setting made it easy for my i4,I didnt want to J/B cause the battery life isnt that good on i4 and I had to put new battery in the i3g.This is the best deal I ever got in cellphones!!!
    2011-10-06 02:13 AM