1. shane8002's Avatar
    alright guys so about 3 weeks ago i was using my iphone on 3g h20 network randomly the 3g logo disappeared. My data cap had not been reached because i reset the data counter everytime i renew my monthly 60 dollar plan. So then i tried resetting the network settings then i tried the manual apn editing, tried the comm center classic patch tried pretty much everything i could find on the internet to no avail. So i gave up just thinking that maybe somehow i did hit the data cap. Now i just refilled my account yesterday i was hoping data would come back nothing. So today i completely restored the phone set it up as a new iphone and jailbroke it again using the latest redsnow. Any ideas guys im completely stumped at this point and have no idea what to do. Ive done sim card pulls hard reset soft reset everything please help me only had the iphone about a month now everything was perfect the first 2 weeks until i lost data. wifi works fine as do calls and text but even when i manually configured the mms using the correct settings nothing.
    2012-01-29 02:54 PM
  2. duromega's Avatar
    Theres nothing wrong with your phone, you just reached the limit (1GB) on your monthly plan

    2012-02-01 11:54 AM
  3. Jj2345's Avatar
    My girl had the Same problem with them,she had to call h2o and tell them to reset it manually.but that 1 gig a month sucks so I had her leave and added her to my att family plan,which now included unlimited mobile to mobile,text and 3 gigs of data.
    The best part is since she already has a iPhone she doesnt get a 2yr contract
    2012-02-02 01:43 AM