1. buenhec's Avatar
    Two weeks ago in Mexico I purchased a Telcel mini sim and put it in my Sprint Iphone 4s. It worked perfectly. For $2 per day (prepaid) I got all my imessage, emails and forwarded skype calls. I was so happy saving on roaming charges.

    Last week in Mexico near the border I inserted the Telcel sim again. Now all I get is ATT. If I manual select carrier-Telcel, I get 1 unusable bar, then ATT.

    I tried it again yesterday, same thing. I kept driving away from the border (ATT tower), about 40 miles in and an hour later I finally got Telcel, maybe because there was no AT&T signal around. My phone worked perfectly all the way back to the US with Telcel and did not pick up ATT again.

    This is very frustrating. I put the Telecel sim into my wifes iphone4s and same thing happened. I have not upgraded software or changed anything, why wont the I4s detect Telcel in Telcel territory. Could an update have been pushed to my phone or something?

    Help?
    __________________
    2012-02-06 04:00 AM
  2. duromega's Avatar
    Make sure to install the "other" firmware (9A406) then go to carrier turn off automatic and select telcel when you're in Mexico and AT&T when you're in Texas I was having the same problem in the Dominican Republic did this and it worked like a charm




    2012-02-06 10:12 AM
  3. buenhec's Avatar
    Make sure to install the "other" firmware (9A406) then go to carrier turn off automatic and select telcel when you're in Mexico and AT&T when you're in Texas I was having the same problem in the Dominican Republic did this and it worked like a charm
    Thanks, I am already on 9A406. I also jailbroke with absinthe but this happened pre and post jailbreak. I do manually select but I get ATT anyway. Im in sunny California. Reinstall maybe?

    Thanks!
    2012-02-06 05:04 PM
  4. duromega's Avatar
    yes that's what I did when I was in DR I've reinstall 9A406 it worked!




    2012-02-07 01:10 PM
  5. buenhec's Avatar
    yes that's what I did when I was in DR I've reinstall 9A406 it worked!

    Did a fresh install and same problem. I will try a different sim then go to Sprint. It worked before, I cant think of anything that changed.
    2012-02-13 06:06 PM
  6. duromega's Avatar
    Sprint doesn't no longer allow international unlock (GSM unlock) they changed their policies!




    2012-03-16 10:30 AM
  7. buenhec's Avatar
    New policies? It turns out I went to Telcel, many of their Iphones are having the same issue, they said its a problem with the carrier/software compatibility. I then went to the other GSM carrier Movistar and bought a prepaid sim from them. It works perfect on both my wifes and mine. No more problems whatsoever.

    A friend of mine just got her new Sprint 4s, I put my Mexican Sim in and it would not work. She will call Sprint to unlock. I will post what they say. Thanks.
    2012-03-16 04:58 PM
  8. duromega's Avatar
    Exactly now you have to be a good standing costumer and request the unlock from sprint :/




    2012-03-18 08:04 PM
LINK TO POST COPIED TO CLIPBOARD