1. rld77's Avatar
    I need urgent help from some experts to get my phone working.

    I got a new iphone 4 (with iOs 4.1) last week and tried to jailbreak it yesterday evening using Greenpois0n.

    It completed successfully and I got loader to install Cydia. After I launched Cydia, it started re-organization. At that moment, I accidently rebooted the phone. After reboot, I lost all the default apps (Safari, Mail, iPod, Camera, Weather, Settings etc.). I can only see the apps that I installed after I got the phone. All pre-installed apps have disappeared. I tried spot search and no luck.

    I tried to update it back to iOs 4.1 using iTunes but it does not let me do that.

    I now have a jailbroken phone which has few apps that I had installed and Cydia. I can install new apps using Cydia.

    I have already tried with iTunes to restore to 4.1 using ipsw file. It fails after giving error - Cannot be restored. This device is not eligible for the requested build.

    Only option that I know to go back to 4.1 is to modify hosts file to point to Cydia server to look at my 4.1 SHSH and then restor to 4.1 using iTunes.

    From my phone, I have uploaded SHSH using Cydia. It currently shows Pending TSS request. I need to wait for some time (may be a week - as per blogs I read) to do the next action.

    I am not sure if using TinyUmbrella, I can do this quickly rightaway or not. Trying to read blogs to understand that. Any help would be appreciated.

    2010-12-03 09:29 PM
  2. salander85's Avatar
    Yes, TinyUmbrella is your way out. Run it, follow its instructions, and make it work for you! That's really weird about the whole disappearance thing... I would actually think it'd be easier to restore to the latest firmware and THEN downgrade, that way you guarantee that you get the essential apps back. It'd be pretty hard to use a phone without the phone app.
    2010-12-26 12:16 AM
  3. Beastaroni's Avatar
    This also happened to me I'm on iPad 2 5.1.1 when jail broke my iPad I clicked on cydia my iPad crashed and all pre loaded apps were gone I tried resetting but to no avail. Please help! And I jail broke it using absinthe 2.0.4 I've used everything on this thread nothing is working
    2012-06-05 07:52 AM
  4. cyb3rduck's Avatar
    Why not try redsn0w and using iOS 5.1.1? You can ask redsn0w to personalise your downloaded official iOS 5.1.1 file with the .SHSH files that TinyUmbrella saved for you (usually located in CUsers\<Your User Name>\.shsh by default).

    Once you have those files open redsn0w, then click Extras > SHSH Blobs, then click stitch. You can either use local SHSH files or the copies stored with Cydia. This will modify your IPSW and save a new one in the same location as the original file. Once complete, go to Extras > Pwned DFU mode. Enter Pwned DFU mode then open iTunes which should say your phone is in recovery mode and must be restored with iTunes. Press shift and click restore, then specify your customised IPSW you made earlier. Worked like a charm for my iPhone 4 and its the method I used to clean install the OS. At least that way Safari, Camera and the other apps that stopped working will work fine this time. It is important to allow Cydia to prepare the file system fully - otherwise it'll damage your apps causing headaches later.
    2012-09-04 04:48 PM