1. j3wbagell's Avatar
    I hate doing this ****. Is there away to downgrade from 4.2.1 my phone is still restoring so I don't know what baseband I'm on even though I downloaded directly from iTunes.

    I wanted 2.0 but what is the stock firmware on model number ending in 41

    Ok here's an update:

    I'm on (stock) 4.2.1 BB 5.15.04 and the is to eventually unlock.
    I have like 30 minutes before 3.1.3 is downloaded but I want 2.0 what do you think?
    Last edited by j3wbagell; 2011-12-14 at 04:40 AM.

    My parents didn't pay for my iPhone.
    *If i help you hit that "Thanks" button for me*
    2011-12-14 04:21 AM
  2. iYeow's Avatar
    No, version 2.0 is obselete and cydia doesn't support it. The least and best fw for 3g is 3.1.3
    2011-12-23 07:24 AM
LINK TO POST COPIED TO CLIPBOARD