1. mdwsta4's Avatar
    i previously had an unlocked phone via ziphone on 1.1.4. everything was fine, but today i decided to upgrade to 2.0 via pwnage. so i downloaded the pwnage app, got the process started, but after the pineapple came up and itunes wanted me to upload the custom firmware i got a 1604 error. i cleared whatever file was in the data recovery folder and tried it again. same problem. i redownloaded pwnage, then downloaded the 2.0.1 version, nothing made a difference.
    i tried to download 1.1.4, but every time i do it ends up as a folder with subfolders inside it. not a lego looking block that ends in ipsw.
    so now nothing works. my phone will do nothing but show the itunes logo with a cable saying connect it to itunes. every time i try to do the process i get the 1604 error message.

    i am extremely frustrated as i've been trying to fix this problem all afternoon. i don't care if i even get 2.0 anymore. i just want my friggin phone to work!!!!!

    thanks SO much!
    2008-07-21 02:04 AM
  2. wd_stroke's Avatar
    Here are the steps for a successful 2.0 to 1.1.4 downgrade for those of you that updated to 2.0 and realized what a mistake it was. (Thanks goes to Geeb for finding the iTunes 7.5 solution, Thanks goes to Crumpx for the pwnage method). Note that this has been performed on a PC.

    Ok, so you updated to iTunes 7.7 and then installed 2.0 and you’re stuck. Here are the steps to downgrade to 1.1.4. Note that the result of this guide will be that you will be back to 1.1.4 version of firmware with baseband of 2.0 (4.05.04_G).

    Step 1) The first problem in your downgrade is that you probably are getting error 20 in restore mode and error 160x in DFU mode. This is due to iTunes 7.7. So, you now you need to uninstall iTunes 7.7 and install iTunes 7.5. Make sure after your iTunes 7.7 uninstall you reboot your pc as it requests you to.

    Note for OSX users:
    If you are on OSX and want to attempt to downgrade your iTunes, you can try these steps:

    Load up Terminal and type the following:
    killall iTunesHelper
    sudo -s
    rm -r /Applications/iTunes.app
    rm -r /Library/Receipts/iTunesX.pkg
    rm ~/Library/Preferences/com.apple.iTunes*
    rm -r /Applications/iTunes.app
    rm -r /Library/Receipts/iTunesX.pkg
    rm ~/Library/Preferences/com.apple.iTunes*
    rm -r /System/Library/PrivateFrameworks/MobileDevice.framework

    Step 2) Now that you have iTunes 7.5, you will still have the DFU driver for 7.7. This is good and will allow the process to work. Put your phone into DFU mode using the DFU steps. Make sure you follow these step. You will not have any display on your device in DFU mode. If you see the cable and connect to iTunes, you did not get into DFU mode.

    Step 3) Restore using iTunes 7.5. You will get an error like 1011, 1012, 1013, 1015. This is normal and expected. An error 1601, 1602, 1600 or anything else is not ok.

    Step 4) Once you get error above, leave iTunes open and kick your phone out of restore mode. I recommend just loading winpwn(PC) or pwnage(MAC) and pwning the device at this point. If pwnage fails to work, you need to restore your phone again. You should be able to use normal restore mode, however. Other ways to kick out of restore mode may be ibrickr, jailbreak 1.1.2 (boot phone), iLiberty+.

    Step 5) Once completed, you have a pwned device with baseband 4.05.04_G from firmware v2.0.

    Step 6) To get back to 04.04.05_G (1.1.4 baseband) load bootneuter. If you don’t have this, install it from installer. Run bootneuter with Neuter, 4.6, and unlock. When it’s done, you will have an unlocked 04.04.05_G right back where you started. Unfortunately, this only works if you have neutered your phone before the upgrade. If you did not, you will have to follow the steps below instead.

    If you get a boot neuter error like 05, 02 or such, you need to follow these steps. Unfortunately, there is no safe answer to this one.The only method I know of to do this is to use a patched version of Ziphone as described here. Before you do this, you should know the risks. Read my Ziphone warning here. Your other option is to just wait for dev teams pwnage v2.0. Direct download link for pc and mac and instructions for use.

    Troubleshooting:
    Some of you have reported “I am in DFU mode and keep getting error 20 from iTunes restore”. Answer, you are not in DFU mode. Follow the guide and the DFU link. An iPhone in DFU mode has no image on the screen and looks powered down.

    Some of you are reporting error 160x (1600, 1601, 1602, 1604 etc) on the iTunes downgrade while in DFU mode. I suggest trying another PC. You may still have some residual files left over from the 7.7 install. Make sure you are in iTunes 7.5 with drivers from 7.7.


    DFU tool download:
    http://www.savefile.com/files/1678756
    Last edited by wd_stroke; 2008-07-21 at 02:27 AM.
    =======================================
    Every time you download music, GOD kills a kitten.
    =======================================
    2008-07-21 02:23 AM
  3. mdwsta4's Avatar
    i saw that and tried that, but again, as mentioned in my post, i can't seem to find or get the correct 1.1.4 firmware file. when i download it, the end result is a folder with a bunch of different files in it. it is not a .ipsw lego looking block file.

    this is what i'm looking at
    2008-07-21 02:39 AM
  4. pncntigger's Avatar
    Try downloading the ipsw with firefox. If you download through Safari, Safari will automatically extract that file.
    Don't forget the Thanks if I helped
    2008-07-21 02:59 AM
  5. mdwsta4's Avatar
    well that was a great help, thank you.
    i did that and am not getting the error stated in the how-to. my error is just '20'
    i have two versions of ziphone. one normal and the other baseband eraser or something like that. both say 'permission denied' when i connect my iphone.

    so i guess i get to step 4 before i can't go any further. ziphone isn't working, and when i use pwnage again i go back to the 1604 error. i only have pwnage 2.0.1 if that makes a difference.
    also, if it makes a difference, the icon on my phone is itunes and the usb end of the connector, not the 30pin connector.
    2008-07-21 04:36 AM
  6. compton,Tx's Avatar
    Now you need to pwn it in expert mode if you get error 20. Try it again and it should work.
    2008-07-21 04:51 AM
  7. mdwsta4's Avatar
    using the 2.0.1 pwnage? and i am guessing that will upgrade my firmware to 2.0 (like i originally wanted)?
    what's the difference in the expert mode?
    when i go into expert mode it asks me to chose my firmware. but when i select 1.1.4, it tells me that's not the right one and continues to use 2.0. the next step has a bunch of options for bootneuter, general, install, etc. i just did install. looks to be doing the same thing as it did before.
    Last edited by mdwsta4; 2008-07-21 at 04:59 AM.
    2008-07-21 04:54 AM
  8. compton,Tx's Avatar
    Yes, it's a workaround for pwnage, and it only supports 2.0 and newer. If you want 1.1.4 back you will need to do a lot of crap to downgrade and get back.
    2008-07-21 05:07 AM
  9. mdwsta4's Avatar
    i went through the whole process again using expert mode and it gave me the 1604 error again. i deleted and downloaded new everything, switched USB ports, and still came up with the same result.

    and stupidly it looks as though i also moved the incorrect itunes library when downgrading/upgrading back and forth with 7.5 and 7.7 so i lost all my playlists/ratings in itunes as well. fan-fvcking-tastic.

    so i'm still stuck with a bricked iphone.
    2008-07-21 05:40 AM
  10. compton,Tx's Avatar
    So where are you now? iTunes version, what is your phone in (restore mode picture)? Try not to lose it, you can get it back.
    2008-07-21 06:03 AM
  11. mdwsta4's Avatar
    i'm back to where i started. 1604 error, itunes/usb picture, itunes 7.7, pwnage 2.0.1, firmware 2.0
    2008-07-21 06:09 AM
  12. compton,Tx's Avatar
    Are you going into true DFU mode (Black Screen, no pic) and restoring?
    2008-07-21 06:18 AM
  13. mdwsta4's Avatar
    i'm quite certain i'm in DFU mode, yes. when i follow pwnage's app to get into DFU it says i'm successful. blank screen, looks like the phone's off. then when i go back into itunes and click option/restore to select my firmware the screen turns white, then the screen turns black with the pineapple logo.
    2008-07-21 02:34 PM
  14. Gavin_T's Avatar
    Same here, my iphone is now a brick.

    I mean I know I wanted the new 3G one but this is forcing my hand a bit :-)

    Anyone any Ideas.

    How about the Dev Team?? all my base band etc has been wiped. Ive done about 8 1st gen phones with pwnage and not had any problems bar 1.

    Note to all wait before you upgrade to 2.0, it does seem like theres still a few glitches
    2008-07-21 02:46 PM
  15. eddieespinal's Avatar
    I'm having big big issues with my iphone. I bricked it this morning trying to install the custom firmware 2.0.

    Right now my iphone boot and only shows the itune recovery mode. I won't boot to the home screen.

    I tried so many things, but nothing is working. Every time i tried to restore my firmware with itunes 7.7 i keep getting an 1604 error. I don't know what else to do at this moment. I spent more than 5 hours straight and can't find a way to fix it.

    Can anybody please help me fixed my problem?
    2008-07-22 01:44 AM
  16. hiflyer's Avatar
    Maybe some of the problems using the pwnage tool 2.0 is not following the instructions. On the BigBoss guide for installing pwnage 2.0 is:

    Item #1 is to restore to 2.0 .... this is a link to his guide.

    Pwnage 2.0 Guide - iPhone News & Review
    2008-07-22 02:23 AM
  17. jettrue's Avatar
    Too bad the step by step instructions on this site don't state that, in fact it suggests staying at 1.1.4 "or wtvr you're on."

    I was going to ask here whether or not updating to a fresh 2.0 would be a good idea; it seems like a good idea to start fresh.
    2008-07-22 04:10 AM
  18. mdwsta4's Avatar
    i followed this link:
    Hack that Phone - Step 1: Unlocking 1st generation iPhones

    still didn't matter and my phone is STILL bricked! no one's been able to come up with a solution that has worked for me

    Maybe some of the problems using the pwnage tool 2.0 is not following the instructions. On the BigBoss guide for installing pwnage 2.0 is:

    Item #1 is to restore to 2.0 .... this is a link to his guide.

    Pwnage 2.0 Guide - iPhone News & Review
    well i finally fixed my phone... kind of.

    was on the phone with apple support for an hour yesterday thinking they could do something (of course they couldn't). so i took it into a store today and they gave me a new one. so... at least that worked!
    Last edited by mdwsta4; 2008-07-23 at 11:35 PM. Reason: Automerged Doublepost
    2008-07-23 11:35 PM
  19. danoodle's Avatar
    i've ran into the problems u guys ahve with a bricked iphone doing the OP steps. when i couldn't get out of recovery mode, i just opened iliberty and then did another jailbreak, downgrade bootloader and allow 3rd party add via wifi and now in normal mode, if it helps remember to thank
    2008-07-24 11:49 PM
  20. princemarko's Avatar
    Guys, friends iPhone in continous reboot, and the USB port says its drawing too much power so iTunes wont recognize it as it shuts off the USB. Now what? I let the iPhone drain the battery but it still wont charge because of the power issue.
    2008-07-25 12:35 AM
25 12
LINK TO POST COPIED TO CLIPBOARD