1. ripshion's Avatar
    I cannot toggle my Show Caller ID function ON or OFF. Anyone else experiencing the same problem? It is set to OFF, but when I make a phone call it will show my number on the receiving phone. Is there any solution to this problem?
    2008-07-30 04:59 PM
  2. mylexon20s's Avatar
    this happened to me to. For some reason, after I turned password lock on, it would not let me change the show my caller id. I turned off passcode and it let me alter that funtion
    2008-07-31 01:37 AM
  3. ripshion's Avatar
    Bump...........


    So no one else experiencing this problem?

    Pwnage 2G phone from 1.1.4.
    2008-08-01 06:22 AM
  4. cyber16's Avatar
    Did anyone figure this out?
    I have the same issue.
    Not sure if I should reapply 2.0
    Or just go back to 1.1.4
    2008-08-03 03:31 PM
  5. ripshion's Avatar
    I reloaded Pawnge 2.0 and it did not fix the problem for me. I am still not able to toggle it ON or OFF. My toggle setting is fixed on OFF but my Caller ID still shows up on the receiving phone (?).

    If anyone has a fix for this please share it, thanks!
    2008-08-04 12:53 AM
  6. gonano's Avatar
    I got the same problem after pwning to 2.0 and also 2.0.1
    It was working before with 1.1.4 and below on T-Mobile. So it's not a carrier issue like I read someone say somewhere about this matter.

    Turning off Passcode Lock did not solve the issue for me.

    For now you could manually dial the number with *67 before the phone number. *675557890 or *67(area code)5557890 I know it's not the best way and that most people know about *67 in the U.S but some people may not know.
    Last edited by gonano; 2008-08-12 at 12:02 PM. Reason: Adding a temporary fix
    2008-08-12 11:58 AM
  7. gauravs82's Avatar
    I had the same problem and this worked for me. I hope this helps for everyone else here.


    Put the phone in Airplane Mode and then go to your Phone settings and switch your caller ID to ON, from now on it should work as usual.

    original post: Hackint0sh - View Single Post - Show my caller ID Switch gone in 2.0
    2008-08-13 12:02 AM
  8. cyber16's Avatar
    gauravs82,
    THANK YOU!
    I tried it once prior without any luck
    Just tried again and it took.
    Turned airplane mode ON
    Then I hit the home button,
    Went back into settings, and low behold I could toggle the show caller id from on to off,
    changed the show caller id to off, hit home button again.
    Placed a call just to check that its now working, indeed it was, no number shown.
    Went back into settings and shut off airplane mode.
    After all this, the show caller id remains usable, I can still toggle on/off

    Thanks much...
    2008-08-13 05:17 AM
  9. westc0ast's Avatar
    worked for me too thanks gauravs82
    All information contained in my post came to me in a dream. I don't even own an iphone.
    Don't forget to hit the thanks button
    2008-09-01 08:14 AM
  10. cheldan's Avatar
    Thanks gauravs82, worked for me too

    Cheers!
    2008-09-03 06:10 AM
  11. pitbulvig's Avatar
    I had the same problem and this worked for me. I hope this helps for everyone else here.


    Put the phone in Airplane Mode and then go to your Phone settings and switch your caller ID to ON, from now on it should work as usual.

    original post: Hackint0sh - View Single Post - Show my caller ID Switch gone in 2.0
    This was driving me nuts! Did a search and find this post and had to say thanks!!
    [FONT="Arial Black"]
    2008-09-12 05:08 PM
  12. pakiguy's Avatar
    this problem came back on 3.0 now and the show my caller id is dim once again . but if i downgrade to 2.2.1 and do the airplane mode it fix itself
    i am having a 2g phone any help on how to fix this on a 3.0
    2009-06-22 10:12 PM
  13. vmadayag's Avatar
    same thing happened here upgrade to 3.0 on (2G) phone.
    [img]LINK TO IMAGE[/img]
    2009-06-24 05:48 AM
  14. westc0ast's Avatar
    it's back for me too on 3.0. but on 3.0 when in airplane mode you can't go into phone settings. help

    well i just updated my carrier.plst to fix the mms image resolution and guess what? i am now able to toggle my caller id.i guess that the carrier.plst is the culprit.

    hope this helps
    Last edited by westc0ast; 2009-07-03 at 08:07 AM. Reason: Automerged Doublepost
    All information contained in my post came to me in a dream. I don't even own an iphone.
    Don't forget to hit the thanks button
    2009-07-03 08:07 AM
  15. ddfilms's Avatar
    it's back for me too on 3.0. but on 3.0 when in airplane mode you can't go into phone settings. help

    well i just updated my carrier.plst to fix the mms image resolution and guess what? i am now able to toggle my caller id.i guess that the carrier.plst is the culprit.

    hope this helps
    what carrie ipcc did you use. Mine still wont toggle.
    2009-07-04 07:16 AM
  16. westc0ast's Avatar
    2shared - download carrier.plist
    from http://www.modmyi.com/forums/t-mobil...ml#post4666521
    this post fix my pic resolution and toggle issue
    Last edited by westc0ast; 2009-07-07 at 07:42 AM.
    All information contained in my post came to me in a dream. I don't even own an iphone.
    Don't forget to hit the thanks button
    2009-07-07 07:38 AM
  17. pakiguy's Avatar
    didnt work but atleast the pictures r coming more clear then before and a new menu is now at phone setting called international assist on off menu is there

    but caller id still cant be on and off

    u can make it go in airplane mode in the sbs setting
    just go to phone and make sure u have airplane mode icon in the sbs setting on
    click it and u in the airplane mode and now when u go to caller id setting it works on and off clickable
    but as soon as u turn airplane mode off it dims it self and
    now off and on no longer works again..

    the funny thing is not everyone having this problem only a few of us and we have to find a way to fix it
    Last edited by pakiguy; 2009-07-07 at 10:40 PM. Reason: Automerged Doublepost
    2009-07-07 10:40 PM
  18. bobaloop's Avatar
    I had a problem getting my caller ID to toggle on my iPhone 3gs, after trying all of the suggestions I removed my Sim Card cleaned it and re inserted it into the iPhone and sure enough when I clicked on show my caller ID it was highlighted and I could select on or off. I hope this helps. bobaloop
    2010-04-27 01:23 PM
LINK TO POST COPIED TO CLIPBOARD