1. iMack007's Avatar
    Hi all.
    I've used Pwnage on both my iPhone 3G & my wife's iPhone 2G. Both work very well....until today. I have discovered that my 3G iPhone will not allow me to install some apps as they are dependant on something that is messed up on my phone. Cydia reports that I have one essential upgrade, but won't let me install that either!

    The message is as follows:
    Source Error...unable to make backup link of '.usr/lib/bisubstrate.dylib' before installing new version

    The original file that needs updating, which other apps are dependant on is;mobilesubstrate

    Has anyone else come across this problem or know of a fix for this please? I have tried re-installing it, but same result.

    If I want to remove it in order to reinstall it, it advises me that it will additionally remove many other programs of mine such Winterboard and mostly other graphical apps.

    Any help will be greatly appreciated.

    I'm on FW 2.0.1 Jailbroken with Pwnage.

    Thanks in advance.

    I'll also post this in the Cydia section incase it falls under that category.
    2008-09-19 03:26 PM
  2. Poseidon79's Avatar
    Upgrade your pwnage and then create a new custom fw for 2.1 and restore. This will fix both your error problems and firmware bugs at the same time. When you're done restoring set the phone up as new in iTunes and resync your data.
    2008-09-19 03:28 PM
  3. iMack007's Avatar
    If anyone else is interested how the problem was solved; I simply removed Mobilesubstrate and allowed it to uninstall all dependant apps (made a note of them though), then re-installed Mobilesubstrate followed by the other removed apps.

    All is well again.
    2008-09-19 11:43 PM
LINK TO POST COPIED TO CLIPBOARD