1. gammada's Avatar
    I tried to update my previously pwnaged iPhone to version 2.2.1 (from 2.2) on a Mac with Leopard 10.5.6 on it. As you might have read in other places, this is not a good idea since the phone cannot be put into DFU mode unless connected to a hub between the iphone and the computer or if you install older USB drivers on the system -which conflict with QT 7.6 and also wreak havoc on the system-

    So after attemping to return my iPhone to life using all listed tricks on the net, the solution that worked for me was to use a PC to "Update and Restore" the iPhone to factory specs using iTunes latest version, then to install .NET framework from MS, then Quickpwn and follow the app's instructions.

    Be careful thou. I managed to put my iPhone into DFU mode twice on the Mac and if you do that and then attempt to restore on the PC, iTunes will not detect it or will erupt an error. You gotta have your iPhone in restore mode, then on Quickpwn use DFU.

    Hope this helps someone.
    2009-02-27 03:58 AM
  2. JStraitiff's Avatar
    well its not true that you cant get it into dfu mode on a mac... you just cant do dfu work (if that makes any sense)

    thereare a couple fixes for that issue... i would never consider using a pc to do anything with my iphone
    2009-02-27 04:01 AM
  3. dejawoo's Avatar
    If you have run any 'DFU fix-Automator scripts'before the QT update,the latest version of it sometimes causes serious problems.Some people have no access to keyboard or trackpad&even can't plug in a mouse.
    These are some solutions for who has trouble with it:
    *If you still have access to your keyboard and mouse,you can copy the backup files(it should be under Backup_IOUSBFamily_kext_10_5_6 on your desktop)to where the automator script was,Install_IOUSBFamily_kext_10_5_5on your desktop.Just run the automator script again,it will copy those 'original' files to the right location,then change the permissions correctly&reboot your machine.
    *If you already ran the QT update&you're unable to access any input(usb or otherwise),you can SSH into your machine and run these commands one by one.If you had trouble with the automator script,you can open up the terminal&do this too,manually.
    sudo rm -R /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBHub.kext
    sudo rm -R /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/IOUSBCompositeDriver.kext
    sudo cp -R $HOME/Desktop/Backup_IOUSBFamily_kext_10_5_6/AppleUSBHub.kext /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/
    sudo cp -R $HOME/Desktop/Backup_IOUSBFamily_kext_10_5_6/IOUSBCompositeDriver.kext /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/
    sudo chown -R root:wheel /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBHub.kext
    sudo chmod -R 755 /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBHub.kext
    sudo chown -R root:wheel /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/IOUSBCompositeDriver.kext
    sudo chmod -R 755 /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/IOUSBCompositeDriver.kext
    sudo rm -r /System/Library/Extensions.mkextprivileges
    sudo touch /System/Library/Extensions
    sudo reboot
    *Your machine will reboot after prompting to update boot caches&the files should be back to the standard 10.5.6 ones.
    *In case your Mac is not recognizing your iPhone in DFU mode,use a usb hub in-between the DFU device&the Mac&insert/reinsert the iphone’s usb cable.
    2009-02-27 03:01 PM
LINK TO POST COPIED TO CLIPBOARD