1. thagoods89's Avatar
    It keeps say "the iPhone could not be restored because the firmware file is not compatible"..i was running 3.1.2 jailbroken with blackrain and unlocked with snow...i upgraded to 4.0 using pwgage now i wanna go back...i miss my apps ...what could be wrong i went back to itunes 9.1.1 stil no luck..
    2010-06-28 03:13 AM
  2. RetiredBilly's Avatar
    I'll bet your issue is that you did not save your shsh blobs on the cydia server.
    2010-06-28 04:22 AM
  3. thagoods89's Avatar
    thats probably it...i dont even know what shsh blobs are....

    So what do i do from here.lol...
    Last edited by thagoods89; 2010-06-28 at 08:17 PM. Reason: Automerged Doublepost
    2010-06-28 08:17 PM
LINK TO POST COPIED TO CLIPBOARD