1. Contivity's Avatar
    Finally I have something to share. I have been stuck with my iPhone 3GS 3.1.3 on 5.12.01 using spirit until I found this guide:
    From iPhone 3GS 3.1.3 Spirit Jailbreak to iOS4 Sn0wbreeze | Life in 0 and 1

    It uses the spirit2pwn. I tried it and it works.
    2010-06-29 12:43 AM
  2. ranova's Avatar
    Wow, this works.

    I had spirit'd 3.1.3 (with only 3.1.3 shsh blobs on the server) and the old bootrom.

    Nothing worked upgrading to a pwn'd 4.0. Followed this guide and it works great! Jailbroken and unlocked 4.0 3GS
    2010-06-29 02:20 AM
  3. hasteveha's Avatar
    will this work for the new bootrom?
    2010-06-29 02:44 AM
  4. Contivity's Avatar
    I don't think that it will work. Pwnagetool specifically can't crack the new bootrom.

    I used to incorrectly thought that bootrom is the modem firmware. If you're not sure and what to make sure that your understanding of bootrom is correct then check here: How to check iBoot (bootrom) version
    2010-06-29 04:00 AM
  5. hila47's Avatar
    not working to me.. old bootrom..
    i have error 2 while trying to restore 4.0 custom file..
    2010-06-29 09:07 AM
  6. Contivity's Avatar
    Did you get 1600 or 1604 while trying to upload iOS 4? What happen when u run blackrain in restore mode?
    2010-06-29 09:20 AM
  7. hila47's Avatar
    Ohhh yehhhhhh finally i have Cydia again!!!! ))
    i got error 2 on windows.. so i used my MAC.. it works great!
    THANK YOUUUUUUUUUUUUUUUUU!!
    2010-06-29 10:15 AM
  8. 100h4x's Avatar
    I didnt back up my 3.1.3, such an idiot i am...Cant i downgrade without SHSH?
    2010-06-29 02:21 PM
  9. hila47's Avatar
    I didnt back up my 3.1.3, such an idiot i am...Cant i downgrade without SHSH?
    as i know.. without SHSH iphone 3gs can-not be downgraded..
    2010-06-29 02:29 PM
  10. maoshouse's Avatar
    it worked! thankyoU!
    2010-06-29 03:44 PM
  11. aznboii's Avatar
    does this really work with new bootrom 05.12.01???

    i only need jailbreak no unlock since i already have AT&T
    2010-06-30 03:57 AM
  12. Contivity's Avatar
    05.12.01 is not bootrom. That is modem version. I am on mobile so hard to give you link, but Google it. Bootrom should be 359.3 or 359.3.2, the latter being the new one.

    Usually it is also characterized by the serial number. The two digits before the alphabet in the serial marks the week of production. If yours before 39, you have a big chance of having old bootrom.
    2010-06-30 04:21 AM
  13. maoshouse's Avatar
    oh you might want to change the guide. the modded 4.0 from sn0wbreeze still had a messed up ibooks for me. i had to restore to a pwnagetool 4.0 on top of it to fix it.
    2010-06-30 04:36 AM
  14. aznboii's Avatar
    i just wanna make sure it works with the 3gs:

    version:3.1.3 jailbroken with spirit
    model: MC136LL
    modem firmware: 05.12.01

    thanks
    2010-06-30 04:55 AM
  15. maoshouse's Avatar
    go see what your serial number is.

    mine is XX936XXXXXX

    36 means my phone was made in the 36th week of 2009. supposedly they started updating the bootloader at 940. so long as 939 and lower, everything should work for your 3gs.

    just make sure you have 3.1.3 shsh saved just in case you fuckup and have to downgrade to try again.
    2010-06-30 05:03 AM
  16. aznboii's Avatar
    i have bootloader 6.4 is this new or old?

    Thanks
    2010-06-30 07:14 AM
  17. FreeApple's Avatar
    To anybody who needed to downgrade without SSH on windows you have to download the file such as 3.1.2 go into itunes where you see the restore button...Now hold down the shift "or ctrl" button and right click it should bring up a browser to find the file you want to downgrade too. find it click ok and your on your way! Dont forget to hit the thanks button folks!
    2010-07-04 06:07 PM
LINK TO POST COPIED TO CLIPBOARD