1. dotFIVE's Avatar
    I have a 3GS on 3.1.3, new bootrom, no SHSH on Cydia (only 4.1). I bought this phone used so I have no idea what it was jailbroken with. I was wondering if:

    1) The new pwnage works on the new bootrom
    2) If I can use the new pwnage to update my phone to like 4.0.2 or something as I have 4.1 redsn0w on my iPod Touch 2G and there are some app bugs with 4.1, like SBSettings (not being able to play music on a dock)
    3) I bought a new AT&T SIM from Amazon that is unactivated; I use T-Mobile but would this new SIM activate my phone? I don't want to hacktivate and get push/YouTube issues.

    I'm really happy on 3.1.3 as everything runs flawlessly but I am missing a couple of apps that are 4.0 only. I'm not sure if I should risk the upgrade or not..

    I rely on an unlock so I don't want to have problems upgrading and then get stuck with no unlock.
    Last edited by dotFIVE; 2010-10-20 at 11:18 PM.
    2010-10-20 11:14 PM
  2. z6joker9's Avatar
    1) Yes
    2) Not sure. It specifically says it's for 4.1 but they may build in older firmware support.
    3) Try it and if it doesn't work, go back and hacktivate. Worst case you lose 15 minutes.

    I would highly recommend going straight to 4.1. Some apps may have bugs but fixes are rolled out quite fast. 4.x is worth the risk, but in general, it's pretty easy to do. Just remember to NEVER upgrade/restore using the standard iTunes method, as that will upgrade your baseband and cause a loss of unlock until the next ultrasnow is released. Upgrading through pwnagetool will maintain your existing baseband, so always upgrade using pwnage.
    2010-10-20 11:33 PM
  3. i.Annie's Avatar
    The deactivated SIM will work fine. Seen tons of people do it that way.

    As for your iPT 2G, Greenpois0n will work fine on it now so you can stop dealing with the buggy redsn0w.
    Last edited by i.Annie; 2010-10-20 at 11:39 PM. Reason: Automerged Doublepost
    2010-10-20 11:39 PM
  4. dotFIVE's Avatar
    So it doesn't matter which method the previous owner used to jailbreak? I don't have to download jbme2pwn or spirit2pwn?
    2010-10-20 11:40 PM
  5. i.Annie's Avatar
    For your 3GS? That I'm pretty sure doesn't matter anymore. I could be wrong, but it wouldn't hurt to try. Cuz it's not like you can install jbme2pwn for your new boot phone, it'll wreck your phone anyway.
    2010-10-20 11:41 PM
  6. dotFIVE's Avatar
    Yeah on my 3GS. Okay that sounds good as I wouldn't know which to install anyway since I don't know which jailbreak was used.

    So I can go for the shift + restore to the custom firmware on my already jailbroken 3.1.3? No need for a fresh firmware? I just want to make sure old, unnecessary jb files won't be hidden within.
    Last edited by dotFIVE; 2010-10-20 at 11:54 PM.
    2010-10-20 11:48 PM
  7. i.Annie's Avatar
    Yes, that should be fine.
    2010-10-21 12:04 AM
  8. varunshariharan's Avatar
    Hey there. I've got a 3GS on 4.0.1 BB 05.13.04. I know I can use the latest pwnage tool to jailbreak(using custom firmware) and since my baseband is preserved, I can go into cydia and ultrasn0w to preserve unlock. Here's my question : are there any known issues (dfu, recovery loop) that I need to watch out for? I don't wanna regret doing anything stupid. I have a mac running os x 10.6.4 with latest version of iTunes. Any problem I may encounter. Sorry for the trouble. But I'm crazy scared that I might do something wrong.
    2010-10-21 10:18 PM
  9. i.Annie's Avatar
    If you do everything right, you shouldn't have too much trouble. That isn't guaranteed, sometimes things just don't go right. It's a risk we all take when we jb our phones. USUALLY things go fine tho
    2010-10-21 10:32 PM
  10. dotFIVE's Avatar
    Hey there. I've got a 3GS on 4.0.1 BB 05.13.04. I know I can use the latest pwnage tool to jailbreak(using custom firmware) and since my baseband is preserved, I can go into cydia and ultrasn0w to preserve unlock. Here's my question : are there any known issues (dfu, recovery loop) that I need to watch out for? I don't wanna regret doing anything stupid. I have a mac running os x 10.6.4 with latest version of iTunes. Any problem I may encounter. Sorry for the trouble. But I'm crazy scared that I might do something wrong.
    I was in the same boat as you when I typed up those messages above you. I made sure that user-error was eliminated by updating to iTunes 10.0.1 and following Pwnage's directions very carefully. I have no SHSHs on file so it was risky for me.

    In the end, I finally took the leap of faith and I'm glad I did. 4.1 is legit! It all went smoooooothly. Go for it man, you won't regret it.
    2010-10-21 10:38 PM
LINK TO POST COPIED TO CLIPBOARD