1. misterdobi's Avatar
    I'm trying to upgrade my iPhone4 to iPhone3,1_4.3.3_8J2_Restore.ipsw using this link iClarified - iPhone - How to Jailbreak Your iPhone 4 Using PwnageTool (Mac) [4.3.3] .

    Using the link on the iclarified page gives me PwnageTool 4.3.3. That gave me the message "Wrong firmware bundle selected" .

    I then tried to find a newer version, 4.3.3.1. Also not working.

    Is something wrong with my computer or am I downloading the wrong files?

    Thanks
    2011-05-29 08:26 AM
  2. j3st3r's Avatar
    did you get your ipsw's from apple (are they official ipsws) if not that is the problem, there are links in the download section of this forum that will allow you to download official firmwares
    2011-05-30 07:12 AM
  3. misterdobi's Avatar
    I got it from iClarified's link from that page. I will try it now from the Downloads section of the forum.

    Update:
    I just checked iClarified's link and I think it is from the Apple official ipsws. http://appldnld.apple.com/iPhone4/04...2_Restore.ipsw .

    Is that correct?
    Last edited by misterdobi; 2011-05-30 at 07:30 AM.
    2011-05-30 07:18 AM
  4. j3st3r's Avatar
    if you got it from the iclarified link then that is an official firmware, you can try redownloading and disabling any antivirus before the download
    2011-05-30 07:30 AM
  5. misterdobi's Avatar
    Thanks I got it. Something was wrong with my downloading manager.

    Only PwnageTool retains your baseband, right? redsn0w and others will update the baseband? I'm asking because I need the unlock on this iPhone.
    2011-05-30 07:03 PM
  6. j3st3r's Avatar
    correct, pwnagetool will preserve your baseband
    2011-05-31 11:33 AM
LINK TO POST COPIED TO CLIPBOARD