User Tag List

  1. Radfone's Avatar
    Hey guys need help......I have an Iphone 2G windows on tmobile. was running 2.2 with no problems.........upgraded yesterday to 3.0 using redsnow, just jail break no unlock....seemed like everything was working fine but could not use edge. no internet no email. although wifi was working fine. so I reran redsnow, this time wiped everything clean on Itunes (restore to original settings) and then JB and unlocked again (lost all my programs this time)and exactly the same thing...edge not working error says"could not activate cellular data network: you are not subscribed to a cellular data service" Can ANYONE figure this out???
    2009-06-23 04:07 AM
  2. jeffreyfu's Avatar
    I had the same problem but fixed it by installing APN editing. Go to Cydia and search for "APN Editing". Install it and go to Setting->General->Network->Cellular Data Network(which is added by APN editing). Enter your APN setting. For AT&T,
    APN:wap.cingular
    Username:[email protected]
    Password:CINGULAR1

    Reboot and it should work.
    2009-06-23 03:35 PM
  3. Shinner23's Avatar
    I had the same problem. It ended up working, several hours later. I THINK what caused it was SBSettings-the "Edge" toggle was off. Really stupid, I know, but I didn't have the "Edge" toggle set up to be on the main SBSettings screen, so I never thought to look at it. Check it. But also, in Settings-General-Network-APN-make sure to put epc.tmobile.com or internet2.voicestream.com
    2009-06-23 03:46 PM
  4. namrepus_ohm's Avatar
    hi everyone! i also have some problem with my apn. i have upgraded to OS 3.0, jailbroken it and installed APN Editing. But when i go to settings/network there is no cellular data network only the vpn. Is Apn Editing not working on 3.0? hope someone can help me or give some advice. i have a softbank network japan. thanks and Godbless
    2009-06-29 10:29 PM
  5. xprtrdr's Avatar
    I am also having the same issue. I have a 2G iphone AT&T no data plan. Worked fine before 3.0. Now I get "Could not activate cellualr data network: You are not subscribed to a cellular data service". WIFI works fine. I go to Setting->General->Network-> I dont have any cellular data options available. I also tried to install APN editor and it did not make these setting available. Do you guys have any idea how to fix this?
    2009-07-03 07:56 AM
  6. MetallicaFan1991's Avatar
    If you had EDGE turned off and backed up your iPhone and then restored from the backup, you will get that error.

    To renable EDGE, get Sbsettings and use the EDGE toggle, should work, worked for me anyway.

    If you don't have the ability to change Cellular Data, go to General and Reset Network Settings. Also the settings only appear for certain carriers and depends on sim
    Last edited by MetallicaFan1991; 2009-07-03 at 01:44 PM.

    MBP 15" 2.66Ghz Core 2 Duo Nvidia 9400M 9600GT 256MB OS X 10.6.4 Windows 7 June 2009
    iPhone 4 August 28th
    2009-07-03 01:41 PM
  7. yungsavage157's Avatar
    My method does not require a jailbreak. I made a mobile configuration file for my iPhone 3G in order to change my APN. It is much safer than a custom .ipcc or a manual change. (due to human error of course, and its easier to apply, no iTunes needed to apply it.)

    So what you need to do is download a program called “iPhone Configuration Utility”. Its a free download from Apple.com.

    There is a very serious issue though. It seems that Apple has not updated their utility so that you can connect an iPhone 3.0 device to it and apply a configuration file directly via USB. You can however email it to yourself and then tap on it on your iPhone to activate and install the new configuration file.

    Set the APN to:

    APN: wap.cingular
    Username: [email protected]
    Password: CINGULAR1

    Now export the .mobileconfig file via an e-mail and email it to yourself. Now go to your Mail application on your iPhone and open the message you mailed yourself, now, tap on the attachment and install the file!

    Or, I guess, if you want… you can go to a website and bypass the long installation/creation process explained by my previous method. Just go to

    Unlockit - APN Changer for your iPhone

    on your iPhone, now just enter the apn data that I provided above where the website indicates. Just copy and paste it in. (or you can tap on the selector, the thing that says “blank”, the thing that is under the APN inputs, and select your carrier.) Now just tap on “create custom profile” and then it will exit Safari, and take you to the settings application. Now just tap on “install” and you are done. (Installing a profile may take up to 30 seconds, do not exit the menu until it is done installing or you will have a very corrupted carrier file.

    There you go! Now you have full 3G and EDGE capabilities. This took me about a minute to figure out that it was an issue with the APN information Apple provided in the AT&T 4.0 bundle. So I used a method that I used to use to prevent data usage and just did the opposite and re-enabled data usage.

    This is 100% safe! Just make sure you type the APN correctly and you should be fine. Just reboot after you have done this if you still don’t have a connection. I didn’t need to reboot, but you know, just in case. Don’t forget to spread te word and tell everybody you know that has a GoPhone Prepaid iPhone so that they can have uninterrupted service.
    Last edited by yungsavage157; 2009-07-05 at 09:02 AM. Reason: Automerged Doublepost/ and solved problem
    2009-07-05 08:59 AM
  8. Nikez87's Avatar
    I had the same problem for a while. My Cellular Data Network setting wasn't showing and I couldn't edit my APN.

    I went into Cydia, went to the Sections area and then selected 'Tweaks 3.0'. Then from there I installed 'T-Mobile AT EDGE EDIT'. I closed Cydia and restarted my iphone, went into settings ad it was there. Just plugged in my APN and I was good to go.
    2009-07-06 08:51 PM
  9. Blackstev08's Avatar
    I'm having the same problem....I've tried every fix I could find, and nothing has worked. My phone won't even ring when someone calls, but I can receive texts fine. Has anybody figured out a fix for this
    *the only replacement for displacement is boost!*

    *if its not boosted its not worth having*
    2009-07-13 03:56 PM
  10. albrevng's Avatar
    There is an easy way:
    - Reset "Network Settings" in Settings "over-the-air".
    2009-07-13 04:10 PM
  11. Blackstev08's Avatar
    I've done that......

    I sat on the phone with a tmobile rep for almost 2 hours yesterday going through all the troubleshooting. I can't get my edge to work at all and my phone never shows when someone is calling me. When I talked to the tmobile rep he said that it was showing that I was connected to voice, but it never connected to the data network. I put my sim card in my dash and it connected to the data network immediately, but as soon as i put it back in my iphone it wouldn't connect anymore.
    Last edited by Blackstev08; 2009-07-13 at 09:39 PM.
    *the only replacement for displacement is boost!*

    *if its not boosted its not worth having*
    2009-07-13 09:35 PM
  12. albrevng's Avatar
    Perform a clean install
    1. DFU and install Apple firmware iPhone 3.0
    2. Test the most important applications, Mail, Safari, SMS, WI-FI, etc. If everything is working.
    3. Jailbreak and then tests applications again.
    2009-07-14 12:51 AM
  13. Blackstev08's Avatar
    did that already too....I can't really test the apps first though because I'm on tmobile
    *the only replacement for displacement is boost!*

    *if its not boosted its not worth having*
    2009-07-14 03:33 AM
  14. maddawg05's Avatar
    I'm with ATT n just JB with 3.0. Now I have no signal, can't make calls or text. I was able to restore n all data n media there but no 3G n no bars. I have window vista. At this point I'm willing to go back to 2.2.1.

    I'm a newbie but what is APN n where do I get the APN info to put it into?
    Last edited by maddawg05; 2009-07-14 at 04:57 PM. Reason: Automerged Doublepost
    2009-07-14 04:57 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD