1. therugbyman's Avatar
    I have now downloaded the ipod touch firmware 2.2.1 three times from three different sites, and I keep getting an error message from redsn0w saying "Unable to recognize specified IPSW."
    I even tried to do it with QuickPWN, and I get this error message from all three versions of the firmware: "Firmware error string"
    Does anyone know what I am doing wrong?
    2009-06-24 02:42 AM
  2. williamjv's Avatar
    i'm not quite sure redsn0w works with 2.2.1 it was design for firmware 3.0 (i could be wrong) also, i've seen that error when you try loading a "custom firmware" and not the original firmware.
    There're never enough iPhone Mods
    If anything I said helped you, Please press the Thanks! button
    2009-06-24 02:58 AM
  3. bobbyalexander's Avatar
    redsn0w is not designed for 2.2.1. In its current form it works only with firmware version 3.0.
    For a detailed explanation checkout Discrete Vector: DIY: Updating iPhone 2G to OS 3.0 and unlocking using redsn0w
    Last edited by bobbyalexander; 2009-12-15 at 12:28 PM. Reason: Url change
    2009-06-24 12:03 PM
  4. Salamis's Avatar
    so what can I use to jailbreak 2.2.1? It's my uncle's 2g ipod and 32gb
    2009-07-28 04:27 AM
  5. NeoNightmareX's Avatar
    Here is a guide on how to do it. It is kind of lengthy but I wouldn't know of a shorter version since I don't own an iPod Touch:
    iClarified - iPod touch - How to Jailbreak Your 2G iPod Touch (Windows)

    There are links for the necessary files in the tutorial at the beginning. They are the bold words.
    If I helped you, then hit the "Thanks!" button please.

    I can't find Cydia on app store
    2009-07-28 05:23 AM
  6. bobbyalexander's Avatar
    so what can I use to jailbreak 2.2.1? It's my uncle's 2g ipod and 32gb
    Read the post. You have to upgrade to 3.0 first and then jailbreak it.
    2009-07-28 06:31 AM
  7. Salamis's Avatar
    Read the post. You have to upgrade to 3.0 first and then jailbreak it.
    I DON'T want to upgrade to 3.0 though.
    2009-07-28 07:02 PM
  8. bobbyalexander's Avatar
    I DON'T want to upgrade to 3.0 though.
    Then just use QuickPwn.
    2009-07-28 07:08 PM
  9. NeoNightmareX's Avatar
    Quickpwn doesn't work on a 2G iPod. BTW, did everyone just ignore my post above?
    If I helped you, then hit the "Thanks!" button please.

    I can't find Cydia on app store
    2009-07-28 07:15 PM
  10. angiepangie's Avatar
    LOL. Everyone check out Neo's post, it holds the answer
    I always feel sorry for the guy in the iPhone commercials. He always gets a call right in the middle of trying to do something
    2009-07-29 02:00 AM
  11. Salamis's Avatar
    Umm okay. Well when I jailbroke my sister's 2g ipod touch I remember that I just used 1 program that was a lot quicker than all of that. I can't remember the name though. Does anyone know any alternatives?
    2009-07-31 05:57 PM
LINK TO POST COPIED TO CLIPBOARD