1. Lynswin's Avatar
    Hi.

    I am trying to upgrade to 3.0 from 2.2 with red snow.
    I have followed the guide and restored in itunes.

    When I run redsnow, i get to the bit where I put my phone in DFU restore mode when the program crashes and says redsnow.exe has stopped working.

    After a search, I found some other people have had this problem in vista so I followed their instructions to change it into XP compatability mode and run as administrator but still no joy.
    I have rebooted my PC to but program just crahses when I get to this point.

    Now my phone won't even turn on and I am stuck.

    Just had a thought - I can run redsnow on my other PC which has XP on it but this PC doesn't have itunes or anything. Would it be possible just to do the unlock/jailbreak on the other PC without installing itunes etc?

    Please help.
    Many thanks
    Lynda
    Last edited by Lynswin; 2009-06-24 at 06:39 PM.
    2009-06-24 06:19 PM
  2. albrevng's Avatar
    Yeah!, some Windows users have had similar problem with redsn0w. I had the same problem, so I can use a MAC and everything is good.
    2009-06-24 07:22 PM
  3. Lynswin's Avatar
    Anyone? I am desperate!!

    I have tried it on the other computer but I get as far as putting in DFU mode and it says no phone recognised. I know it is there coz I hear the sounds and it comes up saying new hardware found etc.

    All I can get on my phone is the emergency calls screen.

    Keeps crashing on Vista.

    Please help.
    Thanks
    Lynda
    2009-06-24 10:03 PM
  4. albrevng's Avatar
    If you have access to a MAC, then do, mine works after using redsn0w v0.7.1. I'm good to rock!
    2009-06-24 10:35 PM
  5. Bo Troxell's Avatar
    Anyone? I am desperate!!

    I have tried it on the other computer but I get as far as putting in DFU mode and it says no phone recognised. I know it is there coz I hear the sounds and it comes up saying new hardware found etc.

    All I can get on my phone is the emergency calls screen.

    Keeps crashing on Vista.

    Please help.
    Thanks
    Lynda
    so many weird problems, sorry you guys are having such a bad time at this. You just have to keep trying and be calm it will work.
    If the phone is in dfu iTunes should recognize it. Not saying your doing it wrong but try one of these methods and I j
    hope it works for you.
    INSTRUCTIONS
    Step 1. Turn off iPhone
    Step 2. Hold down the power and home button.
    Step 3. When you see the Apple logo, release the power button but continue holding the home button down.
    Step 4. Open iTunes and wait for it to tell you that it’s in restore mode.

    Alternative Method:
    Step 1. Connect iPhone to USB then listen to the sound when it connect and disconnect.
    Step 2. Hold the home and power buttons until hear the disconnect sound then release power button.
    Step 3. Wait until you hear another sound then release home button.

    Good luck.
    2009-06-24 10:41 PM
  6. Lynswin's Avatar
    Hi blkcadi

    thanks for the reply. I have already tried the methods you suggested and still no joy.

    I thought maybe I should download itunes on the other comp i am using (win xp) but this didn't make any differenc, in fact, since downloading this redsnow is crashing on xp now too

    so to summarise, redsnow is now not running on visat or xp. someone mentioned redsnow 7.1 but i can't find a download for it.
    Is redsnow the only thing that will jailbreak AND unlock a 2G iphone on 3.0 fw?

    thanks again
    lynda
    2009-06-24 10:50 PM
  7. Bo Troxell's Avatar
    Hi blkcadi

    thanks for the reply. I have already tried the methods you suggested and still no joy.

    I thought maybe I should download itunes on the other comp i am using (win xp) but this didn't make any differenc, in fact, since downloading this redsnow is crashing on xp now too

    so to summarise, redsnow is now not running on visat or xp. someone mentioned redsnow 7.1 but i can't find a download for it.
    Is redsnow the only thing that will jailbreak AND unlock a 2G iphone on 3.0 fw?

    thanks again
    lynda
    yes, this is the only method available now. You could do a Google search and try to find 7.1. Not sure if that's the answer, but worth a try.
    2009-06-24 10:55 PM
  8. Lynswin's Avatar
    I tried your methods again The first method just seems to put it in to recovery mode, not DFU. Itunes just said I had a phone in recovery mode too. Redsnow says it is in recovery mode not dfu.

    The second method is a bit confusing. Should the phone be on or off when I first connect it?

    thanks
    Lynda

    I have tried the second method with the phone both on and off to start and neither works!! Redsnow just says 'no device detected'

    ARRRRRRRRRGGGGGHHHHHH!!!

    BTW, how can I tell if it is in dfu mode? is there something on the screen?

    Anyone? PLEASE!!!! I have a brick!!

    If I can't get 3.0 working how can I get back to 2.2 FW with itunes 8.2?

    Please help, my phone is unuseable at the moment, all I have is the emergency calls screen.

    Thanks

    Lynda

    OK, I have managed to sort this out.

    I have discovered that the reason for Redsnow crashing was due to putting a checkbox next to 'install icy'. If I just checked install Cydia & unlock then it works perfectly.

    I will put this in another thread in case anyone else is having problems.
    Last edited by Lynswin; 2009-06-25 at 10:36 AM. Reason: Automerged Doublepost
    2009-06-25 10:36 AM
  9. nylatin0's Avatar
    Try not checking the Icy option. That worked for me.
    2009-06-27 12:39 AM
  10. reddawg's Avatar
    Lynswin's problem with redsn0w.exe crashing during DFU process was solved by not selecting Icy. I never liked Icy anyhow.

    There have been many unresolved reports coming from people running 64-bit versions of Vista and Vista 32-bit systems. Below are steps how to disable User Access Control (UAC) and how to enable the real Administrator account in Microsoft Vista. Try the below steps and see if this helps resolve the Redsn0w.exe crashes or problems and report back your results.
    __________________________________________________ ___________________________________

    How to enable the Vista Administrator account

    1. From the Start menu, simply right-click on Computer and choose Manage.
    2. Next, expand Local Users and Groups and select the Users folder.
    3. The final step is to right-click on the Administrator login and choose properties. Clear the Account is Disabled checkbox and you have now enabled your Administrator account.
    4. Logout and then back in as the true Administrator account and see if Redsn0w works properly

    Make sure you disable the Administrator account when finished.

    How to disable User Account Control (UAC) on Windows Vista

    Method #1 - Using MSCONFIG
    1. Launch MSCONFIG by from the Run menu.
    2. Click on the Tools tab. Scroll down till you find "Disable UAC" . Click on that line.

    Method #2 - Using Search bar
    1. The easy solution is through Control Panel.
    2. Type "UAC" into the search bar at the top of the screen and you'll see this task presented:

      Turn User Account Control (UAC) on or off

    If neither work by themselves, try both together. Make sure you disable the true Administrator account and re-enable UAC when done.
    Last edited by reddawg; 2009-06-27 at 10:51 AM.
    2009-06-27 03:07 AM
  11. Bimmerman's Avatar
    tried all of the above but still no help, is there any other way to get around with this errors, thanks guys
    2009-06-28 02:42 PM
  12. DJ Bless One's Avatar
    Try right clicking on redsnow.exe, properties, and select "unlock". Then try again. It worked for me.
    2009-07-22 08:56 PM
  13. brian1305's Avatar
    usé esta información
    y me funcionó perfecto
    pero tenia el mismo problema que ví por ahí!..


    G R A C I A S
    2009-08-03 09:59 AM
  14. dcrombie's Avatar
    Try not checking the Icy option. That worked for me.
    Thanks, your advice really worked for me.
    I was using Redsn0w .8 for 2G on Vista 32...it was crashing at DFU mode...Glad my iPhone has 3.01 and it's working.
    2009-08-08 05:01 PM
  15. 7mariam7's Avatar
    when you r at the turn off and plug in part in redsnow
    try taking the usb out, put it back in
    then with ur usb pluggd in off ur ipod
    then carry on
    2009-09-06 02:57 AM
  16. osiarap's Avatar
    Works fine if you don't select Icy.
    2009-09-07 04:52 AM
  17. CaptainChaos's Avatar
    I had the same issue, but I used recovery mode instead of DFU mode.
    2009-09-07 06:42 AM
LINK TO POST COPIED TO CLIPBOARD