1. soundengineer's Avatar
    iphone 2G
    Using T-mobile
    I installed firmware for 3.0
    used Redsnow to do the jailbreak and unlock
    trying to find the settings page for mms...
    I dont seem to have picture messaging capabilities for some reason..
    I have a carrier settings page...but nothing for mms setting on it...just cellular data only

    what am I missing or doing wrong that I dont have an mms settings section and I dont seem to have anything in the messaging app to send pic messages with..
    2009-06-26 10:47 AM
  2. m2pilot's Avatar
    Apple did not choose to support MMS in 2G phones. Thus what you are seeing is entirely correct. Only 3G phones & 3GS phones get MMS.
    2009-06-26 06:16 PM
  3. williamjv's Avatar
    I dont think the MMS settings are included on 3.0 for ATT network either. I know MMS hasnt been enabled by ATT yet but i do not see any MMS settings on my phone either. (3G on 3.0 jailbroken) I'm assuming another update may be release once MMS is finally enabled.
    There're never enough iPhone Mods
    If anything I said helped you, Please press the Thanks! button
    2009-06-26 07:20 PM
  4. WingHack's Avatar
    There is now a package available in Cydia: ActiveMMS2G
    That should sort it out, though some people are reporting that it did not work for them.
    Worked like a charm on my phone. Install, reboot, then go to settings/messages and enable MMS. You'll see a little camera in your messages app.

    cheers
    2009-06-28 08:54 PM
  5. williamjv's Avatar
    There is now a package available in Cydia: ActiveMMS2G
    That should sort it out, though some people are reporting that it did not work for them.
    Worked like a charm on my phone. Install, reboot, then go to settings/messages and enable MMS. You'll see a little camera in your messages app.

    cheers
    Hoping this would work on my iPhone 3G since I do not get the "enable MMS" under the messages setting (even after upgrading to 3.0) I went ahead and installed the ActiveMMS2G into my phone knowing it says 2G at the end of the package... Well my phone has gone on a rebooting loop not getting passed the Apple bootup logo... so if you have a 3G phone dont make the same mistake i did hey someone had to do it in order to find out what would happened right? LOL

    Gotta restore my phone now (whack)
    There're never enough iPhone Mods
    If anything I said helped you, Please press the Thanks! button
    2009-06-29 04:55 PM
  6. seaeagle's Avatar
    iPhone 3g 3.0 used redsnow to jailbreak. Now no mms setting. It was there before jailbreak. Do we wait for quickpwn?
    It's not me ... it's THEM
    2009-06-30 10:21 AM
  7. johnnylavah's Avatar
    There is now a package available in Cydia: ActiveMMS2G
    That should sort it out, though some people are reporting that it did not work for them.
    Worked like a charm on my phone. Install, reboot, then go to settings/messages and enable MMS. You'll see a little camera in your messages app.

    cheers
    are u on a 1st generation (2g) iphone?
    2009-07-01 07:38 AM
  8. WingHack's Avatar
    Yes, my phone is 2G.

    (Now if your carrier doesn't support MMS that's another problem.)
    2009-07-06 09:07 AM
  9. johnnylavah's Avatar
    Yes, my phone is 2G.

    (Now if your carrier doesn't support MMS that's another problem.)
    i got it working...and it works great! thanks!
    2009-07-06 10:56 PM
  10. tbanuelos's Avatar
    the same thing happened to me that happened to williamjv and i had to redo my phone like 4 or 5 times because after that i had a problem that my phone kept saying no service and it would never get a signal.


    i just changed over to 3.0 software recently...still learning :-)
    2009-07-27 02:33 AM
  11. nix4m's Avatar
    i didi not have mms too. but i have 3g. why is that. ive tried many times but nothing happens. other thing is ok. is it happen cause of network or the country. reply me ([email protected])please.
    2009-08-19 01:54 PM
  12. John1177's Avatar
    I have tried to download this app several times and I get the following message in a square box middle of screen: "netdb open nodename nor server name provided or not known. option to click "ok". when click ok another box comes up. at top of it it has ispaziorepo.com at the top of the box, then the same message as above..any suggestions. I really want MMS on my
    2g phone
    2009-08-19 05:20 PM
  13. watersports500@gmail.com's Avatar
    iphone 2G
    Using T-mobile
    I installed firmware for 3.0
    used Redsnow to do the jailbreak and unlock
    trying to find the settings page for mms...
    I dont seem to have picture messaging capabilities for some reason..
    I have a carrier settings page...but nothing for mms setting on it...just cellular data only

    what am I missing or doing wrong that I dont have an mms settings section and I dont seem to have anything in the messaging app to send pic messages with..
    Got this from T-Mobile
    Here are those settings for you Apple iPhone in case you have trouble accessing the internet again in the future.

    From the Main Menu select Settings > General > Network
    Verify that Data Roaming is set to On
    Verify that 3G Enable is set to Off
    Verify that Wi-Fi is set to Off
    Select Cellular Data Network
    In the APN field, enter internet2.voicestream.com
    Leave the Username and Password fields blank
    To test connection, open up Safari and browse to a website.

    Here are the settings for the Apple iPhone Picture Settings:
    From the Main Menu select Settings > General > Network
    Select Cellular Data Network
    In the MMS APN field, enter wap.voicestream.com
    Leave the Username and Password fields blank
    In the MMSC field, enter http://216.155.174.84/servlets/mms
    In the Proxy field, enter 216.155.165.050:8080
    Leave the Max Sending Size and MMS UA PROF URL fields blank
    To test the picture messaging, restart the iPhone and then create a new message, select the camera icon and try sending a picture message

    Thank you for being a T-Mobile Customer and have a wonderful day!
    2009-08-19 06:10 PM
LINK TO POST COPIED TO CLIPBOARD